Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчёт кол-ва смен/часов до определённой даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт кол-ва смен/часов до определённой даты (Формулы/Formulas)
подсчёт кол-ва смен/часов до определённой даты
TanyaZorina Дата: Суббота, 09.04.2016, 23:01 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
подскажите пожалуйста формулы которые ответят на вопросы: подсчёт кол-во оставшихся смен от текущей даты до отпуска в часах и сменах, чтобы количество изменялось по истечению времени. Файлик прилагаю.
К сообщению приложен файл: _Microsoft_Offi.xlsx(11Kb)


Сообщение отредактировал TanyaZorina - Суббота, 09.04.2016, 23:12
 
Ответить
Сообщениеподскажите пожалуйста формулы которые ответят на вопросы: подсчёт кол-во оставшихся смен от текущей даты до отпуска в часах и сменах, чтобы количество изменялось по истечению времени. Файлик прилагаю.

Автор - TanyaZorina
Дата добавления - 09.04.2016 в 23:01
StoTisteg Дата: Суббота, 09.04.2016, 23:07 | Сообщение № 2
Группа: Авторы
Ранг: Ветеран
Сообщений: 541
Репутация: 45 ±
Замечаний: 0% ±

Excel 2010
TanyaZorina, в Вашем примере —
Код
СЧЁТЗ(A2:A11)
:D


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
СообщениеTanyaZorina, в Вашем примере —
Код
СЧЁТЗ(A2:A11)
:D

Автор - StoTisteg
Дата добавления - 09.04.2016 в 23:07
TanyaZorina Дата: Суббота, 09.04.2016, 23:13 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
СЧЁТЗ(A2:A11)

это не то(
 
Ответить
Сообщение
СЧЁТЗ(A2:A11)

это не то(

Автор - TanyaZorina
Дата добавления - 09.04.2016 в 23:13
buchlotnik Дата: Суббота, 09.04.2016, 23:24 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так что ли?
Код
=СУММПРОИЗВ(((--ЛЕВСИМВ(A2:A15;10))>=B2)*((--ЛЕВСИМВ(A2:A15;10))<C2))
К сообщению приложен файл: 3756563.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак что ли?
Код
=СУММПРОИЗВ(((--ЛЕВСИМВ(A2:A15;10))>=B2)*((--ЛЕВСИМВ(A2:A15;10))<C2))

Автор - buchlotnik
Дата добавления - 09.04.2016 в 23:24
gling Дата: Суббота, 09.04.2016, 23:38 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Может так подойдет?
Код
=СУММПРОИЗВ((--ЛЕВСИМВ(A2:A11;10)>=B2)*(--ЛЕВСИМВ(A2:A11;10)<C2))
К сообщению приложен файл: 3860397.xlsx(12Kb)
 
Ответить
СообщениеМожет так подойдет?
Код
=СУММПРОИЗВ((--ЛЕВСИМВ(A2:A11;10)>=B2)*(--ЛЕВСИМВ(A2:A11;10)<C2))

Автор - gling
Дата добавления - 09.04.2016 в 23:38
buchlotnik Дата: Суббота, 09.04.2016, 23:39 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
gling, так а я о чём! :D


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеgling, так а я о чём! :D

Автор - buchlotnik
Дата добавления - 09.04.2016 в 23:39
gling Дата: Воскресенье, 10.04.2016, 00:07 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Инет тормозит наверно. Когда отвечал, ответа кроме моего не было. Бывает.
 
Ответить
СообщениеИнет тормозит наверно. Когда отвечал, ответа кроме моего не было. Бывает.

Автор - gling
Дата добавления - 10.04.2016 в 00:07
TanyaZorina Дата: Воскресенье, 10.04.2016, 11:50 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
=СУММПРОИЗВ((--ЛЕВСИМВ(A2:A11;10)>=B2)*(--ЛЕВСИМВ(A2:A11;10)<C2))

формула подходит)) объясните пожалуйста её что то понять не могу, в частности как работает ЛЕВСИМВ girl_smile


Сообщение отредактировал TanyaZorina - Воскресенье, 10.04.2016, 11:53
 
Ответить
Сообщение
=СУММПРОИЗВ((--ЛЕВСИМВ(A2:A11;10)>=B2)*(--ЛЕВСИМВ(A2:A11;10)<C2))

формула подходит)) объясните пожалуйста её что то понять не могу, в частности как работает ЛЕВСИМВ girl_smile

Автор - TanyaZorina
Дата добавления - 10.04.2016 в 11:50
gling Дата: Воскресенье, 10.04.2016, 12:02 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Посмотрите справку про ЛЕВСИМВ(). ЛЕВСИМВ(текст;количество символов (начиная с первого)), можно еще использовать ПСТР()
Код
=СУММПРОИЗВ((--ПСТР(A2:A11;1;10)>=B2)*(--ПСТР(A2:A11;1;10)<C2))
Сложнее понять как работает СУММПРОИЗ()-она из каждой ячейки массива A2:A11 выделяет ЛЕВСИМ и сравнивает с В2. А работу ЛЕВСИМВ() просмотрите на примере одной ячейки, чтобы понять.


Сообщение отредактировал gling - Воскресенье, 10.04.2016, 12:17
 
Ответить
СообщениеПосмотрите справку про ЛЕВСИМВ(). ЛЕВСИМВ(текст;количество символов (начиная с первого)), можно еще использовать ПСТР()
Код
=СУММПРОИЗВ((--ПСТР(A2:A11;1;10)>=B2)*(--ПСТР(A2:A11;1;10)<C2))
Сложнее понять как работает СУММПРОИЗ()-она из каждой ячейки массива A2:A11 выделяет ЛЕВСИМ и сравнивает с В2. А работу ЛЕВСИМВ() просмотрите на примере одной ячейки, чтобы понять.

Автор - gling
Дата добавления - 10.04.2016 в 12:02
TanyaZorina Дата: Воскресенье, 10.04.2016, 12:10 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Посмотрите справку про ЛЕВСИМВ(). ЛЕВСИМВ(текст;количество символов (начиная с первого)), можно еще использовать ПСТР()

спасибо) почитаем
 
Ответить
Сообщение
Посмотрите справку про ЛЕВСИМВ(). ЛЕВСИМВ(текст;количество символов (начиная с первого)), можно еще использовать ПСТР()

спасибо) почитаем

Автор - TanyaZorina
Дата добавления - 10.04.2016 в 12:10
buchlotnik Дата: Воскресенье, 10.04.2016, 18:23 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ну тогда уж и самый короткий вариант:
Код
=СУММПРОИЗВ(((--ЛЕВБ(A2:A15;10))>=B2)*((--ЛЕВБ(A2:A15;10))<C2))
только справку по ЛЕВБ не ищите, работает она как ЛЕВСИМВ B)
К сообщению приложен файл: 4511357.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениену тогда уж и самый короткий вариант:
Код
=СУММПРОИЗВ(((--ЛЕВБ(A2:A15;10))>=B2)*((--ЛЕВБ(A2:A15;10))<C2))
только справку по ЛЕВБ не ищите, работает она как ЛЕВСИМВ B)

Автор - buchlotnik
Дата добавления - 10.04.2016 в 18:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт кол-ва смен/часов до определённой даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!