Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по частичному совпадению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по частичному совпадению (Формулы/Formulas)
Поиск значения по частичному совпадению
totus77 Дата: Понедельник, 11.04.2016, 00:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте!
Помогите пжл подобрать формулу для поиска части значения на одном листе и перенос всего значения на другой!
Пример: на Листе1 в столбце А Row Labels есть целые значения
на Листе2 в колонке С Number есть только номера из цельных значений со столбца А на Листе1
Какую нужно прописать формулу в столбец С Листа2 для автоматического поиска и переноса всех данных (столбец D - столбец H) с Листа1
Надеюсь ясно изложил суть вопроса :)
К сообщению приложен файл: 4917917.xlsx(10Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите пжл подобрать формулу для поиска части значения на одном листе и перенос всего значения на другой!
Пример: на Листе1 в столбце А Row Labels есть целые значения
на Листе2 в колонке С Number есть только номера из цельных значений со столбца А на Листе1
Какую нужно прописать формулу в столбец С Листа2 для автоматического поиска и переноса всех данных (столбец D - столбец H) с Листа1
Надеюсь ясно изложил суть вопроса :)

Автор - totus77
Дата добавления - 11.04.2016 в 00:48
buchlotnik Дата: Понедельник, 11.04.2016, 00:56 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
как-то так
Row Label:
Код
=ЕСЛИ(ЕЧИСЛО(C6);ПРОСМОТР(2;ПОИСК(C6;Лист1!$A$5:$A$9);Лист1!$A$5:$A$9);"")

значения:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$5:$E$9;ПОИСКПОЗ($D6;Лист1!$A$5:$A$9;0);ПОИСКПОЗ(E$5;Лист1!$B$4:$E$4;0));"")

нули убраны форматом 0,00;-0,00;;
К сообщению приложен файл: 4526706.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениекак-то так
Row Label:
Код
=ЕСЛИ(ЕЧИСЛО(C6);ПРОСМОТР(2;ПОИСК(C6;Лист1!$A$5:$A$9);Лист1!$A$5:$A$9);"")

значения:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$5:$E$9;ПОИСКПОЗ($D6;Лист1!$A$5:$A$9;0);ПОИСКПОЗ(E$5;Лист1!$B$4:$E$4;0));"")

нули убраны форматом 0,00;-0,00;;

Автор - buchlotnik
Дата добавления - 11.04.2016 в 00:56
_Boroda_ Дата: Понедельник, 11.04.2016, 07:45 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно одинаковую формулу для всех 5-и столбцов
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$5:A$9;ПОИСКПОЗ("["&$C6&"]*";Лист1!$A$5:$A$9;));"")
К сообщению приложен файл: 4917917_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно одинаковую формулу для всех 5-и столбцов
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$5:A$9;ПОИСКПОЗ("["&$C6&"]*";Лист1!$A$5:$A$9;));"")

Автор - _Boroda_
Дата добавления - 11.04.2016 в 07:45
Nic70y Дата: Понедельник, 11.04.2016, 07:52 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
для разнообразия
Код
=ЕСЛИОШИБКА(ВПР("*"&$C6&"*";Лист1!$A$5:$E$9;СТОЛБЕЦ(A1););"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениедля разнообразия
Код
=ЕСЛИОШИБКА(ВПР("*"&$C6&"*";Лист1!$A$5:$E$9;СТОЛБЕЦ(A1););"")

Автор - Nic70y
Дата добавления - 11.04.2016 в 07:52
totus77 Дата: Понедельник, 11.04.2016, 23:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем добрый день!
Коллеги, огромное спасибо за помощь! Это то что нужно yes
 
Ответить
СообщениеВсем добрый день!
Коллеги, огромное спасибо за помощь! Это то что нужно yes

Автор - totus77
Дата добавления - 11.04.2016 в 23:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по частичному совпадению (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!