Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/создать формулу, чтобы выбирала предыдущую позицию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создать формулу, чтобы выбирала предыдущую позицию (Формулы/Formulas)
создать формулу, чтобы выбирала предыдущую позицию
zaak88 Дата: Понедельник, 11.04.2016, 11:42 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Доброго всем дня, друзья! Помогите, пожалуйста, на листе факт отгрузки в столбце С сделал подбор из справочника. Нужно. чтобы - если в справочнике нет позиции - выводилась предыдущая. Спасибо! И если можно, то здесь уточнить - в столбце D функция ВПР подбирает неверные значения.
К сообщению приложен файл: 2163458.xlsx(22Kb)
 
Ответить
СообщениеДоброго всем дня, друзья! Помогите, пожалуйста, на листе факт отгрузки в столбце С сделал подбор из справочника. Нужно. чтобы - если в справочнике нет позиции - выводилась предыдущая. Спасибо! И если можно, то здесь уточнить - в столбце D функция ВПР подбирает неверные значения.

Автор - zaak88
Дата добавления - 11.04.2016 в 11:42
Roman777 Дата: Понедельник, 11.04.2016, 11:58 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 700
Репутация: 75 ±
Замечаний: 20% ±

Excel 2007, Excel 2013
zaak88, что имеется в виду предыдущая? Предыдущая в справочнике... или в текущей таблице... если в текущей таблице, что если нет самого первого значения?


Много чего не знаю!!!!
 
Ответить
Сообщениеzaak88, что имеется в виду предыдущая? Предыдущая в справочнике... или в текущей таблице... если в текущей таблице, что если нет самого первого значения?

Автор - Roman777
Дата добавления - 11.04.2016 в 11:58
zaak88 Дата: Понедельник, 11.04.2016, 12:10 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Roman777, в самой таблице, первое значение будет по определению (выгрузка из 1С), а вот второе должно совпадать с первым, если не подбирается из справочника....
 
Ответить
СообщениеRoman777, в самой таблице, первое значение будет по определению (выгрузка из 1С), а вот второе должно совпадать с первым, если не подбирается из справочника....

Автор - zaak88
Дата добавления - 11.04.2016 в 12:10
Roman777 Дата: Понедельник, 11.04.2016, 12:38 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 700
Репутация: 75 ±
Замечаний: 20% ±

Excel 2007, Excel 2013
zaak88, Сразу со столбцом "D" и ВПР. Вы используете ВПР(), не указывая "интервальный просмотр" = 0. Когда мы его не указываем, то поиск происходит неточный. Для точного поиска необходимо указывать его равным 0:
Код
=ЕСЛИОШИБКА(ВПР($A3;спр!$A$6:$B$9;2;0);"ГК АТ")

А Вашу основную проблему, я бы примерно так решил:
Код
=ЕСЛИОШИБКА(ВПР(A3;спр!E:F;2;0);'Факт отгузки'!C2)

исправил...


Много чего не знаю!!!!

Сообщение отредактировал Roman777 - Понедельник, 11.04.2016, 12:40
 
Ответить
Сообщениеzaak88, Сразу со столбцом "D" и ВПР. Вы используете ВПР(), не указывая "интервальный просмотр" = 0. Когда мы его не указываем, то поиск происходит неточный. Для точного поиска необходимо указывать его равным 0:
Код
=ЕСЛИОШИБКА(ВПР($A3;спр!$A$6:$B$9;2;0);"ГК АТ")

А Вашу основную проблему, я бы примерно так решил:
Код
=ЕСЛИОШИБКА(ВПР(A3;спр!E:F;2;0);'Факт отгузки'!C2)

исправил...

Автор - Roman777
Дата добавления - 11.04.2016 в 12:38
zaak88 Дата: Понедельник, 11.04.2016, 13:28 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Roman777, спасибо большое, выручили!
 
Ответить
СообщениеRoman777, спасибо большое, выручили!

Автор - zaak88
Дата добавления - 11.04.2016 в 13:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создать формулу, чтобы выбирала предыдущую позицию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!