Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула подбора по нескольким критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула подбора по нескольким критериям (Формулы/Formulas)
Формула подбора по нескольким критериям
zaak88 Дата: Понедельник, 11.04.2016, 11:58 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Друзья, помогите, пожалуйста! Хотелось бы увидеть в столбце Y на листе отклонения подбор значения по городу, наименованию, и номеру недели из листа факт отгрузки, если город или наименование новое, то выводить отдельной строкой - спасибо!
К сообщению приложен файл: 7743582.xlsx(60Kb)


Сообщение отредактировал zaak88 - Понедельник, 11.04.2016, 11:58
 
Ответить
СообщениеДрузья, помогите, пожалуйста! Хотелось бы увидеть в столбце Y на листе отклонения подбор значения по городу, наименованию, и номеру недели из листа факт отгрузки, если город или наименование новое, то выводить отдельной строкой - спасибо!

Автор - zaak88
Дата добавления - 11.04.2016 в 11:58
ReAnima Дата: Понедельник, 11.04.2016, 12:44 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 8 ±
Замечаний: 20% ±

Excel 2013
Если верно понял, то
Код
=ЕСЛИОШИБКА(ИНДЕКС('Факт отгузки'!$A$3:$F$43;ПОИСКПОЗ(A4&отклонения!Y$2&B4;'Факт отгузки'!$C$3:$C$43&'Факт отгузки'!$D$3:$D$43&'Факт отгузки'!$F$3:$F$43;0);2);0)

Формула массива
К сообщению приложен файл: 6712800.xlsx(61Kb)
 
Ответить
СообщениеЕсли верно понял, то
Код
=ЕСЛИОШИБКА(ИНДЕКС('Факт отгузки'!$A$3:$F$43;ПОИСКПОЗ(A4&отклонения!Y$2&B4;'Факт отгузки'!$C$3:$C$43&'Факт отгузки'!$D$3:$D$43&'Факт отгузки'!$F$3:$F$43;0);2);0)

Формула массива

Автор - ReAnima
Дата добавления - 11.04.2016 в 12:44
ReAnima Дата: Понедельник, 11.04.2016, 12:51 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 8 ±
Замечаний: 20% ±

Excel 2013
еще вариант, немассивная формула:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/('Факт отгузки'!$D$3:$D$43=Y$2)/('Факт отгузки'!$C$3:$C$43=A4)/('Факт отгузки'!$F$3:$F$43=B4);'Факт отгузки'!$B$3:$B$43);0)
 
Ответить
Сообщениееще вариант, немассивная формула:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/('Факт отгузки'!$D$3:$D$43=Y$2)/('Факт отгузки'!$C$3:$C$43=A4)/('Факт отгузки'!$F$3:$F$43=B4);'Факт отгузки'!$B$3:$B$43);0)

Автор - ReAnima
Дата добавления - 11.04.2016 в 12:51
_Boroda_ Дата: Понедельник, 11.04.2016, 13:46 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если несколько значений? Пример - Максим Экстрим
Предлагаю так
Код
=СУММЕСЛИМН('Факт отгузки'!$B$3:$B$43;'Факт отгузки'!$D$3:$D$43;Y$2;'Факт отгузки'!$C$3:$C$43;$A4;'Факт отгузки'!$F$3:$F$43;$B4)

Да и быстрее СУММЕСЛИМН
К сообщению приложен файл: 7743582_1.xlsx(58Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА если несколько значений? Пример - Максим Экстрим
Предлагаю так
Код
=СУММЕСЛИМН('Факт отгузки'!$B$3:$B$43;'Факт отгузки'!$D$3:$D$43;Y$2;'Факт отгузки'!$C$3:$C$43;$A4;'Факт отгузки'!$F$3:$F$43;$B4)

Да и быстрее СУММЕСЛИМН

Автор - _Boroda_
Дата добавления - 11.04.2016 в 13:46
zaak88 Дата: Понедельник, 11.04.2016, 13:53 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
ReAnima, спасибо, всё супер!!! очень благодарен!
 
Ответить
СообщениеReAnima, спасибо, всё супер!!! очень благодарен!

Автор - zaak88
Дата добавления - 11.04.2016 в 13:53
zaak88 Дата: Понедельник, 11.04.2016, 13:55 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
_Boroda_, в принципе, что-либо всегда уникально, или неделя, или препарат, или пункт. Спасибо большое тоже за помощь!
 
Ответить
Сообщение_Boroda_, в принципе, что-либо всегда уникально, или неделя, или препарат, или пункт. Спасибо большое тоже за помощь!

Автор - zaak88
Дата добавления - 11.04.2016 в 13:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула подбора по нескольким критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!