Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Динамический диапазон графика - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамический диапазон графика (Формулы/Formulas)
Динамический диапазон графика
neobodr Дата: Среда, 13.04.2016, 05:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Вопрос, как бы диапазон графика с координатами столбцов BE и CD сделать переменным, зависящим от количества заполненных строк столбца C или D, так как если продлить диапазон графика на пустые или с формулами ячейки, то разные линии графика начинают подтягиваться к одно оси X или Y, просто подписывая ось названиями одной из линий.
В примере можно это увидеть, удалив значения C13 и D13 или продлив диапазон графика на пустые пункты ниже.
К сообщению приложен файл: 4144893.xlsx(16Kb)
 
Ответить
СообщениеВопрос, как бы диапазон графика с координатами столбцов BE и CD сделать переменным, зависящим от количества заполненных строк столбца C или D, так как если продлить диапазон графика на пустые или с формулами ячейки, то разные линии графика начинают подтягиваться к одно оси X или Y, просто подписывая ось названиями одной из линий.
В примере можно это увидеть, удалив значения C13 и D13 или продлив диапазон графика на пустые пункты ниже.

Автор - neobodr
Дата добавления - 13.04.2016 в 05:46
Pelena Дата: Среда, 13.04.2016, 07:19 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Можно немного изменить формулы
Код
=ЕСЛИ(C4>0;(C4-C3)*$B$2+B3;НД())

а значения ошибки скрыть условным форматированием
К сообщению приложен файл: 4554740.xlsx(16Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно немного изменить формулы
Код
=ЕСЛИ(C4>0;(C4-C3)*$B$2+B3;НД())

а значения ошибки скрыть условным форматированием

Автор - Pelena
Дата добавления - 13.04.2016 в 07:19
buchlotnik Дата: Среда, 13.04.2016, 07:23 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно через именованные диапазоны
Код
=СМЕЩ(Лист1!$B$3;0;0;СЧЁТ(Лист1!$B$3:$B$17);1)
К сообщению приложен файл: 3323762.xlsx(16Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеможно через именованные диапазоны
Код
=СМЕЩ(Лист1!$B$3;0;0;СЧЁТ(Лист1!$B$3:$B$17);1)

Автор - buchlotnik
Дата добавления - 13.04.2016 в 07:23
neobodr Дата: Среда, 13.04.2016, 08:47 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, Подскажите, это получается где то вводиться формула для переменных x_1 и y_1. Где и как вводить переменные, подскажите плиз.
 
Ответить
Сообщениеbuchlotnik, Подскажите, это получается где то вводиться формула для переменных x_1 и y_1. Где и как вводить переменные, подскажите плиз.

Автор - neobodr
Дата добавления - 13.04.2016 в 08:47
Pelena Дата: Среда, 13.04.2016, 09:00 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
В диспетчере имен (Ctrl+F3)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ диспетчере имен (Ctrl+F3)

Автор - Pelena
Дата добавления - 13.04.2016 в 09:00
neobodr Дата: Среда, 13.04.2016, 09:20 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Спасибо, это то что я искал.
 
Ответить
СообщениеPelena, Спасибо, это то что я искал.

Автор - neobodr
Дата добавления - 13.04.2016 в 09:20
_Boroda_ Дата: Среда, 13.04.2016, 09:31 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9369
Репутация: 3942 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А я бы именованные диапазоны со СМЕЩ не делал бы. Вот так хоть и длиннее, зато не пересчитывается при каждом телодвижении
Код
=Лист1!$B$3:ИНДЕКС(Лист1!$B$3:$B$17;СЧЁТ(Лист1!$B$3:$B$17))
К сообщению приложен файл: 3323762_1.xlsx(16Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА я бы именованные диапазоны со СМЕЩ не делал бы. Вот так хоть и длиннее, зато не пересчитывается при каждом телодвижении
Код
=Лист1!$B$3:ИНДЕКС(Лист1!$B$3:$B$17;СЧЁТ(Лист1!$B$3:$B$17))

Автор - _Boroda_
Дата добавления - 13.04.2016 в 09:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамический диапазон графика (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!