Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создать маршрутный лист транспорта в эксель - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать маршрутный лист транспорта в эксель (Формулы/Formulas)
Создать маршрутный лист транспорта в эксель
TaRaNtuLouS Дата: Среда, 13.04.2016, 10:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть перечень машин, есть база клиентов ( 3 столбца: Название, город, улица). Создаю выпадающий список машин и при этом необходимо чтоб на соседнем столбце открывались клиенты с их данными которые привязаны к этой машине то есть при выборе какой либо машины из выпадающего списка появлялся список всех клиентов которых эта машина вывозила, помогите пожалуйста.


Сообщение отредактировал TaRaNtuLouS - Среда, 13.04.2016, 11:01
 
Ответить
СообщениеЕсть перечень машин, есть база клиентов ( 3 столбца: Название, город, улица). Создаю выпадающий список машин и при этом необходимо чтоб на соседнем столбце открывались клиенты с их данными которые привязаны к этой машине то есть при выборе какой либо машины из выпадающего списка появлялся список всех клиентов которых эта машина вывозила, помогите пожалуйста.

Автор - TaRaNtuLouS
Дата добавления - 13.04.2016 в 10:57
Nic70y Дата: Среда, 13.04.2016, 11:05 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3661
Репутация: 759 ±
Замечаний: 0% ±

Excel 2013
наберете в поиске: связанные выпадающие списки
без Вашего файла - все :(


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенаберете в поиске: связанные выпадающие списки
без Вашего файла - все :(

Автор - Nic70y
Дата добавления - 13.04.2016 в 11:05
TaRaNtuLouS Дата: Среда, 13.04.2016, 11:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, мне нужен не второй выпадающий список а полный перечень клиентов которые выехали с той машиной
 
Ответить
СообщениеNic70y, мне нужен не второй выпадающий список а полный перечень клиентов которые выехали с той машиной

Автор - TaRaNtuLouS
Дата добавления - 13.04.2016 в 11:07
TaRaNtuLouS Дата: Среда, 13.04.2016, 11:09 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
они есть у меня в именованых диапазонах но не могу никак сделать чтоб этот список появлялся на соседнем столбце когда я выбираю какую либо машину
[moder]Файл с примером приложите[/moder]


Сообщение отредактировал Pelena - Среда, 13.04.2016, 11:10
 
Ответить
Сообщениеони есть у меня в именованых диапазонах но не могу никак сделать чтоб этот список появлялся на соседнем столбце когда я выбираю какую либо машину
[moder]Файл с примером приложите[/moder]

Автор - TaRaNtuLouS
Дата добавления - 13.04.2016 в 11:09
Nic70y Дата: Среда, 13.04.2016, 11:09 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3661
Репутация: 759 ±
Замечаний: 0% ±

Excel 2013
тут много вариантов может быть: доп.столбец + ВПР, массивная формула, макросы
в любом случае без файла, только общие рекомендации.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениетут много вариантов может быть: доп.столбец + ВПР, массивная формула, макросы
в любом случае без файла, только общие рекомендации.

Автор - Nic70y
Дата добавления - 13.04.2016 в 11:09
VIDEO56 Дата: Среда, 13.04.2016, 11:10 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
TaRaNtuLouS, файл приложите


Всем удачного дня!
 
Ответить
СообщениеTaRaNtuLouS, файл приложите

Автор - VIDEO56
Дата добавления - 13.04.2016 в 11:10
TaRaNtuLouS Дата: Среда, 13.04.2016, 11:21 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
прилагаю
К сообщению приложен файл: 2044548.xlsx(13Kb)
 
Ответить
Сообщениеприлагаю

Автор - TaRaNtuLouS
Дата добавления - 13.04.2016 в 11:21
Nic70y Дата: Среда, 13.04.2016, 11:25 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3661
Репутация: 759 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(A$2:E$38;СТРОКА(A1);ПОИСКПОЗ(A$42;A$1:E$1;))&""
или
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ(A$42);СТРОКА(C1));"")
К сообщению приложен файл: 9249721.xlsx(15Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 13.04.2016, 11:28
 
Ответить
Сообщение
Код
=ИНДЕКС(A$2:E$38;СТРОКА(A1);ПОИСКПОЗ(A$42;A$1:E$1;))&""
или
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ(A$42);СТРОКА(C1));"")

Автор - Nic70y
Дата добавления - 13.04.2016 в 11:25
TaRaNtuLouS Дата: Среда, 13.04.2016, 11:34 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, сейчас ко всей базе применю)
 
Ответить
СообщениеСпасибо, сейчас ко всей базе применю)

Автор - TaRaNtuLouS
Дата добавления - 13.04.2016 в 11:34
китин Дата: Среда, 13.04.2016, 11:39 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3699
Репутация: 574 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так?
Код
=ИНДЕКС($A$2:$E$39;СТРОКА(A1);ПОИСКПОЗ($A$42;$A$1:$E$1;0))

или с выпадающим списком (формула для проверки данных)
Код
=СМЕЩ($A$1;1;ПОИСКПОЗ($A$42;$A$1:$E$1;0)-1;СЧЁТЗ(ИНДЕКС($A$2:$E$39;;ПОИСКПОЗ($A$42;$A$1:$E$1;0))-1))
К сообщению приложен файл: 44548.xlsx(14Kb) · 111111111.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 13.04.2016, 11:48
 
Ответить
Сообщениетак?
Код
=ИНДЕКС($A$2:$E$39;СТРОКА(A1);ПОИСКПОЗ($A$42;$A$1:$E$1;0))

или с выпадающим списком (формула для проверки данных)
Код
=СМЕЩ($A$1;1;ПОИСКПОЗ($A$42;$A$1:$E$1;0)-1;СЧЁТЗ(ИНДЕКС($A$2:$E$39;;ПОИСКПОЗ($A$42;$A$1:$E$1;0))-1))

Автор - китин
Дата добавления - 13.04.2016 в 11:39
_Boroda_ Дата: Среда, 13.04.2016, 19:54 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4147 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ИНДЕКС(A2:E2;ПРАВБ(A$42))&""
К сообщению приложен файл: 2044548_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ИНДЕКС(A2:E2;ПРАВБ(A$42))&""

Автор - _Boroda_
Дата добавления - 13.04.2016 в 19:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создать маршрутный лист транспорта в эксель (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!