Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти в строке макс значение, поставить его как 100 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в строке макс значение, поставить его как 100 (Формулы/Formulas чтобы в дальнейшем построить график)
Найти в строке макс значение, поставить его как 100
underwaterbat Дата: Понедельник, 18.04.2016, 12:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
здравствуйте!
пожалуйста, помогите составить формулу.
дано: таблица по годам с разными значениями. эти значения могут быть как миллионы, так и единицы...
хочу: значения в каждой строке перевести в проценты. так, чтобы максимальное значение было 100%, а все остальные значения в этой строке плясали уже от этого 100%. и так собсно для каждой строки отдельно... ну и, конечно, чтобы была одна формула на весь процесс. чтобы можно было автоматически растянуть просто и во всех строках (их оч много) вот такая тема получилась.
часть данных настоящих - во вложении
т.е. например,

есть таблица

2000 2001 2002 2003 2004 2005 2006
яблоки 60 0 120 0 90 0 0
груши 0 0 0 20 0 100 200

а на выходе хочу:

2000 2001 2002 2003 2004 2005 2006
яблоки 50% 0 100% 0 75% 0 0
груши 0 0 0 10% 0 50% 100%

спасибо!
К сообщению приложен файл: formula_forum.xlsx(11Kb)
 
Ответить
Сообщениездравствуйте!
пожалуйста, помогите составить формулу.
дано: таблица по годам с разными значениями. эти значения могут быть как миллионы, так и единицы...
хочу: значения в каждой строке перевести в проценты. так, чтобы максимальное значение было 100%, а все остальные значения в этой строке плясали уже от этого 100%. и так собсно для каждой строки отдельно... ну и, конечно, чтобы была одна формула на весь процесс. чтобы можно было автоматически растянуть просто и во всех строках (их оч много) вот такая тема получилась.
часть данных настоящих - во вложении
т.е. например,

есть таблица

2000 2001 2002 2003 2004 2005 2006
яблоки 60 0 120 0 90 0 0
груши 0 0 0 20 0 100 200

а на выходе хочу:

2000 2001 2002 2003 2004 2005 2006
яблоки 50% 0 100% 0 75% 0 0
груши 0 0 0 10% 0 50% 100%

спасибо!

Автор - underwaterbat
Дата добавления - 18.04.2016 в 12:58
underwaterbat Дата: Понедельник, 18.04.2016, 13:04 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
все, спасибо апексу с другого форума (ссылка), вот формула:
Код
=ЕСЛИОШИБКА(D2/МАКС($D2:$T2);"")

[moder]Для оформления формул используйте теги. Поправил Вам


Сообщение отредактировал _Boroda_ - Понедельник, 18.04.2016, 13:31
 
Ответить
Сообщениевсе, спасибо апексу с другого форума (ссылка), вот формула:
Код
=ЕСЛИОШИБКА(D2/МАКС($D2:$T2);"")

[moder]Для оформления формул используйте теги. Поправил Вам

Автор - underwaterbat
Дата добавления - 18.04.2016 в 13:04
buchlotnik Дата: Понедельник, 18.04.2016, 13:08 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ЕСЛИОШИБКА(D2/МАКС($D2:$T2);"")
К сообщению приложен файл: 7863158.xlsx(14Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ЕСЛИОШИБКА(D2/МАКС($D2:$T2);"")

Автор - buchlotnik
Дата добавления - 18.04.2016 в 13:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в строке макс значение, поставить его как 100 (Формулы/Formulas чтобы в дальнейшем построить график)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!