Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое открытие файлов (других книг) вместе с базой. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое открытие файлов (других книг) вместе с базой. (Формулы/Formulas)
Автоматическое открытие файлов (других книг) вместе с базой.
GaLaXoN Дата: Вторник, 19.04.2016, 08:03 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Всем доброго времени суток!

Имеется базовая книга, в ней отображены формулы на другие книги эксель (ссылки на ячейки, ссылки на имена, списки и т.д.).
С макросами дела туго обстоят.....в интернете нашел статью "как связать 2 разные книги макросом", но как я понял макрос применяется на одну ячейку либо же диапазон ячеек из книги.
В общем не походит мне такой метод!

А ссылки в базовой книге не работают, если не открыты другие книги (с данными).
В связи с этим вопрос такой: можно ли каким то образом сделать так, чтобы при открытии базовой книги, открывались еще и книги с данными.
И еще хотел бы уточнить будет ли тормозить файл из за этого? может все же оставить гиперссылкой открытие и открывать вручную?

Спасибо за внимание!

(файл примера не скидываю, т.к. смысла не вижу)
 
Ответить
СообщениеВсем доброго времени суток!

Имеется базовая книга, в ней отображены формулы на другие книги эксель (ссылки на ячейки, ссылки на имена, списки и т.д.).
С макросами дела туго обстоят.....в интернете нашел статью "как связать 2 разные книги макросом", но как я понял макрос применяется на одну ячейку либо же диапазон ячеек из книги.
В общем не походит мне такой метод!

А ссылки в базовой книге не работают, если не открыты другие книги (с данными).
В связи с этим вопрос такой: можно ли каким то образом сделать так, чтобы при открытии базовой книги, открывались еще и книги с данными.
И еще хотел бы уточнить будет ли тормозить файл из за этого? может все же оставить гиперссылкой открытие и открывать вручную?

Спасибо за внимание!

(файл примера не скидываю, т.к. смысла не вижу)

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 08:03
Nic70y Дата: Вторник, 19.04.2016, 08:19 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3672
Репутация: 761 ±
Замечаний: 0% ±

Excel 2013
А ссылки в базовой книге не работают
значит "неправильные" ссылки


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
А ссылки в базовой книге не работают
значит "неправильные" ссылки

Автор - Nic70y
Дата добавления - 19.04.2016 в 08:19
GaLaXoN Дата: Вторник, 19.04.2016, 08:22 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
значит "неправильные" ссылки

почему не правильные?

как пример могу скинуть ссылку...
Код
=ЕСЛИОШИБКА((ЕСЛИ($BV5="Cu";ИНДЕКС(ДВССЫЛ("[2_Кабель.xlsx]Общее!$B$39:$B$65");ПОИСКПОЗ($CI5;ДВССЫЛ("[2_Кабель.xlsx]Общее!$A$39:$A$65");));ИНДЕКС(ДВССЫЛ("[2_Кабель.xlsx]Общее!$C$39:$C$65");ПОИСКПОЗ($CI5;ДВССЫЛ("[2_Кабель.xlsx]Общее!$A$39:$A$65");))));"")


Вот ссылка, не отображает значения если не открыта книга "2_Кабель".
 
Ответить
Сообщение
значит "неправильные" ссылки

почему не правильные?

как пример могу скинуть ссылку...
Код
=ЕСЛИОШИБКА((ЕСЛИ($BV5="Cu";ИНДЕКС(ДВССЫЛ("[2_Кабель.xlsx]Общее!$B$39:$B$65");ПОИСКПОЗ($CI5;ДВССЫЛ("[2_Кабель.xlsx]Общее!$A$39:$A$65");));ИНДЕКС(ДВССЫЛ("[2_Кабель.xlsx]Общее!$C$39:$C$65");ПОИСКПОЗ($CI5;ДВССЫЛ("[2_Кабель.xlsx]Общее!$A$39:$A$65");))));"")


Вот ссылка, не отображает значения если не открыта книга "2_Кабель".

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 08:22
Nic70y Дата: Вторник, 19.04.2016, 08:25 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3672
Репутация: 761 ±
Замечаний: 0% ±

Excel 2013
ДВССЫЛ("[2_Кабель.xlsx]Общее!$B$39:$B$65")
так и знал - неправильные, уберите
Код
ДВССЫЛ
сделайте прямые ссылки
Код
=ЕСЛИОШИБКА((ЕСЛИ($BV5="Cu";ИНДЕКС([2_Кабель.xlsx]Общее!$B$39:$B$65;ПОИСКПОЗ($CI5;[2_Кабель.xlsx]Общее!$A$39:$A$65;));ИНДЕКС([2_Кабель.xlsx]Общее!$C$39:$C$65;ПОИСКПОЗ($CI5;[2_Кабель.xlsx]Общее!$A$39:$A$65;))));"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 19.04.2016, 08:32
 
Ответить
Сообщение
ДВССЫЛ("[2_Кабель.xlsx]Общее!$B$39:$B$65")
так и знал - неправильные, уберите
Код
ДВССЫЛ
сделайте прямые ссылки
Код
=ЕСЛИОШИБКА((ЕСЛИ($BV5="Cu";ИНДЕКС([2_Кабель.xlsx]Общее!$B$39:$B$65;ПОИСКПОЗ($CI5;[2_Кабель.xlsx]Общее!$A$39:$A$65;));ИНДЕКС([2_Кабель.xlsx]Общее!$C$39:$C$65;ПОИСКПОЗ($CI5;[2_Кабель.xlsx]Общее!$A$39:$A$65;))));"")

Автор - Nic70y
Дата добавления - 19.04.2016 в 08:25
китин Дата: Вторник, 19.04.2016, 08:31 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3720
Репутация: 574 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
кэп


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 19.04.2016, 08:32
 
Ответить
Сообщениекэп

Автор - китин
Дата добавления - 19.04.2016 в 08:31
GaLaXoN Дата: Вторник, 19.04.2016, 08:34 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
сделайте прямые ссылки

я всегда так делал!
если честно, даже не знаю как прямей сделать....

Код
=ЕСЛИОШИБКА((ЕСЛИ($BV5="Cu";ИНДЕКС(([2_Кабель.xlsx]Общее!$B$39:$B$65);ПОИСКПОЗ($CI5;([2_Кабель.xlsx]Общее!$A$39:$A$65);));ИНДЕКС(([2_Кабель.xlsx]Общее!$C$39:$C$65);ПОИСКПОЗ($CI5;([2_Кабель.xlsx]Общее!$A$39:$A$65);))));"")

так чтоли?
 
Ответить
Сообщение
сделайте прямые ссылки

я всегда так делал!
если честно, даже не знаю как прямей сделать....

Код
=ЕСЛИОШИБКА((ЕСЛИ($BV5="Cu";ИНДЕКС(([2_Кабель.xlsx]Общее!$B$39:$B$65);ПОИСКПОЗ($CI5;([2_Кабель.xlsx]Общее!$A$39:$A$65);));ИНДЕКС(([2_Кабель.xlsx]Общее!$C$39:$C$65);ПОИСКПОЗ($CI5;([2_Кабель.xlsx]Общее!$A$39:$A$65);))));"")

так чтоли?

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 08:34
Nic70y Дата: Вторник, 19.04.2016, 08:36 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3672
Репутация: 761 ±
Замечаний: 0% ±

Excel 2013
так чтоли?
да, только лишние (), см. мое сообщение выше, я добавил формулу


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
так чтоли?
да, только лишние (), см. мое сообщение выше, я добавил формулу

Автор - Nic70y
Дата добавления - 19.04.2016 в 08:36
GaLaXoN Дата: Вторник, 19.04.2016, 08:38 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
Nic70y, хм....и правда все отображает!
Спасибо огромное!

У меня тогда другой вопрос.
у меня в базовой книге ссылки на имена из других книг (выпадающие списки).......такой метод уже ведь не подойдет?

Могу скинуть файл как пример....если требуется.
 
Ответить
СообщениеNic70y, хм....и правда все отображает!
Спасибо огромное!

У меня тогда другой вопрос.
у меня в базовой книге ссылки на имена из других книг (выпадающие списки).......такой метод уже ведь не подойдет?

Могу скинуть файл как пример....если требуется.

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 08:38
GaLaXoN Дата: Вторник, 19.04.2016, 08:38 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
см. мое сообщение выше, я добавил формулу

да, увидел уже!
теперь буду иметь ввиду это!
Спасибо за помощь в этом вопросе!
 
Ответить
Сообщение
см. мое сообщение выше, я добавил формулу

да, увидел уже!
теперь буду иметь ввиду это!
Спасибо за помощь в этом вопросе!

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 08:38
Nic70y Дата: Вторник, 19.04.2016, 08:42 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3672
Репутация: 761 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ЕСЛИ($BV5="Cu";ВПР($CI5;[2_Кабель.xlsx]Общее!$A$39:$B$65;2;);ВПР($CI5;[2_Кабель.xlsx]Общее!$A$39:$C$65;3;));"")
Код
=ЕСЛИОШИБКА(ВПР($CI5;[2_Кабель.xlsx]Общее!$A$39:$C$65;ЕСЛИ($BV5="Cu";2;3););"")
ссылки на имена из других книг (выпадающие списки).......такой метод уже ведь не подойдет?
вы сами себе ответили.
Могу скинуть
ой не знаю, у модераторов спросить надо
[moder]Читаем Правила[/moder]
я о двух вопросах, а вроде бы и вопрос не о формулах был %)
[vba]
Код
Private Sub Workbook_Open()
    Workbooks.Open Filename:="путь_к_файлу\2_Кабель.xlsx"
    Windows("Имя_основной_книги.xlsm").Activate
End Sub
[/vba]


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 19.04.2016, 08:51
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ЕСЛИ($BV5="Cu";ВПР($CI5;[2_Кабель.xlsx]Общее!$A$39:$B$65;2;);ВПР($CI5;[2_Кабель.xlsx]Общее!$A$39:$C$65;3;));"")
Код
=ЕСЛИОШИБКА(ВПР($CI5;[2_Кабель.xlsx]Общее!$A$39:$C$65;ЕСЛИ($BV5="Cu";2;3););"")
ссылки на имена из других книг (выпадающие списки).......такой метод уже ведь не подойдет?
вы сами себе ответили.
Могу скинуть
ой не знаю, у модераторов спросить надо
[moder]Читаем Правила[/moder]
я о двух вопросах, а вроде бы и вопрос не о формулах был %)
[vba]
Код
Private Sub Workbook_Open()
    Workbooks.Open Filename:="путь_к_файлу\2_Кабель.xlsx"
    Windows("Имя_основной_книги.xlsm").Activate
End Sub
[/vba]

Автор - Nic70y
Дата добавления - 19.04.2016 в 08:42
GaLaXoN Дата: Вторник, 19.04.2016, 09:01 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
ой не знаю, у модераторов спросить надо


Вот попробовал вкратце изложить как я делаю.....
выпадающие списки.....второй зависит от выбора первого....
книги под названиями "111111" и "222222". названия думаю поменяются.
К сообщению приложен файл: 111111.xlsx(9Kb) · 222222.xlsx(10Kb)
 
Ответить
Сообщение
ой не знаю, у модераторов спросить надо


Вот попробовал вкратце изложить как я делаю.....
выпадающие списки.....второй зависит от выбора первого....
книги под названиями "111111" и "222222". названия думаю поменяются.

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 09:01
GaLaXoN Дата: Вторник, 19.04.2016, 09:03 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
я о двух вопросах, а вроде бы и вопрос не о формулах был %)

как обычно......
просто учусь пользоваться экселем, уровень далек от совершенства....
научусь одному приему и пихаю его везде, нет бы подумать как лучше....
поэтому и вопросов куча сразу!.....от одного к другому!
 
Ответить
Сообщение
я о двух вопросах, а вроде бы и вопрос не о формулах был %)

как обычно......
просто учусь пользоваться экселем, уровень далек от совершенства....
научусь одному приему и пихаю его везде, нет бы подумать как лучше....
поэтому и вопросов куча сразу!.....от одного к другому!

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 09:03
Nic70y Дата: Вторник, 19.04.2016, 09:06 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3672
Репутация: 761 ±
Замечаний: 0% ±

Excel 2013
На Ваш основной вопрос
Автоматическое открытие файлов (других книг) вместе с базой.
я ответил
Private Sub Workbook_Open()

а почему бы не сделать эти имена в одном файле с выпадающими списками?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 19.04.2016, 09:08
 
Ответить
СообщениеНа Ваш основной вопрос
Автоматическое открытие файлов (других книг) вместе с базой.
я ответил
Private Sub Workbook_Open()

а почему бы не сделать эти имена в одном файле с выпадающими списками?

Автор - Nic70y
Дата добавления - 19.04.2016 в 09:06
GaLaXoN Дата: Вторник, 19.04.2016, 09:11 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
я ответил

да да! я видел, правда еще не попробовал!

а почему бы не сделать эти имена в одном файле с выпадающими списками?

Вы имеете ввиду не делать выпадающие списки на книге с данными (111111), а сделать их только на книге базовой (222222)?
 
Ответить
Сообщение
я ответил

да да! я видел, правда еще не попробовал!

а почему бы не сделать эти имена в одном файле с выпадающими списками?

Вы имеете ввиду не делать выпадающие списки на книге с данными (111111), а сделать их только на книге базовой (222222)?

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 09:11
Nic70y Дата: Вторник, 19.04.2016, 09:14 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3672
Репутация: 761 ±
Замечаний: 0% ±

Excel 2013
Вы имеете ввиду
да


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Вы имеете ввиду
да

Автор - Nic70y
Дата добавления - 19.04.2016 в 09:14
GaLaXoN Дата: Вторник, 19.04.2016, 09:24 | Сообщение № 16
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010

а это у меня только на начальный выпадающий список стоит значение из списка в книге 111111, а дальше уже списки формируются в книге 222222.
скидываю поправленный пример:
К сообщению приложен файл: 4385027.xlsx(10Kb) · 4268030.xlsx(10Kb)


Сообщение отредактировал GaLaXoN - Вторник, 19.04.2016, 09:24
 
Ответить
Сообщение
а это у меня только на начальный выпадающий список стоит значение из списка в книге 111111, а дальше уже списки формируются в книге 222222.
скидываю поправленный пример:

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 09:24
Nic70y Дата: Вторник, 19.04.2016, 09:43 | Сообщение № 17
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3672
Репутация: 761 ±
Замечаний: 0% ±

Excel 2013
если возможности нет списки в одном файле (хотя я причин не вижу)
вариант vba или одновременно открытые книги
ну может есть и другие варианты, но о них не знаю


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеесли возможности нет списки в одном файле (хотя я причин не вижу)
вариант vba или одновременно открытые книги
ну может есть и другие варианты, но о них не знаю

Автор - Nic70y
Дата добавления - 19.04.2016 в 09:43
GaLaXoN Дата: Вторник, 19.04.2016, 09:45 | Сообщение № 18
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 40% ±

Excel 2010
ну может есть и другие варианты, но о них не знаю

ясно все!
Спасибо за консультацию! =)))
 
Ответить
Сообщение
ну может есть и другие варианты, но о них не знаю

ясно все!
Спасибо за консультацию! =)))

Автор - GaLaXoN
Дата добавления - 19.04.2016 в 09:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое открытие файлов (других книг) вместе с базой. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!