Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/удалить все повторяющиеся значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » удалить все повторяющиеся значения (Формулы/Formulas)
удалить все повторяющиеся значения
АЛЕКСАНДР1986 Дата: Пятница, 22.04.2016, 09:57 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
всем добрый день
есть желтая таблица не подскажите как из нее получить синюю таблицу?
в синей таблице все теже значения, но с удаленными повторами
К сообщению приложен файл: 22222.xlsx(8Kb)


Сообщение отредактировал АЛЕКСАНДР1986 - Пятница, 22.04.2016, 10:17
 
Ответить
Сообщениевсем добрый день
есть желтая таблица не подскажите как из нее получить синюю таблицу?
в синей таблице все теже значения, но с удаленными повторами

Автор - АЛЕКСАНДР1986
Дата добавления - 22.04.2016 в 09:57
китин Дата: Пятница, 22.04.2016, 10:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а вкладка данные удалить дубликаты не прокатит?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа вкладка данные удалить дубликаты не прокатит?

Автор - китин
Дата добавления - 22.04.2016 в 10:02
_Boroda_ Дата: Пятница, 22.04.2016, 10:03 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вариант. Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$25;ПОИСКПОЗ(;СЧЁТЕСЛИ(G$1:G1;C$2:C$25);));"")
К сообщению приложен файл: 22222-1-1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВариант. Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$25;ПОИСКПОЗ(;СЧЁТЕСЛИ(G$1:G1;C$2:C$25);));"")

Автор - _Boroda_
Дата добавления - 22.04.2016 в 10:03
gling Дата: Пятница, 22.04.2016, 10:04 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Здравствуйте. Выделить диапазон--Вкладка данные--Удалить дубликаты--ОК
 
Ответить
СообщениеЗдравствуйте. Выделить диапазон--Вкладка данные--Удалить дубликаты--ОК

Автор - gling
Дата добавления - 22.04.2016 в 10:04
китин Дата: Пятница, 22.04.2016, 10:06 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и еще одна формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$C$25;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($C$2:$C$25;$C$2:$C$25;0)=СТРОКА($C$2:$C$25)-1;СТРОКА($C$2:$C$25)-1);СТРОКА(A1)));"")
К сообщению приложен файл: 9273379.xlsx(9Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи еще одна формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$C$25;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($C$2:$C$25;$C$2:$C$25;0)=СТРОКА($C$2:$C$25)-1;СТРОКА($C$2:$C$25)-1);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 22.04.2016 в 10:06
Pelena Дата: Пятница, 22.04.2016, 10:16 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Почему в теме написано "удалить все НЕ повторяющиеся"? %)
[moder](Невнимательность_ТС) * (невнимательность_отвечающих) = все_нормально
Минус на минус ...


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816


Сообщение отредактировал _Boroda_ - Пятница, 22.04.2016, 10:20
 
Ответить
СообщениеПочему в теме написано "удалить все НЕ повторяющиеся"? %)
[moder](Невнимательность_ТС) * (невнимательность_отвечающих) = все_нормально
Минус на минус ...

Автор - Pelena
Дата добавления - 22.04.2016 в 10:16
АЛЕКСАНДР1986 Дата: Пятница, 22.04.2016, 10:25 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
спасибо за помощь!
 
Ответить
Сообщениеспасибо за помощь!

Автор - АЛЕКСАНДР1986
Дата добавления - 22.04.2016 в 10:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » удалить все повторяющиеся значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!