Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/из столбца сделать строку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » из столбца сделать строку (Формулы/Formulas)
из столбца сделать строку
АЛЕКСАНДР1986 Дата: Пятница, 22.04.2016, 22:17 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 130
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
всем добрый вечер!
не подскажите как из столбца сделать строки и чтобы в каждой строке находилось не больше 8 значений следовательно следующие значения переносятся на следующую строку и т.д.
изначальная таблица с данными представлена в желтой таблице то что должно получиться представлено в зеленой таблице!
заранее спасибо за помощь!
К сообщению приложен файл: 111111.xlsm(38Kb)
 
Ответить
Сообщениевсем добрый вечер!
не подскажите как из столбца сделать строки и чтобы в каждой строке находилось не больше 8 значений следовательно следующие значения переносятся на следующую строку и т.д.
изначальная таблица с данными представлена в желтой таблице то что должно получиться представлено в зеленой таблице!
заранее спасибо за помощь!

Автор - АЛЕКСАНДР1986
Дата добавления - 22.04.2016 в 22:17
Nic70y Дата: Пятница, 22.04.2016, 22:31 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3925
Репутация: 832 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС($B$4:$B$873;(СТРОКА(A1)-1)*8+СТОЛБЕЦ(A1))
К сообщению приложен файл: 9705708.xlsm(34Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС($B$4:$B$873;(СТРОКА(A1)-1)*8+СТОЛБЕЦ(A1))

Автор - Nic70y
Дата добавления - 22.04.2016 в 22:31
МВТ Дата: Суббота, 23.04.2016, 15:57 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 476
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007
Николай, судя по расширению файла, ТС ждет что-то в таком роде
[vba]
Код
Sub tt()
    Dim arr(), i As Integer, j As Integer, maxrow
    arr = Range("B4:B" & Cells(Rows.Count, "B").End(xlUp).Row).Value
    maxrow = WorksheetFunction.RoundUp(UBound(arr) / 8, 0)
    Application.ScreenUpdating = False
    For i = 1 To maxrow
        For j = 1 To 8
            Cells(i + 3, j + 4) = arr((i - 1) * 8 + j, 1)
        Next
    Next
    Application.ScreenUpdating = True
End Sub
[/vba]
UPD немного подправил код


Сообщение отредактировал МВТ - Суббота, 23.04.2016, 16:38
 
Ответить
СообщениеНиколай, судя по расширению файла, ТС ждет что-то в таком роде
[vba]
Код
Sub tt()
    Dim arr(), i As Integer, j As Integer, maxrow
    arr = Range("B4:B" & Cells(Rows.Count, "B").End(xlUp).Row).Value
    maxrow = WorksheetFunction.RoundUp(UBound(arr) / 8, 0)
    Application.ScreenUpdating = False
    For i = 1 To maxrow
        For j = 1 To 8
            Cells(i + 3, j + 4) = arr((i - 1) * 8 + j, 1)
        Next
    Next
    Application.ScreenUpdating = True
End Sub
[/vba]
UPD немного подправил код

Автор - МВТ
Дата добавления - 23.04.2016 в 15:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » из столбца сделать строку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!