Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Многоуровневая формула для выбора значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Многоуровневая формула для выбора значения (Формулы/Formulas)
Многоуровневая формула для выбора значения
kaurov Дата: Понедельник, 25.04.2016, 05:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Подскажите, пожалуйста, формулу, по которой при введении определенного кода "вылетала" соответствующая ему информация. Формула "ЕСЛИ" "тормозит" процесс на 9-ом вводимом значении, а "ВЫБОР" - на 254-ом. А желательно вместить 373 кода в формулу.
Спасибо!
К сообщению приложен файл: _excel_world.xlsx(12Kb)
 
Ответить
СообщениеПодскажите, пожалуйста, формулу, по которой при введении определенного кода "вылетала" соответствующая ему информация. Формула "ЕСЛИ" "тормозит" процесс на 9-ом вводимом значении, а "ВЫБОР" - на 254-ом. А желательно вместить 373 кода в формулу.
Спасибо!

Автор - kaurov
Дата добавления - 25.04.2016 в 05:59
gling Дата: Понедельник, 25.04.2016, 06:59 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
И Вам тоже Здравствуйте. Вам нужна функция ВПР.
Код
=ВПР($B14;$B$4:$I$6;СТОЛБЕЦ()-1;ЛОЖЬ)
К сообщению приложен файл: 2743237.xlsx(13Kb)


Сообщение отредактировал gling - Понедельник, 25.04.2016, 07:00
 
Ответить
СообщениеИ Вам тоже Здравствуйте. Вам нужна функция ВПР.
Код
=ВПР($B14;$B$4:$I$6;СТОЛБЕЦ()-1;ЛОЖЬ)

Автор - gling
Дата добавления - 25.04.2016 в 06:59
pabchek Дата: Понедельник, 25.04.2016, 09:36 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! Можно еще
Код
=ПРОСМОТР($B9;$B$4:$B$6;C$4:C$6)

и, думается мне, наименее тормознутая (из предложенных) должна быть формула
Код
=ИНДЕКС(C$4:C$6;ПОИСКПОЗ($B9;$B$4:$B$6;0))
К сообщению приложен файл: 4888159.xlsx(12Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Понедельник, 25.04.2016, 09:41
 
Ответить
СообщениеЗдравствуйте! Можно еще
Код
=ПРОСМОТР($B9;$B$4:$B$6;C$4:C$6)

и, думается мне, наименее тормознутая (из предложенных) должна быть формула
Код
=ИНДЕКС(C$4:C$6;ПОИСКПОЗ($B9;$B$4:$B$6;0))

Автор - pabchek
Дата добавления - 25.04.2016 в 09:36
_Boroda_ Дата: Понедельник, 25.04.2016, 09:43 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Виктор, с ПРОСМОТРом так не покатит. Смотри файл - красное. Из справки "Значения в аргументе просматриваемый_вектор должны быть расположены в порядке возрастания".
Предлагаю так
Код
=ПРОСМОТР(;-1/($B$4:$B$6=$B9);C$4:C$6)
или
Код
=ПРОСМОТР(2;1/($B$4:$B$6=$B9);E$4:E$6)


А про ИНДЕКС - я тоже фанат именно такой записи. ВПР вообще не люблю.
К сообщению приложен файл: 4888159_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВиктор, с ПРОСМОТРом так не покатит. Смотри файл - красное. Из справки "Значения в аргументе просматриваемый_вектор должны быть расположены в порядке возрастания".
Предлагаю так
Код
=ПРОСМОТР(;-1/($B$4:$B$6=$B9);C$4:C$6)
или
Код
=ПРОСМОТР(2;1/($B$4:$B$6=$B9);E$4:E$6)


А про ИНДЕКС - я тоже фанат именно такой записи. ВПР вообще не люблю.

Автор - _Boroda_
Дата добавления - 25.04.2016 в 09:43
pabchek Дата: Понедельник, 25.04.2016, 10:41 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
[offtop]
с ПРОСМОТРом так не покатит
Да, категорически согласен. С утра, похоже, еще мозг не вышел на крейсерскую скорость ))[/offtop]


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение[offtop]
с ПРОСМОТРом так не покатит
Да, категорически согласен. С утра, похоже, еще мозг не вышел на крейсерскую скорость ))[/offtop]

Автор - pabchek
Дата добавления - 25.04.2016 в 10:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Многоуровневая формула для выбора значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!