Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение текстовых столбцов, простановка численных значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение текстовых столбцов, простановка численных значений (Формулы/Formulas)
Сравнение текстовых столбцов, простановка численных значений
rutgerh Дата: Понедельник, 25.04.2016, 22:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет, очень стыдно, но вынужден просить помощи.
Честно убил 4 часа чтобы разобраться с ВПР, но так ни к чему и не пришел, хотя умом понимаю, что задача простая.

В общем, на первом листе есть крайний левый столбец, в нем перечислены сайты - 300 штук.
Затем идут другие листы (около 30), каждый из которых содержит часть вышеупомянутых сайтов в первом столбце, и численные данные, которые им соответствуют - во втором.

Мне нужно на первом листе собрать данные из всех остальных листов так, чтобы численные данные с каждого следующего листа проставлялись напротив правильного сайта на листе 1 - для каждого листа с данными - новый соответсвующий столбец на листе 1.

Тестовую таблицу прикрепил.

Заранее благодарю и обещаю таки осилить ВПР :)
К сообщению приложен файл: 2218165.xlsx(33Kb)


Сообщение отредактировал rutgerh - Понедельник, 25.04.2016, 22:58
 
Ответить
СообщениеВсем привет, очень стыдно, но вынужден просить помощи.
Честно убил 4 часа чтобы разобраться с ВПР, но так ни к чему и не пришел, хотя умом понимаю, что задача простая.

В общем, на первом листе есть крайний левый столбец, в нем перечислены сайты - 300 штук.
Затем идут другие листы (около 30), каждый из которых содержит часть вышеупомянутых сайтов в первом столбце, и численные данные, которые им соответствуют - во втором.

Мне нужно на первом листе собрать данные из всех остальных листов так, чтобы численные данные с каждого следующего листа проставлялись напротив правильного сайта на листе 1 - для каждого листа с данными - новый соответсвующий столбец на листе 1.

Тестовую таблицу прикрепил.

Заранее благодарю и обещаю таки осилить ВПР :)

Автор - rutgerh
Дата добавления - 25.04.2016 в 22:57
Pelena Дата: Понедельник, 25.04.2016, 23:07 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11493
Репутация: 2557 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Если в первой строке написать имена листов, то можно формулой
Код
=ЕСЛИОШИБКА(ВПР($A2;ДВССЫЛ("'"&B$1&"'!A$1:$B$300");2;0);"")
К сообщению приложен файл: 4411571.xlsx(43Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли в первой строке написать имена листов, то можно формулой
Код
=ЕСЛИОШИБКА(ВПР($A2;ДВССЫЛ("'"&B$1&"'!A$1:$B$300");2;0);"")

Автор - Pelena
Дата добавления - 25.04.2016 в 23:07
gling Дата: Понедельник, 25.04.2016, 23:22 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1622
Репутация: 394 ±
Замечаний: 0% ±

2010
Почти такой же ответ ЗДЕСЬ
 
Ответить
СообщениеПочти такой же ответ ЗДЕСЬ

Автор - gling
Дата добавления - 25.04.2016 в 23:22
rutgerh Дата: Понедельник, 25.04.2016, 23:25 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Большое спасибо!!
Формула работает просто как магия!
 
Ответить
СообщениеБольшое спасибо!!
Формула работает просто как магия!

Автор - rutgerh
Дата добавления - 25.04.2016 в 23:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение текстовых столбцов, простановка численных значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!