Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счёт не пустых ячеек в двух диапазонах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счёт не пустых ячеек в двух диапазонах (Формулы/Formulas)
Счёт не пустых ячеек в двух диапазонах
Ипалит Дата: Вторник, 26.04.2016, 12:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте форумчане. Описание в файле. Лист2. Для меня задача к сожалению кажется не выполнила. Целый день мучаюсь. Необходимо подсчитать количество не пустых ячеек в двух диапазонах отвечающих одному критерию.
[moder]1. Правила форума - "Кратко, но ёмко опишите задачу в теле поста".
2. "Мой вагон файл пуст!".
0. Здравствуйте.
К сообщению приложен файл: 8252385.xls(0Kb)


Сообщение отредактировал Ипалит - Вторник, 26.04.2016, 12:38
 
Ответить
СообщениеЗдравствуйте форумчане. Описание в файле. Лист2. Для меня задача к сожалению кажется не выполнила. Целый день мучаюсь. Необходимо подсчитать количество не пустых ячеек в двух диапазонах отвечающих одному критерию.
[moder]1. Правила форума - "Кратко, но ёмко опишите задачу в теле поста".
2. "Мой вагон файл пуст!".
0. Здравствуйте.

Автор - Ипалит
Дата добавления - 26.04.2016 в 12:07
китин Дата: Вторник, 26.04.2016, 12:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
добрый день . так?
Код
=ЕСЛИ($B3="";"";СУММПРОИЗВ((Лист1!$L$7:$L$32=Лист2!$B3)*НЕ(ЕПУСТО(Лист1!$F$7:$F$32))))
К сообщению приложен файл: 1575312.xls(37Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 26.04.2016, 12:46
 
Ответить
Сообщениедобрый день . так?
Код
=ЕСЛИ($B3="";"";СУММПРОИЗВ((Лист1!$L$7:$L$32=Лист2!$B3)*НЕ(ЕПУСТО(Лист1!$F$7:$F$32))))

Автор - китин
Дата добавления - 26.04.2016 в 12:44
Ипалит Дата: Вторник, 26.04.2016, 12:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да:) спасибо большое. Плюсану с компьютера дома. Ещё раз благодарю
 
Ответить
СообщениеДа:) спасибо большое. Плюсану с компьютера дома. Ещё раз благодарю

Автор - Ипалит
Дата добавления - 26.04.2016 в 12:52
AlexM Дата: Вторник, 26.04.2016, 13:21 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3052
Репутация: 740 ±
Замечаний: 0% ±

Ипалит, Зачем вы объединяете столбцы. В вашем случае в этом нет надобности. Без объединения ячеек формула получается протягиваемая.
Код
=ЕСЛИ($B3="";"";СУММПРОИЗВ((Лист1!$G$7:$G$32=$B3)*ЕТЕКСТ(Лист1!E$7:E$32)))
К сообщению приложен файл: 1575312_1.xls(35Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 26.04.2016, 13:37
 
Ответить
СообщениеИпалит, Зачем вы объединяете столбцы. В вашем случае в этом нет надобности. Без объединения ячеек формула получается протягиваемая.
Код
=ЕСЛИ($B3="";"";СУММПРОИЗВ((Лист1!$G$7:$G$32=$B3)*ЕТЕКСТ(Лист1!E$7:E$32)))

Автор - AlexM
Дата добавления - 26.04.2016 в 13:21
_Boroda_ Дата: Вторник, 26.04.2016, 13:33 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИ(B3="";"";СЧЁТЕСЛИМН(Лист1!L$7:L$32;B3;Лист1!F$7:F$32;"*"))
К сообщению приложен файл: 8913910.xls(43Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(B3="";"";СЧЁТЕСЛИМН(Лист1!L$7:L$32;B3;Лист1!F$7:F$32;"*"))

Автор - _Boroda_
Дата добавления - 26.04.2016 в 13:33
Ипалит Дата: Вторник, 26.04.2016, 16:28 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Зачем вы объединяете столбцы. В вашем случае в этом нет надобности. Без объединения ячеек формула получается протягиваемая.

Потому, что имею дело с многоуровневыми шапками в таблицах. Примеры во вложении. За формулу спасибо.
К сообщению приложен файл: _Microsoft_Exce.xlsx(24Kb)
 
Ответить
Сообщение
Зачем вы объединяете столбцы. В вашем случае в этом нет надобности. Без объединения ячеек формула получается протягиваемая.

Потому, что имею дело с многоуровневыми шапками в таблицах. Примеры во вложении. За формулу спасибо.

Автор - Ипалит
Дата добавления - 26.04.2016 в 16:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счёт не пустых ячеек в двух диапазонах (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!