Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск разбросанных значений. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск разбросанных значений. (Формулы/Formulas)
Поиск разбросанных значений.
Ипалит Дата: Среда, 27.04.2016, 16:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
В очередной раз здравствуйте уважаемые форумчане. Необходимо собрать разбросанные значения в строках одного листа и собрать их в таблице по порядку, другого листа.
К сообщению приложен файл: _Microsoft_Exce.xls(50Kb)
 
Ответить
СообщениеВ очередной раз здравствуйте уважаемые форумчане. Необходимо собрать разбросанные значения в строках одного листа и собрать их в таблице по порядку, другого листа.

Автор - Ипалит
Дата добавления - 27.04.2016 в 16:53
Nic70y Дата: Среда, 27.04.2016, 17:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 760 ±
Замечаний: 0% ±

Excel 2013
Фильтр не?
К сообщению приложен файл: 7288756.xls(38Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеФильтр не?

Автор - Nic70y
Дата добавления - 27.04.2016 в 17:02
Ипалит Дата: Среда, 27.04.2016, 17:11 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Фильтр не?

Нет. Фильтр не вариант
 
Ответить
Сообщение
Фильтр не?

Нет. Фильтр не вариант

Автор - Ипалит
Дата добавления - 27.04.2016 в 17:11
Nic70y Дата: Среда, 27.04.2016, 17:23 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 760 ±
Замечаний: 0% ±

Excel 2013
не вариант
ну так не интересно :(
формула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(маневры!N$7:N$26;НАИМЕНЬШИЙ(ЕСЛИ(маневры!$N$7:$N$26<>"";СТРОКА(маневры!$N$7:$N$26)-6);СТРОКА(U1)));"")
и аналогично
К сообщению приложен файл: 3288610.xls(78Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
не вариант
ну так не интересно :(
формула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(маневры!N$7:N$26;НАИМЕНЬШИЙ(ЕСЛИ(маневры!$N$7:$N$26<>"";СТРОКА(маневры!$N$7:$N$26)-6);СТРОКА(U1)));"")
и аналогично

Автор - Nic70y
Дата добавления - 27.04.2016 в 17:23
Ипалит Дата: Среда, 27.04.2016, 20:33 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ну так не интересно :(
формула массива:

Большое спасибо никогда бы наверное не написал такое.
 
Ответить
Сообщение
ну так не интересно :(
формула массива:

Большое спасибо никогда бы наверное не написал такое.

Автор - Ипалит
Дата добавления - 27.04.2016 в 20:33
_Boroda_ Дата: Среда, 27.04.2016, 20:54 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9827
Репутация: 4148 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Похожий вариант, но немного подругее.
Формулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер.
Для столбца U формула (дает вагоны через дефис)
Код
=ЕСЛИОШИБКА(ИНДЕКС(маневры!$N$7:$N$99&ЕСЛИ(--маневры!$P$7:$P$99;"-"&маневры!$P$7:$P$99;"");НАИМЕНЬШИЙ(ЕСЛИ(--маневры!$N$7:$N$99;маневры!$A$7:$A$99);СТРОКА(U1)));)

Для всех остальных столбцов формула одинаковая протягиваемая вниз и вправо
Код
=ЕСЛИОШИБКА(ИНДЕКС(маневры!$F$7:$X$99;НАИМЕНЬШИЙ(ЕСЛИ(--маневры!$N$7:$N$99;маневры!$A$7:$A$99);СТРОКА(U1));(V$3="мин")+ПОИСКПОЗ(ЕСЛИ(V$2="";U$2;V$2);маневры!$F$3:$X$3&маневры!$F$4:$X$4&маневры!$F$5:$X$5;));)

Правда 3 столбца в Отчете нужно переименовать аналогично столбцам в Маневрах. В файле я их покрасил
К сообщению приложен файл: 0162750.xls(58Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПохожий вариант, но немного подругее.
Формулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер.
Для столбца U формула (дает вагоны через дефис)
Код
=ЕСЛИОШИБКА(ИНДЕКС(маневры!$N$7:$N$99&ЕСЛИ(--маневры!$P$7:$P$99;"-"&маневры!$P$7:$P$99;"");НАИМЕНЬШИЙ(ЕСЛИ(--маневры!$N$7:$N$99;маневры!$A$7:$A$99);СТРОКА(U1)));)

Для всех остальных столбцов формула одинаковая протягиваемая вниз и вправо
Код
=ЕСЛИОШИБКА(ИНДЕКС(маневры!$F$7:$X$99;НАИМЕНЬШИЙ(ЕСЛИ(--маневры!$N$7:$N$99;маневры!$A$7:$A$99);СТРОКА(U1));(V$3="мин")+ПОИСКПОЗ(ЕСЛИ(V$2="";U$2;V$2);маневры!$F$3:$X$3&маневры!$F$4:$X$4&маневры!$F$5:$X$5;));)

Правда 3 столбца в Отчете нужно переименовать аналогично столбцам в Маневрах. В файле я их покрасил

Автор - _Boroda_
Дата добавления - 27.04.2016 в 20:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск разбросанных значений. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!