Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск параметра из массива по трём критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск параметра из массива по трём критериям (Формулы/Formulas)
Поиск параметра из массива по трём критериям
KIMVSR Дата: Среда, 27.04.2016, 17:18 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 96
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте,

Подскажите, пожалуйста, как найти определённое значение из массива, ссылаясь сразу на три условия?

Я так понимаю, что при помощи мною нелюбимых функций INDEX и MATCH.
Только что-то не выходит...

Код
=INDEX(D6:L22;MATCH(B2&C2&D2;C6:C22&D4:L5;0))

Заранее спасибо!
К сообщению приложен файл: poles_calculati.xlsx(12Kb)


Сообщение отредактировал KIMVSR - Среда, 27.04.2016, 17:18
 
Ответить
СообщениеЗдравствуйте,

Подскажите, пожалуйста, как найти определённое значение из массива, ссылаясь сразу на три условия?

Я так понимаю, что при помощи мною нелюбимых функций INDEX и MATCH.
Только что-то не выходит...

Код
=INDEX(D6:L22;MATCH(B2&C2&D2;C6:C22&D4:L5;0))

Заранее спасибо!

Автор - KIMVSR
Дата добавления - 27.04.2016 в 17:18
_Boroda_ Дата: Среда, 27.04.2016, 17:22 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(D6:L22;ПОИСКПОЗ(D2;C6:C22);ПОИСКПОЗ(B2&C2;D4:L4&D5:L5;))

Код
=ИНДЕКС(D6:L22;ПОИСКПОЗ(B2;C6:C22);ПОИСКПОЗ(D2&C2;D4:L4&D5:L5;))

Или без нелюбимых
Код
=СУММПРОИЗВ(D6:L22*(D4:L4=D2)*(D5:L5=C2)*(C6:C22=B2))

Но с ними шустрее

Еще автопокраску в файл добавил
Ну и выбор из зависимых выпадающих списков в голубых ячейках
К сообщению приложен файл: 4084968.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(D6:L22;ПОИСКПОЗ(D2;C6:C22);ПОИСКПОЗ(B2&C2;D4:L4&D5:L5;))

Код
=ИНДЕКС(D6:L22;ПОИСКПОЗ(B2;C6:C22);ПОИСКПОЗ(D2&C2;D4:L4&D5:L5;))

Или без нелюбимых
Код
=СУММПРОИЗВ(D6:L22*(D4:L4=D2)*(D5:L5=C2)*(C6:C22=B2))

Но с ними шустрее

Еще автопокраску в файл добавил
Ну и выбор из зависимых выпадающих списков в голубых ячейках

Автор - _Boroda_
Дата добавления - 27.04.2016 в 17:22
jakim Дата: Среда, 27.04.2016, 19:26 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Для XL2013 подойдёт и такая формула.

Код
=IFERROR(AGGREGATE(15;6;D6:L22/(C6:C22=B2)/(D5:L5=C2)/(D4:L4=D2);1);"")
К сообщению приложен файл: 5759903.xlsx(13Kb)
 
Ответить
Сообщение
Для XL2013 подойдёт и такая формула.

Код
=IFERROR(AGGREGATE(15;6;D6:L22/(C6:C22=B2)/(D5:L5=C2)/(D4:L4=D2);1);"")

Автор - jakim
Дата добавления - 27.04.2016 в 19:26
KIMVSR Дата: Четверг, 28.04.2016, 08:17 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 96
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, jakim, ребят, блин, огромное спасибо! Выручили! yes
Саш, но согласись, что в этот раз я уже был близок со своими нелюбимыми ИНДЕКС и ПОИСКПОЗ! :D
Ну, подумаешь, одной ПОИСКПОЗ недосчитался..
За покраску отдельное спасибо, пытаюсь разобраться в твоём условном форматировании - там тоже космос! :D
 
Ответить
Сообщение_Boroda_, jakim, ребят, блин, огромное спасибо! Выручили! yes
Саш, но согласись, что в этот раз я уже был близок со своими нелюбимыми ИНДЕКС и ПОИСКПОЗ! :D
Ну, подумаешь, одной ПОИСКПОЗ недосчитался..
За покраску отдельное спасибо, пытаюсь разобраться в твоём условном форматировании - там тоже космос! :D

Автор - KIMVSR
Дата добавления - 28.04.2016 в 08:17
китин Дата: Четверг, 28.04.2016, 09:34 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и так можно. но с нелюбимыми :D
Код
=ПРОСМОТР($B$2;$C$6:$C$22;ИНДЕКС($D$6:$L$22;;ПОИСКПОЗ($D$2&$C$2;$D$4:$L$4&$D$5:$L$5;0)))
массивная


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи так можно. но с нелюбимыми :D
Код
=ПРОСМОТР($B$2;$C$6:$C$22;ИНДЕКС($D$6:$L$22;;ПОИСКПОЗ($D$2&$C$2;$D$4:$L$4&$D$5:$L$5;0)))
массивная

Автор - китин
Дата добавления - 28.04.2016 в 09:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск параметра из массива по трём критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!