Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отобразить кол-во одинаковых диапазонов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отобразить кол-во одинаковых диапазонов (Формулы/Formulas)
Отобразить кол-во одинаковых диапазонов
oeei Дата: Среда, 27.04.2016, 18:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Добрый вечер уважаемые форумчане!
Есть таблица с распределением оборудования (list2) по объектам. Всего имеем 14 единиц оборудования и очень много объектов.
Нужно в таблице на list1 отобразить все типы объектов (различаются по кол-ву оборудования).
А на list2 определить тип каждого объекта.
Помогите пожалуйста решить вопрос формулами.
К сообщению приложен файл: oeei.xls(48Kb)


Сообщение отредактировал oeei - Среда, 27.04.2016, 19:07
 
Ответить
СообщениеДобрый вечер уважаемые форумчане!
Есть таблица с распределением оборудования (list2) по объектам. Всего имеем 14 единиц оборудования и очень много объектов.
Нужно в таблице на list1 отобразить все типы объектов (различаются по кол-ву оборудования).
А на list2 определить тип каждого объекта.
Помогите пожалуйста решить вопрос формулами.

Автор - oeei
Дата добавления - 27.04.2016 в 18:46
Pelena Дата: Среда, 27.04.2016, 19:25 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9856
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Выделяем на list2 диапазон С1:Р10 -- копируем на list1, начиная с ячейки В1 -- в диапазоне В1:О10 удаляем дубликаты.
На list2 в ячейку Q2 формулу
Код
=ИНДЕКС(list1!$A$2:$A$100;ПОИСКПОЗ(14;МУМНОЖ(--(C2:P2=list1!$B$2:$O$100);СТРОКА($1:$14)^0);0))
К сообщению приложен файл: 5378362.xls(48Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Выделяем на list2 диапазон С1:Р10 -- копируем на list1, начиная с ячейки В1 -- в диапазоне В1:О10 удаляем дубликаты.
На list2 в ячейку Q2 формулу
Код
=ИНДЕКС(list1!$A$2:$A$100;ПОИСКПОЗ(14;МУМНОЖ(--(C2:P2=list1!$B$2:$O$100);СТРОКА($1:$14)^0);0))

Автор - Pelena
Дата добавления - 27.04.2016 в 19:25
oeei Дата: Четверг, 28.04.2016, 09:59 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
specool Спасибо большое.
 
Ответить
Сообщениеspecool Спасибо большое.

Автор - oeei
Дата добавления - 28.04.2016 в 09:59
_Boroda_ Дата: Четверг, 28.04.2016, 11:29 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9360
Репутация: 3935 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Немного другой подход. Автоматически все делает, без ручных телодвижений.
В Лист2 столбец Q формула массива (вводится одновременным нажатием Контрл Шифт Ентер), тянем ее вниз (формулу явно можно укоротить, написал особо не раздумывая)
Код
=ЕСЛИ(И(МУМНОЖ(--(C2:P2<>C$1:P1);СТРОКА($1:$14)^0));МАКС(Q$1:Q1)+1;ИНДЕКС(Q$1:Q1;ПОИСКПОЗ(;МУМНОЖ(--(C2:P2<>C$1:P1);СТРОКА($1:$14)^0);)))
и формат ячеек
тип0
В лист1 в столбце А пишем 1,2,3,... с аналогичным форматом и в В2 формула, которую тянем вправо-вниз
Код
=ЕСЛИОШИБКА(ИНДЕКС(list2!C$2:C$99;ПОИСКПОЗ($A2;list2!$Q$2:$Q$99;));"")
К сообщению приложен файл: oeei_1.xls(62Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНемного другой подход. Автоматически все делает, без ручных телодвижений.
В Лист2 столбец Q формула массива (вводится одновременным нажатием Контрл Шифт Ентер), тянем ее вниз (формулу явно можно укоротить, написал особо не раздумывая)
Код
=ЕСЛИ(И(МУМНОЖ(--(C2:P2<>C$1:P1);СТРОКА($1:$14)^0));МАКС(Q$1:Q1)+1;ИНДЕКС(Q$1:Q1;ПОИСКПОЗ(;МУМНОЖ(--(C2:P2<>C$1:P1);СТРОКА($1:$14)^0);)))
и формат ячеек
тип0
В лист1 в столбце А пишем 1,2,3,... с аналогичным форматом и в В2 формула, которую тянем вправо-вниз
Код
=ЕСЛИОШИБКА(ИНДЕКС(list2!C$2:C$99;ПОИСКПОЗ($A2;list2!$Q$2:$Q$99;));"")

Автор - _Boroda_
Дата добавления - 28.04.2016 в 11:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отобразить кол-во одинаковых диапазонов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!