Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/расчет интервала между ячейками по цветам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет интервала между ячейками по цветам (Формулы/Formulas)
расчет интервала между ячейками по цветам
ofar989 Дата: Понедельник, 09.05.2016, 18:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте дорогие друзья,не могу решить задачу....если можете помогите пожалуста.
Имею столбец с цифрами(цифры от 1 до 42),каждой цифре конкретно соответствует свой цвет (желтый или черный).>файл который прикреплен видно какие цифры какого цвета.
Нужно извелчить интервалы очередности повторяющихся неповторяющихся ячеек написать интервал зазора где нибудь.
буду очень признателен если поможете :(
 
Ответить
СообщениеЗдравствуйте дорогие друзья,не могу решить задачу....если можете помогите пожалуста.
Имею столбец с цифрами(цифры от 1 до 42),каждой цифре конкретно соответствует свой цвет (желтый или черный).>файл который прикреплен видно какие цифры какого цвета.
Нужно извелчить интервалы очередности повторяющихся неповторяющихся ячеек написать интервал зазора где нибудь.
буду очень признателен если поможете :(

Автор - ofar989
Дата добавления - 09.05.2016 в 18:18
ofar989 Дата: Понедельник, 09.05.2016, 18:20 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Картинка и файл
К сообщению приложен файл: 4102489.jpg(29Kb) · 6554582.xlsx(15Kb)
 
Ответить
СообщениеКартинка и файл

Автор - ofar989
Дата добавления - 09.05.2016 в 18:20
Roman777 Дата: Понедельник, 09.05.2016, 18:40 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 720
Репутация: 78 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
ofar989, чисто по окрашиванию если, придётся средствами VBA (макросов) делать. Но если Вы знаете логику окрашивания, то можно проследить по логике и посчитать интервалы формульно.


Много чего не знаю!!!!

Сообщение отредактировал Roman777 - Понедельник, 09.05.2016, 18:40
 
Ответить
Сообщениеofar989, чисто по окрашиванию если, придётся средствами VBA (макросов) делать. Но если Вы знаете логику окрашивания, то можно проследить по логике и посчитать интервалы формульно.

Автор - Roman777
Дата добавления - 09.05.2016 в 18:40
SLAVICK Дата: Понедельник, 09.05.2016, 18:51 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1926
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
каждой цифре конкретно соответствует свой цвет (желтый или черный)

Следующий раз - уточняйте - не цвет а правило УФ.
Макрос не "видит" цвет, который возвращает УФ.
Поэтому для Вашего случая - я взял формулу Вашего УФ и вставил ее правее - см. зеленые ячейки.
А далее макрос:
[vba]
Код
Sub d()
Dim r As Range
Set r = Application.InputBox("select range", , Selection.Address, , , , , Type:=8)
If r Is Nothing Then Exit Sub
n = r.Rows.Count: i = 1
With r
    Do While i <= n
        Do
        i = i + 1: t = t + 1
        Loop While i <= n And .Cells(i, 1) = .Cells(i - 1, 1)
        .Cells(i - 1, 1).Offset(0, 2) = t: t = 0 ' на сколько столбцов смещение
    Loop
End With
End Sub
[/vba]
К сообщению приложен файл: 6554582.xlsm(25Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
каждой цифре конкретно соответствует свой цвет (желтый или черный)

Следующий раз - уточняйте - не цвет а правило УФ.
Макрос не "видит" цвет, который возвращает УФ.
Поэтому для Вашего случая - я взял формулу Вашего УФ и вставил ее правее - см. зеленые ячейки.
А далее макрос:
[vba]
Код
Sub d()
Dim r As Range
Set r = Application.InputBox("select range", , Selection.Address, , , , , Type:=8)
If r Is Nothing Then Exit Sub
n = r.Rows.Count: i = 1
With r
    Do While i <= n
        Do
        i = i + 1: t = t + 1
        Loop While i <= n And .Cells(i, 1) = .Cells(i - 1, 1)
        .Cells(i - 1, 1).Offset(0, 2) = t: t = 0 ' на сколько столбцов смещение
    Loop
End With
End Sub
[/vba]

Автор - SLAVICK
Дата добавления - 09.05.2016 в 18:51
ofar989 Дата: Понедельник, 09.05.2016, 19:58 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
SLAVICK ваша программа работает как нужно спасибо
а можно это всё делать ну с формулой без vba, потому что с результатами буду опять что то посчитать функциями?
(2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42)=>эти цифры черные, а остальные зеленые,если это чего то даст для формул
огромное спасибо что откликнулись
 
Ответить
СообщениеSLAVICK ваша программа работает как нужно спасибо
а можно это всё делать ну с формулой без vba, потому что с результатами буду опять что то посчитать функциями?
(2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42)=>эти цифры черные, а остальные зеленые,если это чего то даст для формул
огромное спасибо что откликнулись

Автор - ofar989
Дата добавления - 09.05.2016 в 19:58
SLAVICK Дата: Понедельник, 09.05.2016, 20:12 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 1926
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Явно можно оптимизировать, и запихнуть в одну формулу - но сейчас - лениво. ^_^
Вот формулами:
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A2;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0))=
ЕОШИБКА(ПОИСКПОЗ(A1;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0));L1+1;1)


и потом:
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A3;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0))=
ЕОШИБКА(ПОИСКПОЗ(A2;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0));"";L2)
К сообщению приложен файл: 6554582-1-.xlsm(26Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеЯвно можно оптимизировать, и запихнуть в одну формулу - но сейчас - лениво. ^_^
Вот формулами:
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A2;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0))=
ЕОШИБКА(ПОИСКПОЗ(A1;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0));L1+1;1)


и потом:
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A3;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0))=
ЕОШИБКА(ПОИСКПОЗ(A2;{2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42};0));"";L2)

Автор - SLAVICK
Дата добавления - 09.05.2016 в 20:12
ofar989 Дата: Понедельник, 09.05.2016, 22:57 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
стремящейся до ∞ спасибо вам hands hands hands hands
то что я искал victory victory
 
Ответить
Сообщениестремящейся до ∞ спасибо вам hands hands hands hands
то что я искал victory victory

Автор - ofar989
Дата добавления - 09.05.2016 в 22:57
_Boroda_ Дата: Понедельник, 09.05.2016, 23:10 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9834
Репутация: 4152 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант: в J1 пишем вот так (вначале и в конце по ;)
;2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42;
в J2 и ниже формула (и вправо тоже)
Код
=ЕСЛИ(A3*(ЕОШ(ПОИСК(";"&A2&";";$J$1))=ЕОШ(ПОИСК(";"&A3&";";$J$1)));"";ЕСЛИОШИБКА(СТРОКА()-ПРОСМОТР(;-1/(ЕОШ(ПОИСК(";"&A2&";";$J$1))<>ЕОШ(ПОИСК(";"&A$2:A2&";";$J$1)));СТРОКА(A$2:A2));1))
К сообщению приложен файл: 6554582_1.xlsx(47Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант: в J1 пишем вот так (вначале и в конце по ;)
;2;4;6;7;9;11;14;16;18;19;21;23;25;28;30;31;33;35;38;40;42;
в J2 и ниже формула (и вправо тоже)
Код
=ЕСЛИ(A3*(ЕОШ(ПОИСК(";"&A2&";";$J$1))=ЕОШ(ПОИСК(";"&A3&";";$J$1)));"";ЕСЛИОШИБКА(СТРОКА()-ПРОСМОТР(;-1/(ЕОШ(ПОИСК(";"&A2&";";$J$1))<>ЕОШ(ПОИСК(";"&A$2:A2&";";$J$1)));СТРОКА(A$2:A2));1))

Автор - _Boroda_
Дата добавления - 09.05.2016 в 23:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет интервала между ячейками по цветам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!