Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/не могу правильно сформулировать ВПР формулу? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » не могу правильно сформулировать ВПР формулу? (Формулы/Formulas)
не могу правильно сформулировать ВПР формулу?
Пытливый Дата: Вторник, 10.05.2016, 11:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
Здравствуйте!
Мы имеем: Вася, Вася*, Вася** и т.д.
* - добавляется при новом значении
Мне надо чтоб формула понимала что "Вася" это не "Вася*" и не "Вася**"
Обозначение типа: A2(Вася)&"*" - не работает;
A2(Вася)+"*" - выдает ошибку.

я составил формулу типа:
Код
ЕСЛИ(ВПР(A2;Лист1!B:D;3;0)="";"";ТЕКСТ(ВПР(A2;Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2;Лист1!B:D;2;0)&" гр.")&ЕСЛИ(ВПР(A2&"*";Лист1!B:D;3;0)="";"";"
"&ТЕКСТ(ВПР(A2&"*";Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2&"*";Лист1!B:D;2;0)&" гр.")


Что не так?
К сообщению приложен файл: 4501558.xlsx(10Kb)


Сообщение отредактировал Пытливый - Вторник, 10.05.2016, 13:35
 
Ответить
СообщениеЗдравствуйте!
Мы имеем: Вася, Вася*, Вася** и т.д.
* - добавляется при новом значении
Мне надо чтоб формула понимала что "Вася" это не "Вася*" и не "Вася**"
Обозначение типа: A2(Вася)&"*" - не работает;
A2(Вася)+"*" - выдает ошибку.

я составил формулу типа:
Код
ЕСЛИ(ВПР(A2;Лист1!B:D;3;0)="";"";ТЕКСТ(ВПР(A2;Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2;Лист1!B:D;2;0)&" гр.")&ЕСЛИ(ВПР(A2&"*";Лист1!B:D;3;0)="";"";"
"&ТЕКСТ(ВПР(A2&"*";Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2&"*";Лист1!B:D;2;0)&" гр.")


Что не так?

Автор - Пытливый
Дата добавления - 10.05.2016 в 11:08
buchlotnik Дата: Вторник, 10.05.2016, 13:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
когда ищете именно звёздочку перед ней надо тильду ставить
Код
=ЕСЛИ(ВПР(A2;Лист1!B:D;3;0)="";"";ТЕКСТ(ВПР(A2;Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2;Лист1!B:D;2;0)&" гр.")&ЕСЛИ(ВПР(A2&"~*";Лист1!B:D;3;0)="";"";"
"&ТЕКСТ(ВПР(A2&"~*";Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2&"~*";Лист1!B:D;2;0)&" гр.")

[moder] Пытливый, стерли замечание модератора и думаете, что прокатит? Этот комментарий я не в Вашем посте напишу.

Михаила buchlotnik Вы обманули, но я-то помню, что в замечании писал про название темы, которое Вы так и не поправили.

Пытливый, Вас учили, что за все платить нужно? За хитрость тоже. Ловите еще 2 замечания и бан на 5 дней.
К сообщению приложен файл: 1197703.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал _Boroda_ - Вторник, 10.05.2016, 14:26
 
Ответить
Сообщениекогда ищете именно звёздочку перед ней надо тильду ставить
Код
=ЕСЛИ(ВПР(A2;Лист1!B:D;3;0)="";"";ТЕКСТ(ВПР(A2;Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2;Лист1!B:D;2;0)&" гр.")&ЕСЛИ(ВПР(A2&"~*";Лист1!B:D;3;0)="";"";"
"&ТЕКСТ(ВПР(A2&"~*";Лист1!B:D;3;0);"ДД.ММ.ГГГГ")&"
"&ВПР(A2&"~*";Лист1!B:D;2;0)&" гр.")

[moder] Пытливый, стерли замечание модератора и думаете, что прокатит? Этот комментарий я не в Вашем посте напишу.

Михаила buchlotnik Вы обманули, но я-то помню, что в замечании писал про название темы, которое Вы так и не поправили.

Пытливый, Вас учили, что за все платить нужно? За хитрость тоже. Ловите еще 2 замечания и бан на 5 дней.

Автор - buchlotnik
Дата добавления - 10.05.2016 в 13:52
Пытливый Дата: Вторник, 10.05.2016, 14:01 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
buchlotnik, Огромное спасибо!!!
 
Ответить
Сообщениеbuchlotnik, Огромное спасибо!!!

Автор - Пытливый
Дата добавления - 10.05.2016 в 14:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » не могу правильно сформулировать ВПР формулу? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!