Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение времени событий по определенным условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение времени событий по определенным условиям (Формулы/Formulas)
Сравнение времени событий по определенным условиям
RebelSEA Дата: Пятница, 13.05.2016, 17:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые знатоки Excel. Появилась одна интересная задача, но пока не могу понять, как я ее решить с помощью формул. Прошу вашей помощи.
Есть таблица со списком заказов в столбце А. В столбце B указан тип события. Их два: планируемый звонок и исходящий звонок. В столбце C время события. С помощью формулы нужно выявить все случаи, где время планируемого звонка отличается от времени исходящего звонка на 30 минут в любую сторону. Файл прилагается.
К сообщению приложен файл: 1013696.xls(24Kb)


Сообщение отредактировал RebelSEA - Пятница, 13.05.2016, 17:31
 
Ответить
СообщениеЗдравствуйте, уважаемые знатоки Excel. Появилась одна интересная задача, но пока не могу понять, как я ее решить с помощью формул. Прошу вашей помощи.
Есть таблица со списком заказов в столбце А. В столбце B указан тип события. Их два: планируемый звонок и исходящий звонок. В столбце C время события. С помощью формулы нужно выявить все случаи, где время планируемого звонка отличается от времени исходящего звонка на 30 минут в любую сторону. Файл прилагается.

Автор - RebelSEA
Дата добавления - 13.05.2016 в 17:23
Gustav Дата: Пятница, 13.05.2016, 17:54 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1410
Репутация: 541 ±
Замечаний: 0% ±

начинал с Excel 4.0...
У Вас по первой же заявке 437020 пять звонков: 2 планируемых и 3 исходящих. Что с чем сопоставлять?


Мой tip box - яд 41001663842605
 
Ответить
СообщениеУ Вас по первой же заявке 437020 пять звонков: 2 планируемых и 3 исходящих. Что с чем сопоставлять?

Автор - Gustav
Дата добавления - 13.05.2016 в 17:54
RebelSEA Дата: Пятница, 13.05.2016, 18:27 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Скорректирую немного для облегчения понимания. Нужно убедиться, что для каждого планируемого звонка есть исходящий в пределах 30 минут в любую сторону. Например, есть планируемый звонок в 16:00, соответственно должен быть исходящий в период с 15:30 до 16:30. Нужно выявить заявки, у которых такой исходящий отсутствует.
 
Ответить
СообщениеСкорректирую немного для облегчения понимания. Нужно убедиться, что для каждого планируемого звонка есть исходящий в пределах 30 минут в любую сторону. Например, есть планируемый звонок в 16:00, соответственно должен быть исходящий в период с 15:30 до 16:30. Нужно выявить заявки, у которых такой исходящий отсутствует.

Автор - RebelSEA
Дата добавления - 13.05.2016 в 18:27
Gustav Дата: Пятница, 13.05.2016, 18:35 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1410
Репутация: 541 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Я уже прикинул эвристически, что звонков должна быть пара в пределах суток. С этими допущениями и сваял первое приближение.

Самый первый звонок, кстати, без пары.
К сообщению приложен файл: 1013696_03.xls(26Kb)


Мой tip box - яд 41001663842605
 
Ответить
СообщениеЯ уже прикинул эвристически, что звонков должна быть пара в пределах суток. С этими допущениями и сваял первое приближение.

Самый первый звонок, кстати, без пары.

Автор - Gustav
Дата добавления - 13.05.2016 в 18:35
Manyasha Дата: Пятница, 13.05.2016, 18:50 | Сообщение № 5
Группа: Модераторы
Ранг: Старожил
Сообщений: 1967
Репутация: 816 ±
Замечаний: 0% ±

Excel 2010, 2016
У меня вот так получилось:
Код
=ЕСЛИ(B2="Исходящий звонок";"";ЕСЛИ(ЕНД(ПОИСКПОЗ(1;ЕСЛИ(($A$2:$A$10=A2)*($B$2:$B$10="Исходящий звонок");--(ABS($C$2:$C$10-C2)<=1/48);"");0));"Нет";"Есть"))

формула массива, вводить через ctrl+shift+enter
К сообщению приложен файл: 1013696-1.xls(27Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеУ меня вот так получилось:
Код
=ЕСЛИ(B2="Исходящий звонок";"";ЕСЛИ(ЕНД(ПОИСКПОЗ(1;ЕСЛИ(($A$2:$A$10=A2)*($B$2:$B$10="Исходящий звонок");--(ABS($C$2:$C$10-C2)<=1/48);"");0));"Нет";"Есть"))

формула массива, вводить через ctrl+shift+enter

Автор - Manyasha
Дата добавления - 13.05.2016 в 18:50
AlexM Дата: Пятница, 13.05.2016, 19:00 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3585
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Формула массива
Код
=ЕСЛИ("План"=ЛЕВБ(B2;4);--ИЛИ(ABS(C2-(A2=A$2:A$10)*("Исхо"=ЛЕВБ(B$2:B$10;4))*C$2:C$10)<=1/48);"")
Формат ячеек "ЕСТЬ";;"НЕТ"
К сообщению приложен файл: 1013696_04.xls(26Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИ("План"=ЛЕВБ(B2;4);--ИЛИ(ABS(C2-(A2=A$2:A$10)*("Исхо"=ЛЕВБ(B$2:B$10;4))*C$2:C$10)<=1/48);"")
Формат ячеек "ЕСТЬ";;"НЕТ"

Автор - AlexM
Дата добавления - 13.05.2016 в 19:00
Nic70y Дата: Суббота, 14.05.2016, 09:33 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2013
немассивная, для "молодых" версий
Код
=ЕСЛИ(B2="Планируемый звонок";ЕСЛИ(СЧЁТЕСЛИМН(A$2:A$10;A2;B$2:B$10;"<>Планируемый звонок";C$2:C$10;">="&C2-1/48;C$2:C$10;"<="&C2+1/48);"ЕСТЬ";"НЕТ");"")
К сообщению приложен файл: 1013696_07.xls(25Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенемассивная, для "молодых" версий
Код
=ЕСЛИ(B2="Планируемый звонок";ЕСЛИ(СЧЁТЕСЛИМН(A$2:A$10;A2;B$2:B$10;"<>Планируемый звонок";C$2:C$10;">="&C2-1/48;C$2:C$10;"<="&C2+1/48);"ЕСТЬ";"НЕТ");"")

Автор - Nic70y
Дата добавления - 14.05.2016 в 09:33
RebelSEA Дата: Понедельник, 16.05.2016, 16:02 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем спасибо! Предложенные варианты работают.
 
Ответить
СообщениеВсем спасибо! Предложенные варианты работают.

Автор - RebelSEA
Дата добавления - 16.05.2016 в 16:02
_Boroda_ Дата: Понедельник, 16.05.2016, 16:41 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Формула массива
Код
=ЕСЛИ(ЛЕВБ(B2)="п";ИЛИ(ЛЕВБ((C$2:C$10*(ЛЕВБ(B$2:B$10)="и")+1/48-C2)*24)="0");"")

Обычная формула
Код
=ЕСЛИ(ЛЕВБ(B2)="п";СУММПРОИЗВ(Ч(ЛЕВБ((C$2:C$10*(ЛЕВБ(B$2:B$10)="и")+1/48-C2)*24)="0"));"")
К сообщению приложен файл: 1013696_04_01.xls(27Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Формула массива
Код
=ЕСЛИ(ЛЕВБ(B2)="п";ИЛИ(ЛЕВБ((C$2:C$10*(ЛЕВБ(B$2:B$10)="и")+1/48-C2)*24)="0");"")

Обычная формула
Код
=ЕСЛИ(ЛЕВБ(B2)="п";СУММПРОИЗВ(Ч(ЛЕВБ((C$2:C$10*(ЛЕВБ(B$2:B$10)="и")+1/48-C2)*24)="0"));"")

Автор - _Boroda_
Дата добавления - 16.05.2016 в 16:41
RebelSEA Дата: Вторник, 17.05.2016, 10:21 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Manyasha, возник вопрос. А для чего используется бинарное отрицание перед функцией ABS?
 
Ответить
СообщениеManyasha, возник вопрос. А для чего используется бинарное отрицание перед функцией ABS?

Автор - RebelSEA
Дата добавления - 17.05.2016 в 10:21
Manyasha Дата: Вторник, 17.05.2016, 10:39 | Сообщение № 11
Группа: Модераторы
Ранг: Старожил
Сообщений: 1967
Репутация: 816 ±
Замечаний: 0% ±

Excel 2010, 2016
RebelSEA, кусочек
Код
(ABS($C$2:$C$10-C2)<=1/48)
вернет значение ИСТИНА или ЛОЖЬ, значит ЕСЛИ(($A$2:$A$10... вернет массив из значений Истина и Ложь.
А в функции Поискпоз мы ищем 1 в этом массиве.
Значит, чтобы Поискпоз вернул какой-нибудь результат, нужно либо Истина/Ложь превратить в 1/0, либо искать значение Истина.

Кстати, можно в кусочке
Код
ЕСЛИ(($A$2:$A$10=A2)*($B$2:$B$10="Исходящий звонок");--(ABS($C$2:$C$10-C2)<=1/48);"")
убрать "" в конце.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеRebelSEA, кусочек
Код
(ABS($C$2:$C$10-C2)<=1/48)
вернет значение ИСТИНА или ЛОЖЬ, значит ЕСЛИ(($A$2:$A$10... вернет массив из значений Истина и Ложь.
А в функции Поискпоз мы ищем 1 в этом массиве.
Значит, чтобы Поискпоз вернул какой-нибудь результат, нужно либо Истина/Ложь превратить в 1/0, либо искать значение Истина.

Кстати, можно в кусочке
Код
ЕСЛИ(($A$2:$A$10=A2)*($B$2:$B$10="Исходящий звонок");--(ABS($C$2:$C$10-C2)<=1/48);"")
убрать "" в конце.

Автор - Manyasha
Дата добавления - 17.05.2016 в 10:39
RebelSEA Дата: Вторник, 17.05.2016, 12:32 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Manyasha, просто я попробовал без бинарного отрицания, и формула работает. Эксель приравнивает 1 к ИСТИНА и 0 к ЛОЖЬ в таких функциях.
"Кстати, можно в кусочке убрать "" в конце", точно, а можно поставить 0.
 
Ответить
СообщениеManyasha, просто я попробовал без бинарного отрицания, и формула работает. Эксель приравнивает 1 к ИСТИНА и 0 к ЛОЖЬ в таких функциях.
"Кстати, можно в кусочке убрать "" в конце", точно, а можно поставить 0.

Автор - RebelSEA
Дата добавления - 17.05.2016 в 12:32
Manyasha Дата: Вторник, 17.05.2016, 14:40 | Сообщение № 13
Группа: Модераторы
Ранг: Старожил
Сообщений: 1967
Репутация: 816 ±
Замечаний: 0% ±

Excel 2010, 2016
формула работает

А Вы уверены, что она правильно работает? Смотрите файл.
К сообщению приложен файл: 1013696-2.xls(28Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщение
формула работает

А Вы уверены, что она правильно работает? Смотрите файл.

Автор - Manyasha
Дата добавления - 17.05.2016 в 14:40
RebelSEA Дата: Четверг, 19.05.2016, 16:43 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Manyasha, да, точно. Проверил еще раз. Странно, видимо, в первый раз что-то не учел.
Кстати, у вас во втором столбце(с бинарным отрицанием) формула массива, а в первом нет.
[moder]Ну да, это я так "хорошо" формулу протянула.[/moder]


Сообщение отредактировал Manyasha - Четверг, 19.05.2016, 17:15
 
Ответить
СообщениеManyasha, да, точно. Проверил еще раз. Странно, видимо, в первый раз что-то не учел.
Кстати, у вас во втором столбце(с бинарным отрицанием) формула массива, а в первом нет.
[moder]Ну да, это я так "хорошо" формулу протянула.[/moder]

Автор - RebelSEA
Дата добавления - 19.05.2016 в 16:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение времени событий по определенным условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!