Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка уникальных значений из диапазона (+ доп. критерии) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка уникальных значений из диапазона (+ доп. критерии) (Формулы/Formulas)
Выборка уникальных значений из диапазона (+ доп. критерии)
Endrus1 Дата: Четверг, 19.05.2016, 12:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые эксперты по Excel!

Прошу помочь с решением задачи:

Необходимо реализовать с помощью формул массива выборку уникальных значений - администраторов парикмахерской. Дополнительные критерии отбора - кол-во смен за период + временной интервал.

Файл прикрепляю. Комментарии разместил в примечаниях к ячейкам

P.S. Прошу сообщить, если сложность моей задачи тянет уже на платную помощь :)

Спасибо!
К сообщению приложен файл: ___.xlsx(28Kb)
 
Ответить
СообщениеДобрый день, уважаемые эксперты по Excel!

Прошу помочь с решением задачи:

Необходимо реализовать с помощью формул массива выборку уникальных значений - администраторов парикмахерской. Дополнительные критерии отбора - кол-во смен за период + временной интервал.

Файл прикрепляю. Комментарии разместил в примечаниях к ячейкам

P.S. Прошу сообщить, если сложность моей задачи тянет уже на платную помощь :)

Спасибо!

Автор - Endrus1
Дата добавления - 19.05.2016 в 12:02
китин Дата: Четверг, 19.05.2016, 12:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3673
Репутация: 573 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Проверяйте
К сообщению приложен файл: 987654.xlsx(31Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 19.05.2016, 12:55
 
Ответить
СообщениеПроверяйте

Автор - китин
Дата добавления - 19.05.2016 в 12:50
Endrus1 Дата: Четверг, 19.05.2016, 13:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Проверяйте

китин, Превосходно!! hands
А можно только еще поправить список админов - чтобы выводились только те, кто проходит по условию "Мин. кол-во смен"?

Т.е., в высланном примере - что скрывались еще и "Андреева" и "Котылёва"

+ Значение "Ср.чек" предполагалось как арифметическое среднее от значений "Средний чек" (Сводка!А11:А11)

На примере Дмитриевой. В выборку 1.03-31.03 попало 5 смен, в которые она выходила. Средние чеки, соответственно, были:
1262,5
793,4
606,4
1143,1
1120,6

Таким образом, в ячейке "Админы!G10" должно быть (1262,5+793,4+606,4+1143,1+1120,6)/5 = 985,2

Спасибо!


Сообщение отредактировал Endrus1 - Четверг, 19.05.2016, 13:37
 
Ответить
Сообщение
Проверяйте

китин, Превосходно!! hands
А можно только еще поправить список админов - чтобы выводились только те, кто проходит по условию "Мин. кол-во смен"?

Т.е., в высланном примере - что скрывались еще и "Андреева" и "Котылёва"

+ Значение "Ср.чек" предполагалось как арифметическое среднее от значений "Средний чек" (Сводка!А11:А11)

На примере Дмитриевой. В выборку 1.03-31.03 попало 5 смен, в которые она выходила. Средние чеки, соответственно, были:
1262,5
793,4
606,4
1143,1
1120,6

Таким образом, в ячейке "Админы!G10" должно быть (1262,5+793,4+606,4+1143,1+1120,6)/5 = 985,2

Спасибо!

Автор - Endrus1
Дата добавления - 19.05.2016 в 13:35
китин Дата: Четверг, 19.05.2016, 13:55 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3673
Репутация: 573 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
поправить список админов
легко !!! массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС(Сводка!$B$23:$CM$23;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Сводка!$B$23:$CM$23;Сводка!$B$23:$CM$23;0)=СТОЛБЕЦ(Сводка!$B$23:$CM$23)-1)*(СЧЁТЕСЛИ(Сводка!$B$23:$CM$23;Сводка!$B$23:$CM$23)>Админы!$J$3);СТОЛБЕЦ(Сводка!$B$23:$CM$23)-1);СТРОКА(A1)));"")
К сообщению приложен файл: 987654-2.xlsx(31Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
поправить список админов
легко !!! массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС(Сводка!$B$23:$CM$23;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Сводка!$B$23:$CM$23;Сводка!$B$23:$CM$23;0)=СТОЛБЕЦ(Сводка!$B$23:$CM$23)-1)*(СЧЁТЕСЛИ(Сводка!$B$23:$CM$23;Сводка!$B$23:$CM$23)>Админы!$J$3);СТОЛБЕЦ(Сводка!$B$23:$CM$23)-1);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 19.05.2016 в 13:55
Endrus1 Дата: Четверг, 19.05.2016, 15:35 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Китин, Вы истинный маг и чародей! Все работает, прямо как во сне!! Восторгу моему нет предела!! Спасибо огроменное!!! clap clap clap
 
Ответить
СообщениеКитин, Вы истинный маг и чародей! Все работает, прямо как во сне!! Восторгу моему нет предела!! Спасибо огроменное!!! clap clap clap

Автор - Endrus1
Дата добавления - 19.05.2016 в 15:35
jakim Дата: Четверг, 19.05.2016, 16:33 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 708
Репутация: 182 ±
Замечаний: 0% ±

Как я понял, то так проще и точнее.
Обратите внимание на общее количество смен.
У Вас есть различия в фамилиях администраторов в списках.
К сообщению приложен файл: 2735832.xlsx(32Kb)
 
Ответить
Сообщение
Как я понял, то так проще и точнее.
Обратите внимание на общее количество смен.
У Вас есть различия в фамилиях администраторов в списках.

Автор - jakim
Дата добавления - 19.05.2016 в 16:33
Endrus1 Дата: Четверг, 19.05.2016, 17:55 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
jakim, Благодарю за уделенное время. Решение Китина мне подошло больше)
 
Ответить
Сообщениеjakim, Благодарю за уделенное время. Решение Китина мне подошло больше)

Автор - Endrus1
Дата добавления - 19.05.2016 в 17:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка уникальных значений из диапазона (+ доп. критерии) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!