Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена одинаковых чисел на заданные - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена одинаковых чисел на заданные (Формулы/Formulas)
Замена одинаковых чисел на заданные
n0leg68 Дата: Пятница, 20.05.2016, 14:09 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
В таблице РЕШЕНИЕ должны быть все числа из столбца А с условием,что если в столбце А есть числа как в столбце Е, то они меняются на числа какие в столбце С.

Т.е. число 8448648 должно поменяться на 30303030
Т.е. число 48648648 должно поменяться на 202020 и т. д.

Если чисел как в столбце Е нет, то они остаются как и были.
К сообщению приложен файл: _Microsoft_Offi.xlsx(11Kb)
 
Ответить
СообщениеВ таблице РЕШЕНИЕ должны быть все числа из столбца А с условием,что если в столбце А есть числа как в столбце Е, то они меняются на числа какие в столбце С.

Т.е. число 8448648 должно поменяться на 30303030
Т.е. число 48648648 должно поменяться на 202020 и т. д.

Если чисел как в столбце Е нет, то они остаются как и были.

Автор - n0leg68
Дата добавления - 20.05.2016 в 14:09
akobir Дата: Пятница, 20.05.2016, 14:19 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
В лоб:
Код
=ЕСЛИ(A2=$E$2;$C$2;ЕСЛИ(A2=$E$3;$C$3;ЕСЛИ(A2=$E$4;$C$4;A2)))
К сообщению приложен файл: 4228703.xlsx(12Kb)


e-mail: akobir.ismailov@gmail.com
 
Ответить
СообщениеВ лоб:
Код
=ЕСЛИ(A2=$E$2;$C$2;ЕСЛИ(A2=$E$3;$C$3;ЕСЛИ(A2=$E$4;$C$4;A2)))

Автор - akobir
Дата добавления - 20.05.2016 в 14:19
buchlotnik Дата: Пятница, 20.05.2016, 14:20 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$C$4;ПОИСКПОЗ(A2;$E$2:$E$4;0));A2)
К сообщению приложен файл: 3597125.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$C$4;ПОИСКПОЗ(A2;$E$2:$E$4;0));A2)

Автор - buchlotnik
Дата добавления - 20.05.2016 в 14:20
pabchek Дата: Пятница, 20.05.2016, 14:20 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Так надо?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(A2;E$2:E$4;C$2:C$4);A2)
К сообщению приложен файл: 3297458.xlsx(12Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте. Так надо?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(A2;E$2:E$4;C$2:C$4);A2)

Автор - pabchek
Дата добавления - 20.05.2016 в 14:20
ArkaIIIa Дата: Пятница, 20.05.2016, 14:23 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 858
Репутация: 114 ±
Замечаний: 0% ±

2010
Еще вариант:
Код
=ЕСЛИ(СЧЁТЕСЛИ($E$2:$E$4;A2);ПРОСМОТР(A2;$E$2:$E$4;$C$2:$C$4);A2)
 
Ответить
СообщениеЕще вариант:
Код
=ЕСЛИ(СЧЁТЕСЛИ($E$2:$E$4;A2);ПРОСМОТР(A2;$E$2:$E$4;$C$2:$C$4);A2)

Автор - ArkaIIIa
Дата добавления - 20.05.2016 в 14:23
ArkaIIIa Дата: Пятница, 20.05.2016, 14:23 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 858
Репутация: 114 ±
Замечаний: 0% ±

2010
Хм, да, у pabchek покороче.
 
Ответить
СообщениеХм, да, у pabchek покороче.

Автор - ArkaIIIa
Дата добавления - 20.05.2016 в 14:23
akobir Дата: Пятница, 20.05.2016, 14:28 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
ArkaIIIa, даже "в лоб" покороче получилось. :)


e-mail: akobir.ismailov@gmail.com
 
Ответить
СообщениеArkaIIIa, даже "в лоб" покороче получилось. :)

Автор - akobir
Дата добавления - 20.05.2016 в 14:28
n0leg68 Дата: Пятница, 20.05.2016, 14:31 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
Все варианты правильно, спасибо))))
 
Ответить
СообщениеВсе варианты правильно, спасибо))))

Автор - n0leg68
Дата добавления - 20.05.2016 в 14:31
_Boroda_ Дата: Пятница, 20.05.2016, 14:51 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9360
Репутация: 3935 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант (массивный)
Код
=МАКС(ЕСЛИ(A2=E$2:E$4;C$2:C$4-A2))+A2
К сообщению приложен файл: 725852.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант (массивный)
Код
=МАКС(ЕСЛИ(A2=E$2:E$4;C$2:C$4-A2))+A2

Автор - _Boroda_
Дата добавления - 20.05.2016 в 14:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена одинаковых чисел на заданные (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!