Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счёт по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счёт по нескольким условиям (Формулы/Formulas)
Счёт по нескольким условиям
Sony Дата: Суббота, 21.05.2016, 23:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Приветствую знатоков!
Помогите решить в общем-то не сложную задачку. Просто я зашел в тупик...

В ячейках F24:27 нужно посчитать количество дней из диапазона F2:F10 c критерием из столбца (1-е условие, второе- ячейка в столбце F - <>) .

В соседней ячейке, где нужно сложить часы (G24:27) это решается просто формулой СУММЕСЛИ, в формулах счета (СЧЕТЕСЛИ, СЧЁТЕСЛИМН) нет диапазона суммирования, СЧЁТЗ тоже не совсем то. Побывал их применять совместно и прочие варианты на что фантазии хватило, итог один- сплошной счёт по столбцу.
К сообщению приложен файл: 6165970.xlsx(14Kb)


Сообщение отредактировал Sony - Суббота, 21.05.2016, 23:41
 
Ответить
СообщениеПриветствую знатоков!
Помогите решить в общем-то не сложную задачку. Просто я зашел в тупик...

В ячейках F24:27 нужно посчитать количество дней из диапазона F2:F10 c критерием из столбца (1-е условие, второе- ячейка в столбце F - <>) .

В соседней ячейке, где нужно сложить часы (G24:27) это решается просто формулой СУММЕСЛИ, в формулах счета (СЧЕТЕСЛИ, СЧЁТЕСЛИМН) нет диапазона суммирования, СЧЁТЗ тоже не совсем то. Побывал их применять совместно и прочие варианты на что фантазии хватило, итог один- сплошной счёт по столбцу.

Автор - Sony
Дата добавления - 21.05.2016 в 23:34
gling Дата: Воскресенье, 22.05.2016, 00:32 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Может такую попробовать
Код
=СЧЁТЕСЛИМН($B$2:$B$19;A24;$F$2:$F$19;">0")
 
Ответить
СообщениеМожет такую попробовать
Код
=СЧЁТЕСЛИМН($B$2:$B$19;A24;$F$2:$F$19;">0")

Автор - gling
Дата добавления - 22.05.2016 в 00:32
Sony Дата: Понедельник, 23.05.2016, 23:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Ну да. Спасибо! Не пойму до сих пор что я не так делал... Никак не получалось объяснить программе этот момент ">0". Кавычки вроде ставил. ;)
 
Ответить
СообщениеНу да. Спасибо! Не пойму до сих пор что я не так делал... Никак не получалось объяснить программе этот момент ">0". Кавычки вроде ставил. ;)

Автор - Sony
Дата добавления - 23.05.2016 в 23:18
китин Дата: Вторник, 24.05.2016, 09:49 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну или для всех версий
Код
=СУММПРОИЗВ(ЕЧИСЛО($F$2:$F$19)*($B$2:$B$19=$A24))
К сообщению приложен файл: 165970.xls(30Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену или для всех версий
Код
=СУММПРОИЗВ(ЕЧИСЛО($F$2:$F$19)*($B$2:$B$19=$A24))

Автор - китин
Дата добавления - 24.05.2016 в 09:49
_Boroda_ Дата: Вторник, 24.05.2016, 10:36 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И еще для всех, и массивная еще (ввод одновременным нажатием Контрл Шифт Ентер)
Код
=СЧЁТ(1/(B$2:B$19=A24)/F$2:F$19)
К сообщению приложен файл: 165970_1.xls(44Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ еще для всех, и массивная еще (ввод одновременным нажатием Контрл Шифт Ентер)
Код
=СЧЁТ(1/(B$2:B$19=A24)/F$2:F$19)

Автор - _Boroda_
Дата добавления - 24.05.2016 в 10:36
Sony Дата: Вторник, 24.05.2016, 22:02 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_ изящное решение ! +1 hands
 
Ответить
Сообщение_Boroda_ изящное решение ! +1 hands

Автор - Sony
Дата добавления - 24.05.2016 в 22:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счёт по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!