Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сумму по дням недели - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму по дням недели (Формулы/Formulas)
Посчитать сумму по дням недели
garfeeld Дата: Понедельник, 23.05.2016, 19:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер. Необходимо посчитать сумму выручки по дням недели, дабы понять, какие дни наиболее пиковые. В тех формулах, что нашел - так и не разобрался...
То есть в ячейке R5C8 нужна сумма всех понедельников, в R6C8 всех вторников итд
Заранее спасибо
 
Ответить
СообщениеДобрый вечер. Необходимо посчитать сумму выручки по дням недели, дабы понять, какие дни наиболее пиковые. В тех формулах, что нашел - так и не разобрался...
То есть в ячейке R5C8 нужна сумма всех понедельников, в R6C8 всех вторников итд
Заранее спасибо

Автор - garfeeld
Дата добавления - 23.05.2016 в 19:45
buchlotnik Дата: Понедельник, 23.05.2016, 19:47 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
garfeeld, файл не прилепился - ограничение 100 кб


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеgarfeeld, файл не прилепился - ограничение 100 кб

Автор - buchlotnik
Дата добавления - 23.05.2016 в 19:47
garfeeld Дата: Понедельник, 23.05.2016, 19:49 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
точно
К сообщению приложен файл: 123.xls(33Kb)
 
Ответить
Сообщениеточно

Автор - garfeeld
Дата добавления - 23.05.2016 в 19:49
gling Дата: Понедельник, 23.05.2016, 20:06 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Здравствуйте. Можно так
Код
=СУММЕСЛИ($A$5:$A$56;G5;$D$5:$D$56)
или так
Код
=СУММПРОИЗВ((ТЕКСТ($B$5:$B$56;"ДДД")=G5)*D5:D56)
К сообщению приложен файл: 7776627.xls(33Kb)
 
Ответить
СообщениеЗдравствуйте. Можно так
Код
=СУММЕСЛИ($A$5:$A$56;G5;$D$5:$D$56)
или так
Код
=СУММПРОИЗВ((ТЕКСТ($B$5:$B$56;"ДДД")=G5)*D5:D56)

Автор - gling
Дата добавления - 23.05.2016 в 20:06
buchlotnik Дата: Понедельник, 23.05.2016, 20:12 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно сводной таблицей после преобразования в числа
Код
=ЕСЛИОШИБКА(--ПОДСТАВИТЬ(D2;".";",");"")
К сообщению приложен файл: 4559107.xls(38Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 23.05.2016, 20:13
 
Ответить
Сообщениеможно сводной таблицей после преобразования в числа
Код
=ЕСЛИОШИБКА(--ПОДСТАВИТЬ(D2;".";",");"")

Автор - buchlotnik
Дата добавления - 23.05.2016 в 20:12
garfeeld Дата: Понедельник, 23.05.2016, 20:25 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Можно так

=СУММЕСЛИ($A$5:$A$56;G5;$D$5:$D$56)

Большое спасибо! Именно эту формулу я и пробовал, но получалось 0. Оказывается проблема в точке
 
Ответить
Сообщение
Здравствуйте. Можно так

=СУММЕСЛИ($A$5:$A$56;G5;$D$5:$D$56)

Большое спасибо! Именно эту формулу я и пробовал, но получалось 0. Оказывается проблема в точке

Автор - garfeeld
Дата добавления - 23.05.2016 в 20:25
_Boroda_ Дата: Понедельник, 23.05.2016, 20:26 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И вообще без привязки к столбцу G можно
Код
=СУММПРОИЗВ((ДЕНЬНЕД(B$5:B$56;2)=СТРОКА(H1))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(D$5:D$56;".";",");" ";))

Оказывается проблема в точке

Проблема не только в точке, но и в неразрывном пробеле
А с привязкой аналогично
Код
=СУММПРОИЗВ((ТЕКСТ(B$5:B$56;"ДДД")=G5)*ПОДСТАВИТЬ(ПОДСТАВИТЬ(D$5:D$56;".";",");" ";))

Код
=СУММПРОИЗВ((A$5:A$56=G5)*ПОДСТАВИТЬ(ПОДСТАВИТЬ(D$5:D$56;".";",");" ";))

Только обратите внимание, что у Вас пропущено 9 мая и поэтому дни недели ниже не соответствуют датам
К сообщению приложен файл: 123_2.xls(38Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ вообще без привязки к столбцу G можно
Код
=СУММПРОИЗВ((ДЕНЬНЕД(B$5:B$56;2)=СТРОКА(H1))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(D$5:D$56;".";",");" ";))

Оказывается проблема в точке

Проблема не только в точке, но и в неразрывном пробеле
А с привязкой аналогично
Код
=СУММПРОИЗВ((ТЕКСТ(B$5:B$56;"ДДД")=G5)*ПОДСТАВИТЬ(ПОДСТАВИТЬ(D$5:D$56;".";",");" ";))

Код
=СУММПРОИЗВ((A$5:A$56=G5)*ПОДСТАВИТЬ(ПОДСТАВИТЬ(D$5:D$56;".";",");" ";))

Только обратите внимание, что у Вас пропущено 9 мая и поэтому дни недели ниже не соответствуют датам

Автор - _Boroda_
Дата добавления - 23.05.2016 в 20:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму по дням недели (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!