Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/прирост при нуле не считат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » прирост при нуле не считат (Формулы/Formulas)
прирост при нуле не считат
Dimon2512 Дата: Четверг, 26.05.2016, 11:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
Добрый день, подскажите пжл, для вас это наверное будет совсем просто, считаю прирост если стоит 0 то он не считает, как прописать формулу что бы считало все равно?
Файл в приложении
К сообщению приложен файл: 4567843.xls(18Kb)
 
Ответить
СообщениеДобрый день, подскажите пжл, для вас это наверное будет совсем просто, считаю прирост если стоит 0 то он не считает, как прописать формулу что бы считало все равно?
Файл в приложении

Автор - Dimon2512
Дата добавления - 26.05.2016 в 11:45
pabchek Дата: Четверг, 26.05.2016, 11:50 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Так надо?
Код
=ЕСЛИОШИБКА((B4-A4)/A4;0)

Хотя, наверное, лучше
Код
=ЕСЛИОШИБКА((B4-A4)/A4;1)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 26.05.2016, 11:52
 
Ответить
СообщениеЗдравствуйте!
Так надо?
Код
=ЕСЛИОШИБКА((B4-A4)/A4;0)

Хотя, наверное, лучше
Код
=ЕСЛИОШИБКА((B4-A4)/A4;1)

Автор - pabchek
Дата добавления - 26.05.2016 в 11:50
Dimon2512 Дата: Четверг, 26.05.2016, 11:53 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
pabchek, в столбце С такая же формула стоит, но по ней показывает 0, а надо что бы показывало прирост 100%
 
Ответить
Сообщениеpabchek, в столбце С такая же формула стоит, но по ней показывает 0, а надо что бы показывало прирост 100%

Автор - Dimon2512
Дата добавления - 26.05.2016 в 11:53
Dimon2512 Дата: Четверг, 26.05.2016, 11:57 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
pabchek, а вот если 1 поставить то что надо спасибо
 
Ответить
Сообщениеpabchek, а вот если 1 поставить то что надо спасибо

Автор - Dimon2512
Дата добавления - 26.05.2016 в 11:57
_Boroda_ Дата: Четверг, 26.05.2016, 12:03 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9379
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты (для любой версии Excel)
Код
=(B2-A2)/ЕСЛИ(A2;A2;B2)

Код
=B2/ЕСЛИ(A2;A2;B2/2)-1
К сообщению приложен файл: 4567843_1.xls(29Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты (для любой версии Excel)
Код
=(B2-A2)/ЕСЛИ(A2;A2;B2)

Код
=B2/ЕСЛИ(A2;A2;B2/2)-1

Автор - _Boroda_
Дата добавления - 26.05.2016 в 12:03
Dimon2512 Дата: Четверг, 26.05.2016, 12:06 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

2007
_Boroda_, Да спасибо
 
Ответить
Сообщение_Boroda_, Да спасибо

Автор - Dimon2512
Дата добавления - 26.05.2016 в 12:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » прирост при нуле не считат (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!