Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединить ячейки по правилам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединить ячейки по правилам (Формулы/Formulas)
Объединить ячейки по правилам
vladislaf Дата: Четверг, 26.05.2016, 18:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте!
Пример файла в приложении, там легче будет описать, задачу.
Заранее благодарен за ответы! Очень надо, а строк много и часто так надо делать.
[moder]Дайте теме более конкретное название![/moder]
К сообщению приложен файл: _20_.xls(28Kb)


Сообщение отредактировал vladislaf - Четверг, 26.05.2016, 19:09
 
Ответить
СообщениеЗдравствуйте!
Пример файла в приложении, там легче будет описать, задачу.
Заранее благодарен за ответы! Очень надо, а строк много и часто так надо делать.
[moder]Дайте теме более конкретное название![/moder]

Автор - vladislaf
Дата добавления - 26.05.2016 в 18:43
Светлый Дата: Четверг, 26.05.2016, 20:02 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
Один из вариантов - добавить впереди пробел в цветных ячейках и использовать формулу:
Код
=ЕСЛИ(ЛЕВБ(B8)=" ";"";ИНДЕКС($B$1:$B7;МАКС((ЛЕВБ(B$7:B7)=" ")*СТРОКА($7:7)))&" "&B8)
К сообщению приложен файл: _20_1.xls(31Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеОдин из вариантов - добавить впереди пробел в цветных ячейках и использовать формулу:
Код
=ЕСЛИ(ЛЕВБ(B8)=" ";"";ИНДЕКС($B$1:$B7;МАКС((ЛЕВБ(B$7:B7)=" ")*СТРОКА($7:7)))&" "&B8)

Автор - Светлый
Дата добавления - 26.05.2016 в 20:02
_Boroda_ Дата: Четверг, 26.05.2016, 20:15 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не знаю, какие значения у Вас в других выгрузках, но для ЭТОЙ подходит формула
Код
=ЕСЛИ(СЧЁТ(ПОИСК({".":"-"};B8));"";ПРОСМОТР(;-ПОИСК("-";B$8:B8);B$8:B8)&" "&B8)
К сообщению приложен файл: 9065691.xls(37Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе знаю, какие значения у Вас в других выгрузках, но для ЭТОЙ подходит формула
Код
=ЕСЛИ(СЧЁТ(ПОИСК({".":"-"};B8));"";ПРОСМОТР(;-ПОИСК("-";B$8:B8);B$8:B8)&" "&B8)

Автор - _Boroda_
Дата добавления - 26.05.2016 в 20:15
vladislaf Дата: Четверг, 26.05.2016, 21:28 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Большое спасибо!
 
Ответить
СообщениеБольшое спасибо!

Автор - vladislaf
Дата добавления - 26.05.2016 в 21:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединить ячейки по правилам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!