Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить загрузку, зная трудоемкость - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить загрузку, зная трудоемкость (Формулы/Formulas)
Определить загрузку, зная трудоемкость
ryazanov Дата: Четверг, 26.05.2016, 19:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

2010
Добрый день!
Сотрудникам передаются в работу заказы. Дата передачи заказа в работу и трудоемкость заказов в часах известна ("лист 1" в файле примера).
Необходимо вывести загрузку каждого сотрудника на каждый рабочий день (лист "Загрузка сотрудников").
Продолжительность рабочего дня 8 часов. Сб и Вс выходные дни.
Т.е. загрузка на сегодня должна учитывать остаток работы с последнего рабочего дня (то что >8 часов) и то, что передано сегодня.
Помогите вывести эту информацию формулами, чтобы можно было протягивать.
К сообщению приложен файл: 20.xlsx(14Kb)
 
Ответить
СообщениеДобрый день!
Сотрудникам передаются в работу заказы. Дата передачи заказа в работу и трудоемкость заказов в часах известна ("лист 1" в файле примера).
Необходимо вывести загрузку каждого сотрудника на каждый рабочий день (лист "Загрузка сотрудников").
Продолжительность рабочего дня 8 часов. Сб и Вс выходные дни.
Т.е. загрузка на сегодня должна учитывать остаток работы с последнего рабочего дня (то что >8 часов) и то, что передано сегодня.
Помогите вывести эту информацию формулами, чтобы можно было протягивать.

Автор - ryazanov
Дата добавления - 26.05.2016 в 19:51
Pelena Дата: Четверг, 26.05.2016, 21:30 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9858
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Код
=ЕСЛИ(ДЕНЬНЕД(B$2;2)<6;МИН(СУММЕСЛИМН(Лист1!$D:$D;Лист1!$B:$B;$A8;Лист1!$A:$A;"<="&B$2;Лист1!$A:$A;">="&$B$2)-СУММ($A8:A8);8);0)
К сообщению приложен файл: 20-1-.xlsx(15Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(ДЕНЬНЕД(B$2;2)<6;МИН(СУММЕСЛИМН(Лист1!$D:$D;Лист1!$B:$B;$A8;Лист1!$A:$A;"<="&B$2;Лист1!$A:$A;">="&$B$2)-СУММ($A8:A8);8);0)

Автор - Pelena
Дата добавления - 26.05.2016 в 21:30
krosav4ig Дата: Четверг, 26.05.2016, 22:11 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1345
Репутация: 547 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте
я тут чего-то непонятное нагородил
[vba]
Код
=ЕСЛИ(И(РАБДЕНЬ(B$2-1;1)=B$2;РАБДЕНЬ(МИН(ЕСЛИ(--ТЕКСТ($B4:B4;"0;;0;\0");$B$2:B$2));ОКРУГЛВВЕРХ(СУММ($B4:B4)/8;))>=B$2);МЕДИАНА(;8;СУММ($B4:B4)-СУММ($A8:A8));)
[/vba]
К сообщению приложен файл: 20-2.xlsx(15Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Четверг, 26.05.2016, 22:15
 
Ответить
СообщениеЗдравствуйте
я тут чего-то непонятное нагородил
[vba]
Код
=ЕСЛИ(И(РАБДЕНЬ(B$2-1;1)=B$2;РАБДЕНЬ(МИН(ЕСЛИ(--ТЕКСТ($B4:B4;"0;;0;\0");$B$2:B$2));ОКРУГЛВВЕРХ(СУММ($B4:B4)/8;))>=B$2);МЕДИАНА(;8;СУММ($B4:B4)-СУММ($A8:A8));)
[/vba]

Автор - krosav4ig
Дата добавления - 26.05.2016 в 22:11
ryazanov Дата: Пятница, 27.05.2016, 00:08 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

2010
Лена, как всегда супер! Большое спасибо, выручили! )
 
Ответить
СообщениеЛена, как всегда супер! Большое спасибо, выручили! )

Автор - ryazanov
Дата добавления - 27.05.2016 в 00:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить загрузку, зная трудоемкость (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!