Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сцепить число и оператор сравнения в лог_выражение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить число и оператор сравнения в лог_выражение (Формулы/Formulas)
Сцепить число и оператор сравнения в лог_выражение
Almost Дата: Воскресенье, 05.06.2016, 00:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте!

В ячейке a1 указано значение "1", которое нужно проверить на соответствие критерию, указанному в ячейке b1 - "<0,5".

Пишу формулу "=ЕСЛИ(a1&b1;1;0)", чтобы после подстановки данных из ячеек a1 и b1 она выглядела так: "=ЕСЛИ(1<0,5;1;0)". Но она выдаёт ошибку вычисления #ЗНАЧ.

Как поправить формулу, чтобы лог_выражение правильно подтягивало критерий из b1?
К сообщению приложен файл: 9917982.xlsx(8Kb)
 
Ответить
СообщениеЗдравствуйте!

В ячейке a1 указано значение "1", которое нужно проверить на соответствие критерию, указанному в ячейке b1 - "<0,5".

Пишу формулу "=ЕСЛИ(a1&b1;1;0)", чтобы после подстановки данных из ячеек a1 и b1 она выглядела так: "=ЕСЛИ(1<0,5;1;0)". Но она выдаёт ошибку вычисления #ЗНАЧ.

Как поправить формулу, чтобы лог_выражение правильно подтягивало критерий из b1?

Автор - Almost
Дата добавления - 05.06.2016 в 00:29
buchlotnik Дата: Воскресенье, 05.06.2016, 01:08 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно через макрофункции - в диспетчер имён:
Код
=--ВЫЧИСЛИТЬ(Лист1!A1&Лист1!B1)
но проще так:
Код
=СЧЁТЕСЛИ(A1;B1)
К сообщению приложен файл: 9917982.xls(23Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Воскресенье, 05.06.2016, 01:14
 
Ответить
Сообщениеможно через макрофункции - в диспетчер имён:
Код
=--ВЫЧИСЛИТЬ(Лист1!A1&Лист1!B1)
но проще так:
Код
=СЧЁТЕСЛИ(A1;B1)

Автор - buchlotnik
Дата добавления - 05.06.2016 в 01:08
Almost Дата: Воскресенье, 05.06.2016, 01:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо за оперативный ответ, решение отлично подходит.
 
Ответить
СообщениеСпасибо за оперативный ответ, решение отлично подходит.

Автор - Almost
Дата добавления - 05.06.2016 в 01:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить число и оператор сравнения в лог_выражение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!