Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Пронумеровать единицы по порядку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пронумеровать единицы по порядку (Формулы/Formulas)
Пронумеровать единицы по порядку
Dizeloid Дата: Понедельник, 06.06.2016, 10:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет! Подскажите, как решить вопрос. У меня есть столбец в котором содержится информация в виде только нулей и единиц:
1
0
1
1
0
1
0
1
Мне нужно сделать так, что бы в соседнем столбце были пронумерованы по порядку единицы вот таким образом:
1 1
0
1 2
1 3
0
1 4
0
1 5
Это реально сделать?
 
Ответить
СообщениеВсем привет! Подскажите, как решить вопрос. У меня есть столбец в котором содержится информация в виде только нулей и единиц:
1
0
1
1
0
1
0
1
Мне нужно сделать так, что бы в соседнем столбце были пронумерованы по порядку единицы вот таким образом:
1 1
0
1 2
1 3
0
1 4
0
1 5
Это реально сделать?

Автор - Dizeloid
Дата добавления - 06.06.2016 в 10:22
_Boroda_ Дата: Понедельник, 06.06.2016, 10:25 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В В1
Код
=сумм(A$1:A1)
и тяните ее вниз.
Если не то, то кладите файл-пример


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ В1
Код
=сумм(A$1:A1)
и тяните ее вниз.
Если не то, то кладите файл-пример

Автор - _Boroda_
Дата добавления - 06.06.2016 в 10:25
Dizeloid Дата: Понедельник, 06.06.2016, 10:30 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Не получилось. Вот файл пример
К сообщению приложен файл: 4372137.xlsx(9Kb)
 
Ответить
СообщениеНе получилось. Вот файл пример

Автор - Dizeloid
Дата добавления - 06.06.2016 в 10:30
pabchek Дата: Понедельник, 06.06.2016, 10:32 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 751
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
Модификация формулы Александра ( _Boroda_)
Код
=ЕСЛИ(A1=0;"";СУММ(A$1:A1))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеМодификация формулы Александра ( _Boroda_)
Код
=ЕСЛИ(A1=0;"";СУММ(A$1:A1))

Автор - pabchek
Дата добавления - 06.06.2016 в 10:32
Russel Дата: Понедельник, 06.06.2016, 10:32 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1263
Репутация: 286 ±
Замечаний: 0% ±

Excel 2010
Dizeloid,
Код
=ЕСЛИ(A1=1;СУММ(A$1:A1);"")


QIWI 9173973973
 
Ответить
СообщениеDizeloid,
Код
=ЕСЛИ(A1=1;СУММ(A$1:A1);"")

Автор - Russel
Дата добавления - 06.06.2016 в 10:32
_Boroda_ Дата: Понедельник, 06.06.2016, 10:33 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИ(A1;СУММ(A$1:A1);"")

Код
=СУММ(A$1:A1)*A1
и формат ячеек
0;;
К сообщению приложен файл: 4372137_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИ(A1;СУММ(A$1:A1);"")

Код
=СУММ(A$1:A1)*A1
и формат ячеек
0;;

Автор - _Boroda_
Дата добавления - 06.06.2016 в 10:33
китин Дата: Понедельник, 06.06.2016, 10:37 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4351
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
усложним варианты ответов :D
Код
=ЕСЛИ(A1=1;СЧЁТЕСЛИ($A$1:A1;1);"")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеусложним варианты ответов :D
Код
=ЕСЛИ(A1=1;СЧЁТЕСЛИ($A$1:A1;1);"")

Автор - китин
Дата добавления - 06.06.2016 в 10:37
Dizeloid Дата: Понедельник, 06.06.2016, 10:40 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Не могу понять что не так? Вставляю формулы предложенные участниками форума и ничего не происходит, формула остается висеть в ячейке. Странно...


Сообщение отредактировал Dizeloid - Понедельник, 06.06.2016, 10:40
 
Ответить
СообщениеНе могу понять что не так? Вставляю формулы предложенные участниками форума и ничего не происходит, формула остается висеть в ячейке. Странно...

Автор - Dizeloid
Дата добавления - 06.06.2016 в 10:40
buchlotnik Дата: Понедельник, 06.06.2016, 10:42 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 854 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
У вас стиль ссылок R1C1, а вставляете в стиле A1.
И случаем режим отображения формул не включен?


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 06.06.2016, 10:43
 
Ответить
СообщениеУ вас стиль ссылок R1C1, а вставляете в стиле A1.
И случаем режим отображения формул не включен?

Автор - buchlotnik
Дата добавления - 06.06.2016 в 10:42
Dizeloid Дата: Понедельник, 06.06.2016, 10:52 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
У вас стиль ссылок R1C1, а вставляете в стиле A1.
И случаем режим отображения формул не включен?

Да, все правильно, уже разобрался, век живи век учись))) Всем по плюсу в репу отвесил за скорую помощь)


Сообщение отредактировал Dizeloid - Понедельник, 06.06.2016, 10:59
 
Ответить
Сообщение
У вас стиль ссылок R1C1, а вставляете в стиле A1.
И случаем режим отображения формул не включен?

Да, все правильно, уже разобрался, век живи век учись))) Всем по плюсу в репу отвесил за скорую помощь)

Автор - Dizeloid
Дата добавления - 06.06.2016 в 10:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пронумеровать единицы по порядку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!