Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Группировка числовых значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Группировка числовых значений (Формулы/Formulas)
Группировка числовых значений
Es72 Дата: Понедельник, 06.06.2016, 17:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
имеются числа в формате времени в столбик, в зависимости от размера нужно отнести число к группе 1, 2 или 3: если меньше 02:00 - группа "1", если больше или равно 02:00 и меньше 04:00 - "2", если больше или равно 04:00 - "3".
Формула должна быть простой для любого опытного участника форума, но на всякий случай файл формате ME2010 прикладываю.
К сообщению приложен файл: gr.xlsx(8Kb)
 
Ответить
Сообщениеимеются числа в формате времени в столбик, в зависимости от размера нужно отнести число к группе 1, 2 или 3: если меньше 02:00 - группа "1", если больше или равно 02:00 и меньше 04:00 - "2", если больше или равно 04:00 - "3".
Формула должна быть простой для любого опытного участника форума, но на всякий случай файл формате ME2010 прикладываю.

Автор - Es72
Дата добавления - 06.06.2016 в 17:37
ArkaIIIa Дата: Понедельник, 06.06.2016, 17:41 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 873
Репутация: 115 ±
Замечаний: 0% ±

2010
Вариант:
Код
=ПРОСМОТР(A2;{0;0,0833333333333333;0,166666666666666};{1;2;3})


0,0833333333333333 - это то же самое, что и 02:00, но в числовом формате.
0,166666666666667 - аналогично для 04:00 (в формуле на конце 6, чтобы выполнить условие "Если больше или равно 04:00 - 3").


Сообщение отредактировал ArkaIIIa - Понедельник, 06.06.2016, 17:50
 
Ответить
СообщениеВариант:
Код
=ПРОСМОТР(A2;{0;0,0833333333333333;0,166666666666666};{1;2;3})


0,0833333333333333 - это то же самое, что и 02:00, но в числовом формате.
0,166666666666667 - аналогично для 04:00 (в формуле на конце 6, чтобы выполнить условие "Если больше или равно 04:00 - 3").

Автор - ArkaIIIa
Дата добавления - 06.06.2016 в 17:41
sboy Дата: Понедельник, 06.06.2016, 17:48 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 924
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(RC[-2]<R2C5;1;ЕСЛИ(RC[-2]<R3C5;2;3))
К сообщению приложен файл: 8550194.xlsx(8Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(RC[-2]<R2C5;1;ЕСЛИ(RC[-2]<R3C5;2;3))

Автор - sboy
Дата добавления - 06.06.2016 в 17:48
sboy Дата: Понедельник, 06.06.2016, 17:50 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 924
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
0,0833333333333333 - это то же самое, что и 02:00, но в числовом формате.
0,166666666666667 - аналогично для 04:00.


Код
=ЕСЛИ(RC[-2]<0,0833333333333333;1;ЕСЛИ(RC[-2]<0,166666666666666;2;3))


Сообщение отредактировал sboy - Понедельник, 06.06.2016, 17:55
 
Ответить
Сообщение
0,0833333333333333 - это то же самое, что и 02:00, но в числовом формате.
0,166666666666667 - аналогично для 04:00.


Код
=ЕСЛИ(RC[-2]<0,0833333333333333;1;ЕСЛИ(RC[-2]<0,166666666666666;2;3))

Автор - sboy
Дата добавления - 06.06.2016 в 17:50
ArkaIIIa Дата: Понедельник, 06.06.2016, 17:53 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 873
Репутация: 115 ±
Замечаний: 0% ±

2010
=ЕСЛИ(RC[-2]<0,0833333333333333;1;ЕСЛИ(RC[-2]<0,166666666666667;2;3))

Повторюсь, во втором значении на конце нужно указывать 6, иначе для точного времени 04:00 группа проставляется некорректно.
 
Ответить
Сообщение
=ЕСЛИ(RC[-2]<0,0833333333333333;1;ЕСЛИ(RC[-2]<0,166666666666667;2;3))

Повторюсь, во втором значении на конце нужно указывать 6, иначе для точного времени 04:00 группа проставляется некорректно.

Автор - ArkaIIIa
Дата добавления - 06.06.2016 в 17:53
sboy Дата: Понедельник, 06.06.2016, 17:56 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 924
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
[offtop] поправил, спасибо ArkaIIIa,
 
Ответить
Сообщение[offtop] поправил, спасибо ArkaIIIa,

Автор - sboy
Дата добавления - 06.06.2016 в 17:56
_Boroda_ Дата: Понедельник, 06.06.2016, 18:16 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11315
Репутация: 4675 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот это
0,0833333333333333
зря Вы.
Вот так вроде и точнее, и красивее, и понятнее
Код
=3-(A2<--"2:")-(A2<--"4:")
К сообщению приложен файл: gr_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот это
0,0833333333333333
зря Вы.
Вот так вроде и точнее, и красивее, и понятнее
Код
=3-(A2<--"2:")-(A2<--"4:")

Автор - _Boroda_
Дата добавления - 06.06.2016 в 18:16
Es72 Дата: Понедельник, 06.06.2016, 18:57 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Не успел доехать с работы домой, а уже куча решений! Спасибо большое!
 
Ответить
СообщениеНе успел доехать с работы домой, а уже куча решений! Спасибо большое!

Автор - Es72
Дата добавления - 06.06.2016 в 18:57
китин Дата: Вторник, 07.06.2016, 08:35 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а мы вот еще так извратимся :D
Код
=ПРОСМОТР(ТЕКСТ(A2;"чч");{"00";"02";"04"};{1;2;3})


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа мы вот еще так извратимся :D
Код
=ПРОСМОТР(ТЕКСТ(A2;"чч");{"00";"02";"04"};{1;2;3})

Автор - китин
Дата добавления - 07.06.2016 в 08:35
_Boroda_ Дата: Вторник, 07.06.2016, 09:27 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11315
Репутация: 4675 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Переизвратил Игорево извращение
Код
=ПРОСМОТР(--ТЕКСТ(A2;"ч");{0;2;4};{1;2;3})

И свое наизвращал
Код
=МАКС(--ТЕКСТ(A2;"[>"&--{0:"2:":"4:"}&"]"&{1:2:3}))
К сообщению приложен файл: gr_2.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПереизвратил Игорево извращение
Код
=ПРОСМОТР(--ТЕКСТ(A2;"ч");{0;2;4};{1;2;3})

И свое наизвращал
Код
=МАКС(--ТЕКСТ(A2;"[>"&--{0:"2:":"4:"}&"]"&{1:2:3}))

Автор - _Boroda_
Дата добавления - 07.06.2016 в 09:27
ArkaIIIa Дата: Вторник, 07.06.2016, 09:43 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 873
Репутация: 115 ±
Замечаний: 0% ±

2010
И свое наизвращал
=МАКС(--ТЕКСТ(A2;"[>"&--{0:"2:":"4:"}&"]"&{1:2:3}))

Формула должна быть простой для любого опытного участника форума

%)
 
Ответить
Сообщение
И свое наизвращал
=МАКС(--ТЕКСТ(A2;"[>"&--{0:"2:":"4:"}&"]"&{1:2:3}))

Формула должна быть простой для любого опытного участника форума

%)

Автор - ArkaIIIa
Дата добавления - 07.06.2016 в 09:43
_Boroda_ Дата: Вторник, 07.06.2016, 10:24 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11315
Репутация: 4675 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да там все просто:

1. "2:" - это короткая запись "2:00:00" = 2 часа. Следовательно, {0:"2:":"4:"} = {"0:00:00":"2:00:00":"4:00:00"}, а --{0:"2:":"4:"} преобразует {"0:00:00":"2:00:00":"4:00:00"} из текстовых значений во время. Обычно с датами и временем прокатывает и без этого, но не в нашем случае - у нас не прямое равенство, а сравнение ">".

2. представим себе формулу ФФФ =ТЕКСТ(A1;"[>3]8"). Если А1 <= 3, то ФФФ даст нам само значение А1, если А1 > 3, то ФФФ даст нам 8 (8 - это просто для примера - какое-то число мне нужно было взять, вот я взял 8). Формулу ФФФ можно написать еще и вот так (& - знак объединения, например - "ййй"&"ццц" будет "йййццц") =ТЕКСТ(A1;"[>" & 3 &"]" & 8)
Примерно аналогичное написано и в этом куске ТЕКСТ(A2;"[>" & --{0:"2:":"4:"} & "]" & {1:2:3}), только вместо 3 и 8 у нас массивы --{0:"2:":"4:"} и {1:2:3}, которые на выходе дают ТЕКСТ(A2;{"[>0]1":"[>0,0833333333333333]2":"[>0,166666666666667]3"}), а вся эта конструкция даст нам некий массив. Например, для строки 3 со временем 02:13 мы получим вот так {1:2:0,093005952}. Теперь осталось только взять оттуда максимум.

Теги не использовал сознательно - с ними вообще нечитабельно получается.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа там все просто:

1. "2:" - это короткая запись "2:00:00" = 2 часа. Следовательно, {0:"2:":"4:"} = {"0:00:00":"2:00:00":"4:00:00"}, а --{0:"2:":"4:"} преобразует {"0:00:00":"2:00:00":"4:00:00"} из текстовых значений во время. Обычно с датами и временем прокатывает и без этого, но не в нашем случае - у нас не прямое равенство, а сравнение ">".

2. представим себе формулу ФФФ =ТЕКСТ(A1;"[>3]8"). Если А1 <= 3, то ФФФ даст нам само значение А1, если А1 > 3, то ФФФ даст нам 8 (8 - это просто для примера - какое-то число мне нужно было взять, вот я взял 8). Формулу ФФФ можно написать еще и вот так (& - знак объединения, например - "ййй"&"ццц" будет "йййццц") =ТЕКСТ(A1;"[>" & 3 &"]" & 8)
Примерно аналогичное написано и в этом куске ТЕКСТ(A2;"[>" & --{0:"2:":"4:"} & "]" & {1:2:3}), только вместо 3 и 8 у нас массивы --{0:"2:":"4:"} и {1:2:3}, которые на выходе дают ТЕКСТ(A2;{"[>0]1":"[>0,0833333333333333]2":"[>0,166666666666667]3"}), а вся эта конструкция даст нам некий массив. Например, для строки 3 со временем 02:13 мы получим вот так {1:2:0,093005952}. Теперь осталось только взять оттуда максимум.

Теги не использовал сознательно - с ними вообще нечитабельно получается.

Автор - _Boroda_
Дата добавления - 07.06.2016 в 10:24
китин Дата: Вторник, 07.06.2016, 10:34 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
Да там все просто:

ню ню :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
Да там все просто:

ню ню :D

Автор - китин
Дата добавления - 07.06.2016 в 10:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Группировка числовых значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!