Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод заголовка столбца на пересечении строки и столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод заголовка столбца на пересечении строки и столбца (Формулы/Formulas)
Вывод заголовка столбца на пересечении строки и столбца
Arkanzas Дата: Среда, 08.06.2016, 18:21 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Помогите пожалуйста!
Во вложении пример моей рабочей таблицы, смысл ее в том, что в столбцы "С - F" выводятся значения из заголовка стобца, в котором появляется искомое значение марки (комбинация функций ИНДЕКС и ПОИСКПОЗ). Формула работает, но немного не корректно. Цветом выделено некорректное отображение информации номеров документов, если марка повторяется в двух или нескольких строках, выводится первое найденное значение, последующее игнорируется, а для моей работы это очень важный момент. При этом, если убрать из столбца "G" удалить количество, то в строке, в нужных столбцах значение остается.
Думаю увидев пример все будет предельно понятно.
Нужно как-то акцентировать внимание формулы на конкретной строке в которой она стоит, а я не знаю как и чем))
Подскажите пожалуйста?
Заранее благодарю за уделенное моей задаче время!
К сообщению приложен файл: 1768996.xlsx(18Kb)


Сообщение отредактировал Arkanzas - Среда, 08.06.2016, 18:39
 
Ответить
СообщениеЗдравствуйте!
Помогите пожалуйста!
Во вложении пример моей рабочей таблицы, смысл ее в том, что в столбцы "С - F" выводятся значения из заголовка стобца, в котором появляется искомое значение марки (комбинация функций ИНДЕКС и ПОИСКПОЗ). Формула работает, но немного не корректно. Цветом выделено некорректное отображение информации номеров документов, если марка повторяется в двух или нескольких строках, выводится первое найденное значение, последующее игнорируется, а для моей работы это очень важный момент. При этом, если убрать из столбца "G" удалить количество, то в строке, в нужных столбцах значение остается.
Думаю увидев пример все будет предельно понятно.
Нужно как-то акцентировать внимание формулы на конкретной строке в которой она стоит, а я не знаю как и чем))
Подскажите пожалуйста?
Заранее благодарю за уделенное моей задаче время!

Автор - Arkanzas
Дата добавления - 08.06.2016 в 18:21
Pelena Дата: Среда, 08.06.2016, 18:39 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9846
Репутация: 2253 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Маловато данных, но, может, для С8 так
Код
=ИНДЕКС($G$4:$J$4;ПОИСКПОЗ($A8;G8:J8;0))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМаловато данных, но, может, для С8 так
Код
=ИНДЕКС($G$4:$J$4;ПОИСКПОЗ($A8;G8:J8;0))

Автор - Pelena
Дата добавления - 08.06.2016 в 18:39
Arkanzas Дата: Среда, 08.06.2016, 18:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, удивительно короткая формула, но она работает как положено, спасибо! Я думал тут будет что-то с чем-то, в полтора метра длиной..))
Все гениальное просто))


Сообщение отредактировал Arkanzas - Среда, 08.06.2016, 19:00
 
Ответить
СообщениеPelena, удивительно короткая формула, но она работает как положено, спасибо! Я думал тут будет что-то с чем-то, в полтора метра длиной..))
Все гениальное просто))

Автор - Arkanzas
Дата добавления - 08.06.2016 в 18:58
AlexM Дата: Среда, 08.06.2016, 20:12 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3049
Репутация: 739 ±
Замечаний: 0% ±

Можно еще так
Код
=ПРОСМОТР(2;1/(H8:J8=A8);H$4:J$4)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеМожно еще так
Код
=ПРОСМОТР(2;1/(H8:J8=A8);H$4:J$4)

Автор - AlexM
Дата добавления - 08.06.2016 в 20:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод заголовка столбца на пересечении строки и столбца (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!