Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округлить до ближайшего большего целого, кратного "n" числа. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округлить до ближайшего большего целого, кратного "n" числа. (Формулы/Formulas)
Округлить до ближайшего большего целого, кратного "n" числа.
Юрий_Нд Дата: Пятница, 10.06.2016, 00:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Как округлить до ближайшего большего целого, кратного "n" числа?
Существует такая формула?
 
Ответить
СообщениеКак округлить до ближайшего большего целого, кратного "n" числа?
Существует такая формула?

Автор - Юрий_Нд
Дата добавления - 10.06.2016 в 00:38
AlexM Дата: Пятница, 10.06.2016, 00:56 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Код
=ОКРВВЕРХ(A2;A1)
В А1 - n, в А2 - округляемое число.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ОКРВВЕРХ(A2;A1)
В А1 - n, в А2 - округляемое число.

Автор - AlexM
Дата добавления - 10.06.2016 в 00:56
_Boroda_ Дата: Пятница, 10.06.2016, 00:59 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Конечно
2007
Код
=ОКРВВЕРХ(A3;B2)

А3 - что округляем
В2 - точность
с 2010 появилась еще
Код
=ОКРВВЕРХ.ТОЧН(A3;B2)

Разница в отрицательных значениях второго аргумента. См. файл
Код
=ОКРВВЕРХ.ТОЧН(-58;-5)=-55

Код
=ОКРВВЕРХ(-58;-5)=-60
К сообщению приложен файл: 687161768.xlsx(8Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКонечно
2007
Код
=ОКРВВЕРХ(A3;B2)

А3 - что округляем
В2 - точность
с 2010 появилась еще
Код
=ОКРВВЕРХ.ТОЧН(A3;B2)

Разница в отрицательных значениях второго аргумента. См. файл
Код
=ОКРВВЕРХ.ТОЧН(-58;-5)=-55

Код
=ОКРВВЕРХ(-58;-5)=-60

Автор - _Boroda_
Дата добавления - 10.06.2016 в 00:59
Юрий_Нд Дата: Пятница, 10.06.2016, 01:07 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо, "все получилось".
 
Ответить
СообщениеСпасибо, "все получилось".

Автор - Юрий_Нд
Дата добавления - 10.06.2016 в 01:07
Юрий_Нд Дата: Пятница, 10.06.2016, 01:17 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
"Новая проблема":
Выполняю инженерный расчет.
Как "округлять вверх", только в том случае, если "до округляемого меньшего" больше трех процентов?
Наверное, такой формулы еще не придумали?
Пример:
число - результат
151 - 150
152 - 150
173 - 200
199 - 200
186 - 200
 
Ответить
Сообщение"Новая проблема":
Выполняю инженерный расчет.
Как "округлять вверх", только в том случае, если "до округляемого меньшего" больше трех процентов?
Наверное, такой формулы еще не придумали?
Пример:
число - результат
151 - 150
152 - 150
173 - 200
199 - 200
186 - 200

Автор - Юрий_Нд
Дата добавления - 10.06.2016 в 01:17
AlexM Дата: Пятница, 10.06.2016, 01:33 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Код
=ЕСЛИ(A1/ОКРВНИЗ(A1;50)>103%;ОКРВВЕРХ(A1;50);ОКРВНИЗ(A1;50))
или
Код
=ОКРВВЕРХ(A1-24*(A1/ОКРВНИЗ(A1;50)<103%);50)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 10.06.2016, 01:39
 
Ответить
Сообщение
Код
=ЕСЛИ(A1/ОКРВНИЗ(A1;50)>103%;ОКРВВЕРХ(A1;50);ОКРВНИЗ(A1;50))
или
Код
=ОКРВВЕРХ(A1-24*(A1/ОКРВНИЗ(A1;50)<103%);50)

Автор - AlexM
Дата добавления - 10.06.2016 в 01:33
_Boroda_ Дата: Пятница, 10.06.2016, 01:57 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ОКРВВЕРХ(C2-ОКРУГЛТ(C2;50)*3%;50)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ОКРВВЕРХ(C2-ОКРУГЛТ(C2;50)*3%;50)

Автор - _Boroda_
Дата добавления - 10.06.2016 в 01:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округлить до ближайшего большего целого, кратного "n" числа. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!