Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание двумерного массива данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание двумерного массива данных (Формулы/Formulas)
Создание двумерного массива данных
shmatique Дата: Пятница, 10.06.2016, 13:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, уважаемые форумчане!
Необходимо создать двумерный массив данных из выгруженной таблицы исходников из 1С.
В связи с большим объемом данных, хочу узнать каким образом возможно проделать эту операцию в автоматическом режиме?[u]
Спасибо Вам большое! Файл "Пример" прикрепляю
К сообщению приложен файл: 1061773.xls(28Kb)


Сообщение отредактировал shmatique - Пятница, 10.06.2016, 13:10
 
Ответить
СообщениеДобрый день, уважаемые форумчане!
Необходимо создать двумерный массив данных из выгруженной таблицы исходников из 1С.
В связи с большим объемом данных, хочу узнать каким образом возможно проделать эту операцию в автоматическом режиме?[u]
Спасибо Вам большое! Файл "Пример" прикрепляю

Автор - shmatique
Дата добавления - 10.06.2016 в 13:09
_Boroda_ Дата: Пятница, 10.06.2016, 13:27 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
каким образом возможно проделать эту операцию в автоматическом режиме?

Дать по башке одинэсникам и сказать, чтобы они нормально настроили отчет. Они будут говорить, что 1С этого не предусматривает - не верьте, они так всегда говорят. Да, действительно, это не прям вот так легко можно сделать, но можно. У меня на предыдущей работе когда Ген.дир. сказал "Уволю всех к чертовой матери", так они за 20 минут моей начальнице такой же отчет сделали, какой Вам нужен.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
каким образом возможно проделать эту операцию в автоматическом режиме?

Дать по башке одинэсникам и сказать, чтобы они нормально настроили отчет. Они будут говорить, что 1С этого не предусматривает - не верьте, они так всегда говорят. Да, действительно, это не прям вот так легко можно сделать, но можно. У меня на предыдущей работе когда Ген.дир. сказал "Уволю всех к чертовой матери", так они за 20 минут моей начальнице такой же отчет сделали, какой Вам нужен.

Автор - _Boroda_
Дата добавления - 10.06.2016 в 13:27
shmatique Дата: Пятница, 10.06.2016, 13:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Обязательно воспользуюсь этим советом, спасибо. Проблема в том, что сроки поджимают.
А что касается собственноручной настройки, непосредственно в эксель, нет идей?
[moder]Излишнее цитирование запрещено Правилами форума. Удалил[/moder]


Сообщение отредактировал _Boroda_ - Пятница, 10.06.2016, 13:53
 
Ответить
СообщениеОбязательно воспользуюсь этим советом, спасибо. Проблема в том, что сроки поджимают.
А что касается собственноручной настройки, непосредственно в эксель, нет идей?
[moder]Излишнее цитирование запрещено Правилами форума. Удалил[/moder]

Автор - shmatique
Дата добавления - 10.06.2016 в 13:50
Nic70y Дата: Пятница, 10.06.2016, 15:09 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Если заранее известны Подразделения и Статьи затрат, то в общем-то не сложно.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B:$B;ПОИСКПОЗ($E3;ИНДЕКС($A:$A;ПОИСКПОЗ(F$2;$A:$A;)):ИНДЕКС($A:$A;ЕСЛИ(G$2="";ПОИСКПОЗ("我我";$A:$A);ПОИСКПОЗ(G$2;$A:$A;)));)+ПОИСКПОЗ(F$2;$A:$A;)-1);0)
К сообщению приложен файл: 0140721.xls(31Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеЕсли заранее известны Подразделения и Статьи затрат, то в общем-то не сложно.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B:$B;ПОИСКПОЗ($E3;ИНДЕКС($A:$A;ПОИСКПОЗ(F$2;$A:$A;)):ИНДЕКС($A:$A;ЕСЛИ(G$2="";ПОИСКПОЗ("我我";$A:$A);ПОИСКПОЗ(G$2;$A:$A;)));)+ПОИСКПОЗ(F$2;$A:$A;)-1);0)

Автор - Nic70y
Дата добавления - 10.06.2016 в 15:09
shmatique Дата: Пятница, 10.06.2016, 16:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Если заранее известны Подразделения и Статьи затрат, то в общем-то не сложно.

Спасибо БОЛЬШОЕ!
 
Ответить
Сообщение
Если заранее известны Подразделения и Статьи затрат, то в общем-то не сложно.

Спасибо БОЛЬШОЕ!

Автор - shmatique
Дата добавления - 10.06.2016 в 16:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание двумерного массива данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!