Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как создать такую последовательность 1,2,1,3,1,2,1,4,1,2,1,3 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как создать такую последовательность 1,2,1,3,1,2,1,4,1,2,1,3 (Формулы/Formulas)
как создать такую последовательность 1,2,1,3,1,2,1,4,1,2,1,3
allcoma Дата: Воскресенье, 12.06.2016, 16:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Как создать такую последовательность 1,2,1,3,1,2,1,4,1,2,1,3,1,2,1,5 до бесконечности?
один смещается и повторяется через 2, два через 4, три через 8, четыре через 16 и так далее
есть такие бесконечные последовательности
1,2,2,3,3,3,3,4,4,4,4,4,4,4,4
1,2,2,4,4,4,4,8,8,8,8,8,8,8,8
1,1,2,1,2,3,4,1,2,3,4,5,6,7,8

продолжение последовательности
 
Ответить
СообщениеКак создать такую последовательность 1,2,1,3,1,2,1,4,1,2,1,3,1,2,1,5 до бесконечности?
один смещается и повторяется через 2, два через 4, три через 8, четыре через 16 и так далее
есть такие бесконечные последовательности
1,2,2,3,3,3,3,4,4,4,4,4,4,4,4
1,2,2,4,4,4,4,8,8,8,8,8,8,8,8
1,1,2,1,2,3,4,1,2,3,4,5,6,7,8

продолжение последовательности

Автор - allcoma
Дата добавления - 12.06.2016 в 16:40
_Boroda_ Дата: Воскресенье, 12.06.2016, 17:06 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9360
Репутация: 3935 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Формула массива
(вводится одновременным нажатием Контрл Шифт Ентер)
Код
=9-СЧЁТ(ПОИСК(",";СТРОКА(A1)/2^(СТРОКА($1:$9)-1)))

Здесь максимум 9, если нужно больше, то вместо обеих девяток поставьте нужное число
Или так
Код
=10-СЧЁТ(ПОИСК(",";СТРОКА(A1)/2^СТРОКА($1:$9)))

Для любого разделителя целой и дробной части (не только запятой, как в формулах выше)
Код
=10-СЧЁТ(ПОИСК(ПСТР(1/2;2;1);СТРОКА(A1)/2^СТРОКА($1:$9)))


Немассивная формула (обычный ввод Ентером)
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК(",";СТРОКА(A1)/2^СТРОКА($1:$9))))+1
К сообщению приложен файл: 1676144_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Формула массива
(вводится одновременным нажатием Контрл Шифт Ентер)
Код
=9-СЧЁТ(ПОИСК(",";СТРОКА(A1)/2^(СТРОКА($1:$9)-1)))

Здесь максимум 9, если нужно больше, то вместо обеих девяток поставьте нужное число
Или так
Код
=10-СЧЁТ(ПОИСК(",";СТРОКА(A1)/2^СТРОКА($1:$9)))

Для любого разделителя целой и дробной части (не только запятой, как в формулах выше)
Код
=10-СЧЁТ(ПОИСК(ПСТР(1/2;2;1);СТРОКА(A1)/2^СТРОКА($1:$9)))


Немассивная формула (обычный ввод Ентером)
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК(",";СТРОКА(A1)/2^СТРОКА($1:$9))))+1

Автор - _Boroda_
Дата добавления - 12.06.2016 в 17:06
allcoma Дата: Воскресенье, 12.06.2016, 17:34 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, как сделать больше 10 ?
 
Ответить
Сообщение_Boroda_, как сделать больше 10 ?

Автор - allcoma
Дата добавления - 12.06.2016 в 17:34
allcoma Дата: Воскресенье, 12.06.2016, 17:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
разобрался
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК(",";СТРОКА(A1)/2^СТРОКА($1:$99))))+1


все правильно так нужно
[moder]Прочитайте Правила форума. На первый раз теги за Вас поправил.[/moder]


Сообщение отредактировал _Boroda_ - Воскресенье, 12.06.2016, 18:04
 
Ответить
Сообщениеразобрался
Код
=СУММПРОИЗВ(--ЕОШ(ПОИСК(",";СТРОКА(A1)/2^СТРОКА($1:$99))))+1


все правильно так нужно
[moder]Прочитайте Правила форума. На первый раз теги за Вас поправил.[/moder]

Автор - allcoma
Дата добавления - 12.06.2016 в 17:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как создать такую последовательность 1,2,1,3,1,2,1,4,1,2,1,3 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!