Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет количества оставшихся дней по месяцам между датами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет количества оставшихся дней по месяцам между датами (Формулы/Formulas)
подсчет количества оставшихся дней по месяцам между датами
kmv85 Дата: Понедельник, 13.06.2016, 12:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Помогите! Запутался. мне необходимо разнести оставшиеся количество дней между двумя датами. файл прилагаю. в нем количество дней я проставил руками, но хочу чтоб это делалось с помощью формул, так как массив дат очень огромный и руками вести подсчет занимает много времени. честно уже чЁкнулся. %)
К сообщению приложен файл: __.xlsx(9Kb)


Сообщение отредактировал kmv85 - Понедельник, 13.06.2016, 12:35
 
Ответить
СообщениеПомогите! Запутался. мне необходимо разнести оставшиеся количество дней между двумя датами. файл прилагаю. в нем количество дней я проставил руками, но хочу чтоб это делалось с помощью формул, так как массив дат очень огромный и руками вести подсчет занимает много времени. честно уже чЁкнулся. %)

Автор - kmv85
Дата добавления - 13.06.2016 в 12:28
Pelena Дата: Понедельник, 13.06.2016, 12:40 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11601
Репутация: 2572 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Похожая тема с решением


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПохожая тема с решением

Автор - Pelena
Дата добавления - 13.06.2016 в 12:40
Nic70y Дата: Понедельник, 13.06.2016, 13:25 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4121
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ИЛИ(СТОЛБЕЦ(A2)<МЕСЯЦ($A2);СТОЛБЕЦ(A2)>МЕСЯЦ($B2));"";МИН(КОНМЕСЯЦА(1&C$1;0);$B2)-МАКС((1&C$1)-1;$A2))
Код
=ЕСЛИ(ИЛИ(СТОЛБЕЦ(A2)<МЕСЯЦ($A2);СТОЛБЕЦ(A2)>МЕСЯЦ($B2));"";МИН(КОНМЕСЯЦА(ДАТА(2016;СТОЛБЕЦ(A2);1);0);$B2)-МАКС(ДАТА(2016;СТОЛБЕЦ(A2);1)-1;$A2))
или с форматом 0;;
Код
=МАКС(МИН(КОНМЕСЯЦА(1&C$1;0);$B2)-МАКС((1&C$1)-1;$A2);)

Похожая тема
не вникал, если что
К сообщению приложен файл: -1-.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 13.06.2016, 13:38
 
Ответить
Сообщение
Код
=ЕСЛИ(ИЛИ(СТОЛБЕЦ(A2)<МЕСЯЦ($A2);СТОЛБЕЦ(A2)>МЕСЯЦ($B2));"";МИН(КОНМЕСЯЦА(1&C$1;0);$B2)-МАКС((1&C$1)-1;$A2))
Код
=ЕСЛИ(ИЛИ(СТОЛБЕЦ(A2)<МЕСЯЦ($A2);СТОЛБЕЦ(A2)>МЕСЯЦ($B2));"";МИН(КОНМЕСЯЦА(ДАТА(2016;СТОЛБЕЦ(A2);1);0);$B2)-МАКС(ДАТА(2016;СТОЛБЕЦ(A2);1)-1;$A2))
или с форматом 0;;
Код
=МАКС(МИН(КОНМЕСЯЦА(1&C$1;0);$B2)-МАКС((1&C$1)-1;$A2);)

Похожая тема
не вникал, если что

Автор - Nic70y
Дата добавления - 13.06.2016 в 13:25
kmv85 Дата: Среда, 15.06.2016, 19:15 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Спасибо ОГРОМНОЕ.
Выручили. Доволен, как никогда.
может посоветуете, где можно почитать и попрактиковаться с формулами?
[moder]Здесь[/moder]


Сообщение отредактировал _Boroda_ - Среда, 15.06.2016, 20:44
 
Ответить
СообщениеNic70y, Спасибо ОГРОМНОЕ.
Выручили. Доволен, как никогда.
может посоветуете, где можно почитать и попрактиковаться с формулами?
[moder]Здесь[/moder]

Автор - kmv85
Дата добавления - 15.06.2016 в 19:15
kmv85 Дата: Четверг, 16.06.2016, 19:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, подскажите как 3 формулой воспользоваться, если период состоит из двух лет т.е. к примеру первая дата 12.10.2015 а вторая 11.11.2015 или первая 12.12.2015 вторая 12.01.2016
 
Ответить
СообщениеNic70y, подскажите как 3 формулой воспользоваться, если период состоит из двух лет т.е. к примеру первая дата 12.10.2015 а вторая 11.11.2015 или первая 12.12.2015 вторая 12.01.2016

Автор - kmv85
Дата добавления - 16.06.2016 в 19:43
Nic70y Дата: Четверг, 16.06.2016, 20:47 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4121
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
kmv85,
данные формулы рассчитаны на текущий год.
допустим у Вас будет 01.01.2015-31.12.2018 - как это по месяцам распределить, если их всего 12?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 17.06.2016, 08:45
 
Ответить
Сообщениеkmv85,
данные формулы рассчитаны на текущий год.
допустим у Вас будет 01.01.2015-31.12.2018 - как это по месяцам распределить, если их всего 12?

Автор - Nic70y
Дата добавления - 16.06.2016 в 20:47
kmv85 Дата: Пятница, 17.06.2016, 19:39 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, понял, все равно спасибо)
 
Ответить
СообщениеNic70y, понял, все равно спасибо)

Автор - kmv85
Дата добавления - 17.06.2016 в 19:39
Nic70y Дата: Суббота, 18.06.2016, 06:30 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4121
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
все равно
:)
можно любое решение придумать, если объясните какой результат нужен.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
все равно
:)
можно любое решение придумать, если объясните какой результат нужен.

Автор - Nic70y
Дата добавления - 18.06.2016 в 06:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет количества оставшихся дней по месяцам между датами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!