Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция СУММЕСЛИ для каждого периода. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция СУММЕСЛИ для каждого периода. (Формулы/Formulas)
Функция СУММЕСЛИ для каждого периода.
YBX Дата: Понедельник, 13.06.2016, 14:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Помогите пожалуйста оптимизировать работу, я сам что-то справиться не могу…(((
Дано: Столбец А - номер периода, столбец В - значение части периода, столбец С - индекс(Y или X) соответствующий части периода.
Что нужно: чтобы в столбце D по окончанию каждого периода (столбец А) считалась сумма всех частей периода соответствующего индекса(по аналогии с функцией суммесли).
Заранее спасибо!!)
К сообщению приложен файл: 2425698.xlsx(23Kb)
 
Ответить
СообщениеДобрый день! Помогите пожалуйста оптимизировать работу, я сам что-то справиться не могу…(((
Дано: Столбец А - номер периода, столбец В - значение части периода, столбец С - индекс(Y или X) соответствующий части периода.
Что нужно: чтобы в столбце D по окончанию каждого периода (столбец А) считалась сумма всех частей периода соответствующего индекса(по аналогии с функцией суммесли).
Заранее спасибо!!)

Автор - YBX
Дата добавления - 13.06.2016 в 14:39
_Boroda_ Дата: Понедельник, 13.06.2016, 14:51 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если в периоде не менее 2-х строк (в A478 нужно написать 14), то можно так
Код
=ЕСЛИ(A3<>A1;СУММЕСЛИМН(B$1:B3;A$1:A3;A1;C$1:C3;ЕСЛИ(A3<>A2;"Y";"X"));"")
К сообщению приложен файл: 2425698_1.xlsx(38Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли в периоде не менее 2-х строк (в A478 нужно написать 14), то можно так
Код
=ЕСЛИ(A3<>A1;СУММЕСЛИМН(B$1:B3;A$1:A3;A1;C$1:C3;ЕСЛИ(A3<>A2;"Y";"X"));"")

Автор - _Boroda_
Дата добавления - 13.06.2016 в 14:51
YBX Дата: Понедельник, 13.06.2016, 14:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_ Спасибо то что нужно!!!)))) Сам бы точно не справился!) Сейчас алгоритм Вашей формулы разбирать и учить буду ее теперь оч часто использовать буду. Спасибо!!!
 
Ответить
Сообщение_Boroda_ Спасибо то что нужно!!!)))) Сам бы точно не справился!) Сейчас алгоритм Вашей формулы разбирать и учить буду ее теперь оч часто использовать буду. Спасибо!!!

Автор - YBX
Дата добавления - 13.06.2016 в 14:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция СУММЕСЛИ для каждого периода. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!