Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не удаляется пробел из столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не удаляется пробел из столбца (Форматирование/Formattings)
Не удаляется пробел из столбца
tar88s Дата: Среда, 15.06.2016, 21:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

В столбце B должно искать соответствующие значения из G, где есть лишний пробел в конце после значения. Удалить в екселе не удается, только путем копирования в ворд, удаления, копирования обратно в ексель. В чем причина?
К сообщению приложен файл: example.xlsx(37Kb)


Сообщение отредактировал tar88s - Среда, 15.06.2016, 21:50
 
Ответить
СообщениеВ столбце B должно искать соответствующие значения из G, где есть лишний пробел в конце после значения. Удалить в екселе не удается, только путем копирования в ворд, удаления, копирования обратно в ексель. В чем причина?

Автор - tar88s
Дата добавления - 15.06.2016 в 21:47
RAN Дата: Среда, 15.06.2016, 21:59 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4419
Репутация: 872 ±
Замечаний: 0% ±

2010
Там не пробел, а неразрывный пробел.
Символ 160, а не 32.
Удаляется путем копирования его из ячейки и вставки в поле найти (заменить на пусто).


Быть или не быть, вот в чем загвоздка!

Сообщение отредактировал RAN - Среда, 15.06.2016, 22:01
 
Ответить
СообщениеТам не пробел, а неразрывный пробел.
Символ 160, а не 32.
Удаляется путем копирования его из ячейки и вставки в поле найти (заменить на пусто).

Автор - RAN
Дата добавления - 15.06.2016 в 21:59
_Boroda_ Дата: Среда, 15.06.2016, 22:31 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно и без удаления, сразу в формулу прописать
Код
=ИНДЕКС($G$2:$G$670;ПОИСКПОЗ(A2&СИМВОЛ(160);$F$2:$F$670;0))

или
Код
=ВПР(A2&СИМВОЛ(160);$F$2:$G$670;2;0)

А если очень хочется удалить, то можно так - жмете Контрл+h, встаете в поле "Найти" и, держа нажатым левый Альт, набираете на ЦИФРОВОЙ клавиатуре 0160, жмете Заменить все.
Или не набирать 0160, а, как Андрей уже выше написал, просто скопировать этот "пробел" из любой ячейки (например, из F2)
К сообщению приложен файл: 584798719.xlsx(38Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно и без удаления, сразу в формулу прописать
Код
=ИНДЕКС($G$2:$G$670;ПОИСКПОЗ(A2&СИМВОЛ(160);$F$2:$F$670;0))

или
Код
=ВПР(A2&СИМВОЛ(160);$F$2:$G$670;2;0)

А если очень хочется удалить, то можно так - жмете Контрл+h, встаете в поле "Найти" и, держа нажатым левый Альт, набираете на ЦИФРОВОЙ клавиатуре 0160, жмете Заменить все.
Или не набирать 0160, а, как Андрей уже выше написал, просто скопировать этот "пробел" из любой ячейки (например, из F2)

Автор - _Boroda_
Дата добавления - 15.06.2016 в 22:31
китин Дата: Четверг, 16.06.2016, 07:22 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4094
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а можно ведь и так извратится
Код
=ЕСЛИОШИБКА(ИНДЕКС($G$2:$G$671;ПОИСКПОЗ(A2&"*";$F$2:$F$671;0));"")
К сообщению приложен файл: 0546246.xlsx(38Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа можно ведь и так извратится
Код
=ЕСЛИОШИБКА(ИНДЕКС($G$2:$G$671;ПОИСКПОЗ(A2&"*";$F$2:$F$671;0));"")

Автор - китин
Дата добавления - 16.06.2016 в 07:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не удаляется пробел из столбца (Форматирование/Formattings)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!