Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод в столбец все совпадения из другой таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод в столбец все совпадения из другой таблицы (Формулы/Formulas)
Вывод в столбец все совпадения из другой таблицы
strannik Дата: Четверг, 16.06.2016, 17:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Есть 3 листа:

Лист1:
id name
1 test
2 test1
3 test
4 test2

Лист2:
ids names
1 test
2 test1
3 test3

Подскажите как вывести на Лист3 в столбец значения id и name из Лист1 , в которых name совпадает с names из Лист2, т.е. чтобы на Лист3 получить такую таблицу:

Лист3:
id_list1 name_list1
1 test
3 test
2 test1

Возможно ли это и как если да?
[moder]А в файле показать?[/moder]
К сообщению приложен файл: test.xlsx(11Kb)


Сообщение отредактировал strannik - Четверг, 16.06.2016, 17:17
 
Ответить
СообщениеДобрый день.
Есть 3 листа:

Лист1:
id name
1 test
2 test1
3 test
4 test2

Лист2:
ids names
1 test
2 test1
3 test3

Подскажите как вывести на Лист3 в столбец значения id и name из Лист1 , в которых name совпадает с names из Лист2, т.е. чтобы на Лист3 получить такую таблицу:

Лист3:
id_list1 name_list1
1 test
3 test
2 test1

Возможно ли это и как если да?
[moder]А в файле показать?[/moder]

Автор - strannik
Дата добавления - 16.06.2016 в 17:01
strannik Дата: Четверг, 16.06.2016, 17:17 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Прикрепил файл
 
Ответить
СообщениеПрикрепил файл

Автор - strannik
Дата добавления - 16.06.2016 в 17:17
Manyasha Дата: Четверг, 16.06.2016, 17:32 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1587
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
strannik, так пойдет?
для id (формула массива, вводить через ctrl+shift+enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$5;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(Лист2!$B$2:$B$4;Лист1!$B$2:$B$5);СТРОКА($A$2:$A$5)-1);СТРОКА(A1)));"")

Если id - уникальны, то name можно через впр вытащить:
Код
=ВПР(A2;Лист1!$A$2:$B$5;2;0)
К сообщению приложен файл: test-1.xlsx(11Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеstrannik, так пойдет?
для id (формула массива, вводить через ctrl+shift+enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$5;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(Лист2!$B$2:$B$4;Лист1!$B$2:$B$5);СТРОКА($A$2:$A$5)-1);СТРОКА(A1)));"")

Если id - уникальны, то name можно через впр вытащить:
Код
=ВПР(A2;Лист1!$A$2:$B$5;2;0)

Автор - Manyasha
Дата добавления - 16.06.2016 в 17:32
strannik Дата: Четверг, 16.06.2016, 17:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
strannik, так пойдет?

а возможно ли вывести данные в том порядке, который нужен без дальнейшей сортировки?
т.е.:
1 test
3 test
2 test1
а не :
1 test
2 test1
3 test
 
Ответить
Сообщение
strannik, так пойдет?

а возможно ли вывести данные в том порядке, который нужен без дальнейшей сортировки?
т.е.:
1 test
3 test
2 test1
а не :
1 test
2 test1
3 test

Автор - strannik
Дата добавления - 16.06.2016 в 17:56
strannik Дата: Четверг, 16.06.2016, 18:42 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
и еще уточните пожалуйста в Лист3!А3 вижу такую формулу:



Подскажите пожалуйста, зачем они?
[moder]Формулы нужно обрамлять тегами (кнопка fx)


Сообщение отредактировал _Boroda_ - Четверг, 16.06.2016, 20:37
 
Ответить
Сообщениеи еще уточните пожалуйста в Лист3!А3 вижу такую формулу:



Подскажите пожалуйста, зачем они?
[moder]Формулы нужно обрамлять тегами (кнопка fx)

Автор - strannik
Дата добавления - 16.06.2016 в 18:42
strannik Дата: Четверг, 16.06.2016, 19:26 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
разобрался спасибо, тема закрыта
 
Ответить
Сообщениеразобрался спасибо, тема закрыта

Автор - strannik
Дата добавления - 16.06.2016 в 19:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод в столбец все совпадения из другой таблицы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!