Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор нескольких макс значений с выводом названий столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор нескольких макс значений с выводом названий столбцов (Формулы/Formulas)
Выбор нескольких макс значений с выводом названий столбцов
Тормозяка Дата: Пятница, 17.06.2016, 15:43 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте Всем! Из построчного набора данных, необходимо выбрать несколько максимальных значений и в соседних строках отобразить названия столбцов с этими максимальными значениями.
К сообщению приложен файл: 2275319.xlsx(11Kb)


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеЗдравствуйте Всем! Из построчного набора данных, необходимо выбрать несколько максимальных значений и в соседних строках отобразить названия столбцов с этими максимальными значениями.

Автор - Тормозяка
Дата добавления - 17.06.2016 в 15:43
krosav4ig Дата: Пятница, 17.06.2016, 16:07 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1347
Репутация: 547 ±
Замечаний: 0% ±

Excel 2007, 2013
так нужно?
Код
=НАИМЕНЬШИЙ((СЧЁТЕСЛИ($B3:$I3;">"&$B3:$I3)<3)*$B$1:$I$1;СТОЛБЕЦ(F3))
К сообщению приложен файл: 8490129.xlsx(12Kb)


(_)Õvõ(_)
 
Ответить
Сообщениетак нужно?
Код
=НАИМЕНЬШИЙ((СЧЁТЕСЛИ($B3:$I3;">"&$B3:$I3)<3)*$B$1:$I$1;СТОЛБЕЦ(F3))

Автор - krosav4ig
Дата добавления - 17.06.2016 в 16:07
jakim Дата: Пятница, 17.06.2016, 16:14 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 680
Репутация: 172 ±
Замечаний: 0% ±

Или так?

Код
=MATCH(LARGE(B3:I3;COLUMNS($B:B));$B3:$I3;0)


Сообщение отредактировал jakim - Пятница, 17.06.2016, 16:14
 
Ответить
Сообщение
Или так?

Код
=MATCH(LARGE(B3:I3;COLUMNS($B:B));$B3:$I3;0)

Автор - jakim
Дата добавления - 17.06.2016 в 16:14
Тормозяка Дата: Пятница, 17.06.2016, 16:31 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо друзья! Обе формулы замечательно работают. Возникает вопрос. Если при выборе трех максимальных значений будет четвертое. Пример: 25, 15, 12, 12. Как предусмотреть появление четвертого?(В принципе оно имеет право на существование). В Ваших формулах игнорируются первые числа


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеСпасибо друзья! Обе формулы замечательно работают. Возникает вопрос. Если при выборе трех максимальных значений будет четвертое. Пример: 25, 15, 12, 12. Как предусмотреть появление четвертого?(В принципе оно имеет право на существование). В Ваших формулах игнорируются первые числа

Автор - Тормозяка
Дата добавления - 17.06.2016 в 16:31
jakim Дата: Пятница, 17.06.2016, 17:08 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 680
Репутация: 172 ±
Замечаний: 0% ±

В моём случае протяните формулу вправо.

Код
=MATCH(LARGE($B3:$I3;COLUMNS($B:B));$B3:$I3;0)
 
Ответить
Сообщение
В моём случае протяните формулу вправо.

Код
=MATCH(LARGE($B3:$I3;COLUMNS($B:B));$B3:$I3;0)

Автор - jakim
Дата добавления - 17.06.2016 в 17:08
Udik Дата: Пятница, 17.06.2016, 17:11 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1215
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
Для возможного 4-го значения такую массивку можно
Код

{=ЕСЛИ(НАИБОЛЬШИЙ($B$2:$I6;4)=НАИБОЛЬШИЙ($B6:$I6;3);МАКС(($B$2:$I$2=НАИБОЛЬШИЙ($B6:$I6;3))*$B$1:$I$1);"")}

или так (зависит от того какой столбец будет 3 выводить)
Код

{=ЕСЛИ(НАИБОЛЬШИЙ($B2:$I$2;4)=НАИБОЛЬШИЙ($B2:$I2;3);НАИБОЛЬШИЙ(($B$2:$I$2=НАИБОЛЬШИЙ($B2:$I2;3))*$B$1:$I$1;2);"")}
К сообщению приложен файл: 0t.xlsx(13Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Пятница, 17.06.2016, 20:29
 
Ответить
СообщениеДля возможного 4-го значения такую массивку можно
Код

{=ЕСЛИ(НАИБОЛЬШИЙ($B$2:$I6;4)=НАИБОЛЬШИЙ($B6:$I6;3);МАКС(($B$2:$I$2=НАИБОЛЬШИЙ($B6:$I6;3))*$B$1:$I$1);"")}

или так (зависит от того какой столбец будет 3 выводить)
Код

{=ЕСЛИ(НАИБОЛЬШИЙ($B2:$I$2;4)=НАИБОЛЬШИЙ($B2:$I2;3);НАИБОЛЬШИЙ(($B$2:$I$2=НАИБОЛЬШИЙ($B2:$I2;3))*$B$1:$I$1;2);"")}

Автор - Udik
Дата добавления - 17.06.2016 в 17:11
Тормозяка Дата: Пятница, 17.06.2016, 17:33 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Еще раз спасибо Вам! С меня причитается! pray pray respect


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеЕще раз спасибо Вам! С меня причитается! pray pray respect

Автор - Тормозяка
Дата добавления - 17.06.2016 в 17:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор нескольких макс значений с выводом названий столбцов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!