Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значений по меняющимся столбцам и строкам таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значений по меняющимся столбцам и строкам таблицы (Формулы/Formulas)
Выбор значений по меняющимся столбцам и строкам таблицы
dmisviridov Дата: Понедельник, 20.06.2016, 06:29 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Суть проблемы вот в чём:
Во вкладке "ТАБЛИЦА" в столбцы отмеченные синим цветом (Это столбцы B, C, D и E) заполняется входящая информация (Клиент, Номер документа, Артикул, Количество закупаемого изделия) для заполнения счёта. Необходимо, чтобы в столбец G (Скидка) проставлялся процент скидки.
Процент скидки берётся в зависимости от столбца и строки Вкладки "Скидки" при этом:
1) Номер строки для вкладки "СКИДКИ" берётся в зависимости от значения Ячейки В2 вкладки "ТАБЛИЦА" в данном примере - это Империя Интерьера;
2) А Номер столбца для вкладки "СКИДКИ" берётся в зависимости от значения от Ячеек столбца F вкладки " таблица" в данном примере:
2.1) в ячейке F2 стоит C-line, значит во вкладке "Скидки" машина находит столбец С-line (это столбец F) и спускается до строки 6 (это строка где написано Империя Интерьера) на пересечении столбца F и строки 6 имеется значение 9 (его и надо ставить);
2.2) в ячейке F3 стоит Т-line, значит во вкладке "Скидки" машина находит столбец Т-line (это столбец Е) и спускается до строки 6 (это строка где написано Империя Интерьера) на пересечении столбца Е и строки 6 имеется значение 8 (его и надо ставить);
2.3) в ячейке F4 стоит C-line, значит во вкладке "Скидки" машина находит столбец С-line (это столбец F) и спускается до строки 6 (это строка где написано Империя Интерьера) на пересечении столбца F и строки 6 имеется значение 9 (его и надо ставить);
и т.д.
К сообщению приложен файл: 2144337.xls(86Kb)
 
Ответить
СообщениеСуть проблемы вот в чём:
Во вкладке "ТАБЛИЦА" в столбцы отмеченные синим цветом (Это столбцы B, C, D и E) заполняется входящая информация (Клиент, Номер документа, Артикул, Количество закупаемого изделия) для заполнения счёта. Необходимо, чтобы в столбец G (Скидка) проставлялся процент скидки.
Процент скидки берётся в зависимости от столбца и строки Вкладки "Скидки" при этом:
1) Номер строки для вкладки "СКИДКИ" берётся в зависимости от значения Ячейки В2 вкладки "ТАБЛИЦА" в данном примере - это Империя Интерьера;
2) А Номер столбца для вкладки "СКИДКИ" берётся в зависимости от значения от Ячеек столбца F вкладки " таблица" в данном примере:
2.1) в ячейке F2 стоит C-line, значит во вкладке "Скидки" машина находит столбец С-line (это столбец F) и спускается до строки 6 (это строка где написано Империя Интерьера) на пересечении столбца F и строки 6 имеется значение 9 (его и надо ставить);
2.2) в ячейке F3 стоит Т-line, значит во вкладке "Скидки" машина находит столбец Т-line (это столбец Е) и спускается до строки 6 (это строка где написано Империя Интерьера) на пересечении столбца Е и строки 6 имеется значение 8 (его и надо ставить);
2.3) в ячейке F4 стоит C-line, значит во вкладке "Скидки" машина находит столбец С-line (это столбец F) и спускается до строки 6 (это строка где написано Империя Интерьера) на пересечении столбца F и строки 6 имеется значение 9 (его и надо ставить);
и т.д.

Автор - dmisviridov
Дата добавления - 20.06.2016 в 06:29
Nic70y Дата: Понедельник, 20.06.2016, 06:49 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(Скидки!B$4:F$17;ПОИСКПОЗ(B2;Скидки!A$4:A$17;);ПОИСКПОЗ(F2;Скидки!B$3:F$3;))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС(Скидки!B$4:F$17;ПОИСКПОЗ(B2;Скидки!A$4:A$17;);ПОИСКПОЗ(F2;Скидки!B$3:F$3;))

Автор - Nic70y
Дата добавления - 20.06.2016 в 06:49
dmisviridov Дата: Понедельник, 20.06.2016, 07:02 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Спасибо. Работает.
 
Ответить
СообщениеСпасибо. Работает.

Автор - dmisviridov
Дата добавления - 20.06.2016 в 07:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значений по меняющимся столбцам и строкам таблицы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!