Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск стоп-слов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск стоп-слов (Формулы/Formulas)
Поиск стоп-слов
Ilnazus Дата: Понедельник, 20.06.2016, 11:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет!
Такая задача, есть список стоп-слов и фраз в столбце А. В каждой ячейке по одному примеру.
В столбце B представлены маленькие тексты по 300-500 символов каждый. В каждой ячейке по тексту.
Нужно производить поиск точных вхождений слов из столбца А в текстах из столбца B.
Результат выводить можно в любой форме (числовое или истина/ложь). Главное, чтобы было понятно - в каких текстах присутствуют стоп-слова.
Надеюсь на Вашу помощь)
[moder]Файл-то покажете? И желаемый результат[/moder]
Пример скинул. Результат подойдет любой, хоть единица/ноль, хоть Истина/ложь, либо еще как-нибудь. Главное, знать есть ли в текстах вхождения стоп-слов.
К сообщению приложен файл: 7207236.xlsx(20Kb)


Сообщение отредактировал Ilnazus - Понедельник, 20.06.2016, 11:59
 
Ответить
СообщениеВсем привет!
Такая задача, есть список стоп-слов и фраз в столбце А. В каждой ячейке по одному примеру.
В столбце B представлены маленькие тексты по 300-500 символов каждый. В каждой ячейке по тексту.
Нужно производить поиск точных вхождений слов из столбца А в текстах из столбца B.
Результат выводить можно в любой форме (числовое или истина/ложь). Главное, чтобы было понятно - в каких текстах присутствуют стоп-слова.
Надеюсь на Вашу помощь)
[moder]Файл-то покажете? И желаемый результат[/moder]
Пример скинул. Результат подойдет любой, хоть единица/ноль, хоть Истина/ложь, либо еще как-нибудь. Главное, знать есть ли в текстах вхождения стоп-слов.

Автор - Ilnazus
Дата добавления - 20.06.2016 в 11:16
Nic70y Дата: Понедельник, 20.06.2016, 12:53 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК(A$2:A$14;B2)))
вдруг правильно


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК(A$2:A$14;B2)))
вдруг правильно

Автор - Nic70y
Дата добавления - 20.06.2016 в 12:53
_Boroda_ Дата: Понедельник, 20.06.2016, 13:09 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Или формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СЧЁТ(ПОИСК(A$2:A$14;B2))
К сообщению приложен файл: 7207236_1.xlsx(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИли формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СЧЁТ(ПОИСК(A$2:A$14;B2))

Автор - _Boroda_
Дата добавления - 20.06.2016 в 13:09
Ilnazus Дата: Понедельник, 20.06.2016, 13:19 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно

Или формула массива

Потестил, оба варианта работают как часы!
Спасибо вам, люди добрые. :)
 
Ответить
Сообщение
вдруг правильно

Или формула массива

Потестил, оба варианта работают как часы!
Спасибо вам, люди добрые. :)

Автор - Ilnazus
Дата добавления - 20.06.2016 в 13:19
Ilnazus Дата: Вторник, 21.06.2016, 10:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Господа, а возможно ли выводить в третьем столбце какое-именно стоп-слово нашлось?
 
Ответить
СообщениеГоспода, а возможно ли выводить в третьем столбце какое-именно стоп-слово нашлось?

Автор - Ilnazus
Дата добавления - 21.06.2016 в 10:14
_Boroda_ Дата: Вторник, 21.06.2016, 10:35 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Конесно возможно.
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(A$2:A$14;B2);A$2:A$14);"")

Если несколько, то выводит нижнее из списка в столбце А
Добавлено
Если нужно выводить все слова, то можно так (серое)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$14;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($A$2:$A$14;$B2));СТРОКА(A$2:A$14));СТОЛБЕЦ(A2)));"")

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Файл _3 перевложил
К сообщению приложен файл: 7207236_3.xlsx(24Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеКонесно возможно.
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(A$2:A$14;B2);A$2:A$14);"")

Если несколько, то выводит нижнее из списка в столбце А
Добавлено
Если нужно выводить все слова, то можно так (серое)
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$14;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($A$2:$A$14;$B2));СТРОКА(A$2:A$14));СТОЛБЕЦ(A2)));"")

Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Файл _3 перевложил

Автор - _Boroda_
Дата добавления - 21.06.2016 в 10:35
Ilnazus Дата: Вторник, 21.06.2016, 12:05 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Если нужно выводить все слова, то можно так (серое)

То, что нужно. Благодарю
 
Ответить
Сообщение
Если нужно выводить все слова, то можно так (серое)

То, что нужно. Благодарю

Автор - Ilnazus
Дата добавления - 21.06.2016 в 12:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск стоп-слов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!