Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подбор значений основанный на использовании базы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подбор значений основанный на использовании базы (Формулы/Formulas)
Подбор значений основанный на использовании базы
Degas Дата: Четверг, 23.06.2016, 11:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день!
Помогите, пожалуйста, решить следующую задачу:
Имеется таблица, в которой указаны названия железно-дорожных станций (файл 1 во вложении), в нее необходимо добавить столбец с регионом, и сделать так, чтобы он автоматически заполнялся основываясь на данных с базы (файл 2 во вложении).
Например в файле 1 появляется станция АСТРАХАНЬ ВТОРАЯ, необходимо, чтобы в столбце справа автоматически появился регион Астраханская.
У меня даже мыслей нет, как это сделать :( Надеюсь на Вашу помощь!
К сообщению приложен файл: _1.xls(58Kb) · _2.xls(61Kb)
 
Ответить
СообщениеДобрый день!
Помогите, пожалуйста, решить следующую задачу:
Имеется таблица, в которой указаны названия железно-дорожных станций (файл 1 во вложении), в нее необходимо добавить столбец с регионом, и сделать так, чтобы он автоматически заполнялся основываясь на данных с базы (файл 2 во вложении).
Например в файле 1 появляется станция АСТРАХАНЬ ВТОРАЯ, необходимо, чтобы в столбце справа автоматически появился регион Астраханская.
У меня даже мыслей нет, как это сделать :( Надеюсь на Вашу помощь!

Автор - Degas
Дата добавления - 23.06.2016 в 11:39
pabchek Дата: Четверг, 23.06.2016, 11:51 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 664
Репутация: 147 ±
Замечаний: 0% ±

Excel 2007
Так надо?

Добавлено
Там у Вас пробелов много лишних. Поправил формулу, файл перезалил
Код
=ЕСЛИОШИБКА(ИНДЕКС('Лист1 (2)'!C$2:C$351;ПОИСКПОЗ(СЖПРОБЕЛЫ(C4);'Лист1 (2)'!B$2:B$351;0));"")
К сообщению приложен файл: 8683655.xlsb(25Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 23.06.2016, 11:53
 
Ответить
СообщениеТак надо?

Добавлено
Там у Вас пробелов много лишних. Поправил формулу, файл перезалил
Код
=ЕСЛИОШИБКА(ИНДЕКС('Лист1 (2)'!C$2:C$351;ПОИСКПОЗ(СЖПРОБЕЛЫ(C4);'Лист1 (2)'!B$2:B$351;0));"")

Автор - pabchek
Дата добавления - 23.06.2016 в 11:51
китин Дата: Четверг, 23.06.2016, 12:18 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3673
Репутация: 573 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или вот так можно
Там у Вас пробелов много лишних

Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;1/(СЖПРОБЕЛЫ(C4)='Лист1 (2)'!$B$2:$B$351);'Лист1 (2)'!$C$2:$C$351);"Нет в списке")
К сообщению приложен файл: 234.xlsx(36Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили вот так можно
Там у Вас пробелов много лишних

Код
=ЕСЛИОШИБКА(ПРОСМОТР(1;1/(СЖПРОБЕЛЫ(C4)='Лист1 (2)'!$B$2:$B$351);'Лист1 (2)'!$C$2:$C$351);"Нет в списке")

Автор - китин
Дата добавления - 23.06.2016 в 12:18
_Boroda_ Дата: Четверг, 23.06.2016, 12:44 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9786
Репутация: 4135 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(C4);'Лист1 (2)'!$B$2:$C$351;2;);"")

Там у Вас пробелов много лишних
К сообщению приложен файл: 2345678.xlsx(37Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(C4);'Лист1 (2)'!$B$2:$C$351;2;);"")

Там у Вас пробелов много лишних

Автор - _Boroda_
Дата добавления - 23.06.2016 в 12:44
Degas Дата: Четверг, 23.06.2016, 12:47 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
pabchek, китин, Низкий Вам поклон товарищи! Воспользовался пока только вторым способом, но и он отлично работает!
Сейчас постараюсь Вам на кошельки по копеечке сбросить!
 
Ответить
Сообщениеpabchek, китин, Низкий Вам поклон товарищи! Воспользовался пока только вторым способом, но и он отлично работает!
Сейчас постараюсь Вам на кошельки по копеечке сбросить!

Автор - Degas
Дата добавления - 23.06.2016 в 12:47
Degas Дата: Четверг, 23.06.2016, 13:29 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
pabchek, возникли некоторые сложности с перечислением обещанной копеечки, вебмани для меня жутко не удобный, в итоге деньги ушли, но когда дойдут и сколько дойдет не понятно (везде куча не понятных комиссий)
 
Ответить
Сообщениеpabchek, возникли некоторые сложности с перечислением обещанной копеечки, вебмани для меня жутко не удобный, в итоге деньги ушли, но когда дойдут и сколько дойдет не понятно (везде куча не понятных комиссий)

Автор - Degas
Дата добавления - 23.06.2016 в 13:29
китин Дата: Четверг, 23.06.2016, 13:29 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3673
Репутация: 573 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Degas, Спасибо


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеDegas, Спасибо

Автор - китин
Дата добавления - 23.06.2016 в 13:29
pabchek Дата: Четверг, 23.06.2016, 13:50 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 664
Репутация: 147 ±
Замечаний: 0% ±

Excel 2007
И мое спасибо!


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеИ мое спасибо!

Автор - pabchek
Дата добавления - 23.06.2016 в 13:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подбор значений основанный на использовании базы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!