Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выборка нескольких значений по одному условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка нескольких значений по одному условию (Формулы/Formulas)
выборка нескольких значений по одному условию
lotos1908 Дата: Четверг, 23.06.2016, 23:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток. Возможно где то моя проблема уже кем то решена, я к сожалению не нашел. Суть вопроса такова: есть таблица в которой в одном столбце указаны фамилии сотрудников, в другом список товара, который эти сотрудники купили. Цель: на другом листе, при выборе фамилии из выпадающего списка, под ячейку с фамилией подтягивается весь товар который купил сотрудник.
Заранее благодарен!!!
Кусок таблицы прилагаю!
 
Ответить
СообщениеДоброго времени суток. Возможно где то моя проблема уже кем то решена, я к сожалению не нашел. Суть вопроса такова: есть таблица в которой в одном столбце указаны фамилии сотрудников, в другом список товара, который эти сотрудники купили. Цель: на другом листе, при выборе фамилии из выпадающего списка, под ячейку с фамилией подтягивается весь товар который купил сотрудник.
Заранее благодарен!!!
Кусок таблицы прилагаю!

Автор - lotos1908
Дата добавления - 23.06.2016 в 23:14
lotos1908 Дата: Четверг, 23.06.2016, 23:15 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
пример таблицы
К сообщению приложен файл: 5918965.xlsx(41Kb)
 
Ответить
Сообщениепример таблицы

Автор - lotos1908
Дата добавления - 23.06.2016 в 23:15
_Boroda_ Дата: Пятница, 24.06.2016, 00:01 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Посмотрите вариант сводной таблицей
К сообщению приложен файл: 5918965_1.xlsx(47Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПосмотрите вариант сводной таблицей

Автор - _Boroda_
Дата добавления - 24.06.2016 в 00:01
китин Дата: Пятница, 24.06.2016, 07:27 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Вот такой вариант с формулами массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('таблица с данными'!D$1:D$32;НАИМЕНЬШИЙ(ЕСЛИ('что хочу получить'!$A$1='таблица с данными'!$A$1:$A$32;СТРОКА('таблица с данными'!$A$1:$A$32));СТРОКА(A1)));"")

[p.s.]в столбце L табличка для выпадающего списка.ее можно пополнять, главное без пропусков строк
К сообщению приложен файл: 345.xlsx(44Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеВот такой вариант с формулами массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('таблица с данными'!D$1:D$32;НАИМЕНЬШИЙ(ЕСЛИ('что хочу получить'!$A$1='таблица с данными'!$A$1:$A$32;СТРОКА('таблица с данными'!$A$1:$A$32));СТРОКА(A1)));"")

[p.s.]в столбце L табличка для выпадающего списка.ее можно пополнять, главное без пропусков строк

Автор - китин
Дата добавления - 24.06.2016 в 07:27
jakim Дата: Пятница, 24.06.2016, 15:28 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Без формул массива.
К сообщению приложен файл: 4409466.xlsx(44Kb)
 
Ответить
Сообщение
Без формул массива.

Автор - jakim
Дата добавления - 24.06.2016 в 15:28
lotos1908 Дата: Пятница, 24.06.2016, 20:33 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, вариант с сводной самый удобный! а можно по подробнее как именно данная сводная сделана? или может где подобная инструкция есть? буду очень признателен!!
[moder]как делать сводную таблицу в excel[/moder]


Сообщение отредактировал _Boroda_ - Пятница, 24.06.2016, 21:47
 
Ответить
Сообщение_Boroda_, вариант с сводной самый удобный! а можно по подробнее как именно данная сводная сделана? или может где подобная инструкция есть? буду очень признателен!!
[moder]как делать сводную таблицу в excel[/moder]

Автор - lotos1908
Дата добавления - 24.06.2016 в 20:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка нескольких значений по одному условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!