Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в текстовой ячейке значения из массива данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в текстовой ячейке значения из массива данных (Формулы/Formulas)
Поиск в текстовой ячейке значения из массива данных
Винкер Дата: Пятница, 24.06.2016, 10:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Помогите, пожалуйста, не знаю уже куда копать!

В ячейке таблицы дан адрес, необходимо найти в нем любой город из списка, и если он там найдется - проставить в соответствующей ячейке значение Город, если не найдется - Значение Сельское поселение.
Также в ячейке с адресом надо определить район, при совпадении значения из списка районов вывести в соответствующей ячейке название района.

Файл с таблицей во вложении.
К сообщению приложен файл: 2709027.xlsx(11Kb)
 
Ответить
СообщениеДобрый день. Помогите, пожалуйста, не знаю уже куда копать!

В ячейке таблицы дан адрес, необходимо найти в нем любой город из списка, и если он там найдется - проставить в соответствующей ячейке значение Город, если не найдется - Значение Сельское поселение.
Также в ячейке с адресом надо определить район, при совпадении значения из списка районов вывести в соответствующей ячейке название района.

Файл с таблицей во вложении.

Автор - Винкер
Дата добавления - 24.06.2016 в 10:18
SLAVICK Дата: Пятница, 24.06.2016, 10:44 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1962
Репутация: 669 ±
Замечаний: 0% ±

2007,2010,2013,2016
формула массива:
Код
=МАКС(ЕСЛИ(ЕЧИСЛО(ПОИСК($D$2:$D$23;A2;1));1;0))
+ формат ячейки или
просто формула массива:
Код
=ТЕКСТ(МАКС(ЕСЛИ(ЕЧИСЛО(ПОИСК($D$2:$D$23;A2;1));1;0));"""Город"";;""Сельское поселение""")
К сообщению приложен файл: 2532186.xlsx(16Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщениеформула массива:
Код
=МАКС(ЕСЛИ(ЕЧИСЛО(ПОИСК($D$2:$D$23;A2;1));1;0))
+ формат ячейки или
просто формула массива:
Код
=ТЕКСТ(МАКС(ЕСЛИ(ЕЧИСЛО(ПОИСК($D$2:$D$23;A2;1));1;0));"""Город"";;""Сельское поселение""")

Автор - SLAVICK
Дата добавления - 24.06.2016 в 10:44
pabchek Дата: Пятница, 24.06.2016, 10:49 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 693
Репутация: 153 ±
Замечаний: 0% ±

Excel 2007
Было уже у нас ссылка
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК(D$2:D$23;$A2);D$2:D$23);$F$2)
К сообщению приложен файл: 9622045.xlsx(13Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеБыло уже у нас ссылка
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК(D$2:D$23;$A2);D$2:D$23);$F$2)

Автор - pabchek
Дата добавления - 24.06.2016 в 10:49
Винкер Дата: Пятница, 24.06.2016, 10:50 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
SLAVICK, спасибо огромное, по второй задаче я, видимо, неточно пояснил. Надо чтобы в столбце Район выходило название района, которое указано в адресе!
 
Ответить
СообщениеSLAVICK, спасибо огромное, по второй задаче я, видимо, неточно пояснил. Надо чтобы в столбце Район выходило название района, которое указано в адресе!

Автор - Винкер
Дата добавления - 24.06.2016 в 10:50
pabchek Дата: Пятница, 24.06.2016, 10:59 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 693
Репутация: 153 ±
Замечаний: 0% ±

Excel 2007
значение Город

Да, я тоже получается недочитал. Поправил
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПРОСМОТР(2;1/ПОИСК(D$2:D$23;$A2));"Город");$F$2)
К сообщению приложен файл: 0569278.xlsx(13Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 24.06.2016, 11:01
 
Ответить
Сообщение
значение Город

Да, я тоже получается недочитал. Поправил
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПРОСМОТР(2;1/ПОИСК(D$2:D$23;$A2));"Город");$F$2)

Автор - pabchek
Дата добавления - 24.06.2016 в 10:59
Винкер Дата: Пятница, 24.06.2016, 11:07 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
pabchek, спасибо, именно то что надо!
 
Ответить
Сообщениеpabchek, спасибо, именно то что надо!

Автор - Винкер
Дата добавления - 24.06.2016 в 11:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в текстовой ячейке значения из массива данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!