Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/найти в столбце 1, и тогда поставить 1, но в другую сточку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » найти в столбце 1, и тогда поставить 1, но в другую сточку (Формулы/Formulas)
найти в столбце 1, и тогда поставить 1, но в другую сточку
vladislaf Дата: Понедельник, 27.06.2016, 13:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте!
Надо решить такую задачу:
- найти в столбце Q значение 1
- поставить эту 1 в столбец E, но выше на несколько строк, когда встретим 0.

Файл excel прилагаю. Заранее благодарен!
К сообщению приложен файл: 0732100.xlsx(22Kb)


Сообщение отредактировал vladislaf - Понедельник, 27.06.2016, 14:04
 
Ответить
СообщениеЗдравствуйте!
Надо решить такую задачу:
- найти в столбце Q значение 1
- поставить эту 1 в столбец E, но выше на несколько строк, когда встретим 0.

Файл excel прилагаю. Заранее благодарен!

Автор - vladislaf
Дата добавления - 27.06.2016 в 13:57
Nic70y Дата: Понедельник, 27.06.2016, 13:59 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
Файл excel прилагаю
зачем обманываете? :(


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Файл excel прилагаю
зачем обманываете? :(

Автор - Nic70y
Дата добавления - 27.06.2016 в 13:59
vladislaf Дата: Понедельник, 27.06.2016, 14:05 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Приложил, извиняюсь.
 
Ответить
СообщениеПриложил, извиняюсь.

Автор - vladislaf
Дата добавления - 27.06.2016 в 14:05
Nic70y Дата: Понедельник, 27.06.2016, 14:13 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
столбец E, но выше на несколько строк, когда встретим 0
так у Вас там одни нули (напротив текста)
лично я не понял как должен выглядеть результат

мож так:
Код
=ЕСЛИ(A1<>"";--ЕЧИСЛО(ПОИСКПОЗ(1;Q1:ИНДЕКС(Q$1:Q$34;ПОИСКПОЗ("*";A$2:A$34;)+СТРОКА());));"")
К сообщению приложен файл: 9703813.xlsx(22Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
столбец E, но выше на несколько строк, когда встретим 0
так у Вас там одни нули (напротив текста)
лично я не понял как должен выглядеть результат

мож так:
Код
=ЕСЛИ(A1<>"";--ЕЧИСЛО(ПОИСКПОЗ(1;Q1:ИНДЕКС(Q$1:Q$34;ПОИСКПОЗ("*";A$2:A$34;)+СТРОКА());));"")

Автор - Nic70y
Дата добавления - 27.06.2016 в 14:13
vladislaf Дата: Понедельник, 27.06.2016, 14:46 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
да, напротив текста стоят нули, но могут быть и 1.
Почти правильно получилось, в том файлике в ячейке E17 должна 1 стоять, так как в ячейке Q19 тоже 1. Сможете подправить формулу? Был бы вам признателен.
 
Ответить
Сообщениеда, напротив текста стоят нули, но могут быть и 1.
Почти правильно получилось, в том файлике в ячейке E17 должна 1 стоять, так как в ячейке Q19 тоже 1. Сможете подправить формулу? Был бы вам признателен.

Автор - vladislaf
Дата добавления - 27.06.2016 в 14:46
Nic70y Дата: Понедельник, 27.06.2016, 15:07 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
E17 должна 1 стоять
она там и стоит, хотя ошибка в формуле есть (поторопился)
Код
=ЕСЛИ(A1<>"";--ЕЧИСЛО(ПОИСКПОЗ(1;Q1:ИНДЕКС(Q$1:Q$34;ЕСЛИОШИБКА(ПОИСКПОЗ("*";A2:A$34;)+СТРОКА();34));));"")
К сообщению приложен файл: 6693248.xlsx(22Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
E17 должна 1 стоять
она там и стоит, хотя ошибка в формуле есть (поторопился)
Код
=ЕСЛИ(A1<>"";--ЕЧИСЛО(ПОИСКПОЗ(1;Q1:ИНДЕКС(Q$1:Q$34;ЕСЛИОШИБКА(ПОИСКПОЗ("*";A2:A$34;)+СТРОКА();34));));"")

Автор - Nic70y
Дата добавления - 27.06.2016 в 15:07
vladislaf Дата: Понедельник, 27.06.2016, 16:14 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Большое спасибо!
Все получилось!
 
Ответить
СообщениеБольшое спасибо!
Все получилось!

Автор - vladislaf
Дата добавления - 27.06.2016 в 16:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » найти в столбце 1, и тогда поставить 1, но в другую сточку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!