Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Некорректный подсчёт количества кликов через СУММПРОИЗВ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Некорректный подсчёт количества кликов через СУММПРОИЗВ (Формулы/Formulas)
Некорректный подсчёт количества кликов через СУММПРОИЗВ
Che79 Дата: Воскресенье, 03.07.2016, 19:07 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
Всех приветствую!
В приложенном файле СУММПРОИЗВ одну ячейку обрабатывает верно, вторую (рядом) нет. Помогите разобраться в чем подвох?
Вопрос простой, но я в ступоре pray Может, файл битый какой-то...
Сам файл достался по наследству, большой, тяжелый, с остатками макросов, огромным кол-вом пользовательских стилей, объединенными ячейками и пр.
Объяснялка что нужно в самом файле, точнее в его куске.
Спасибо.
К сообщению приложен файл: Look_click.xls(62Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВсех приветствую!
В приложенном файле СУММПРОИЗВ одну ячейку обрабатывает верно, вторую (рядом) нет. Помогите разобраться в чем подвох?
Вопрос простой, но я в ступоре pray Может, файл битый какой-то...
Сам файл достался по наследству, большой, тяжелый, с остатками макросов, огромным кол-вом пользовательских стилей, объединенными ячейками и пр.
Объяснялка что нужно в самом файле, точнее в его куске.
Спасибо.

Автор - Che79
Дата добавления - 03.07.2016 в 19:07
Nic70y Дата: Воскресенье, 03.07.2016, 19:18 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
а что Вы хотели...
напишите в любой ячейке
Код
=B9
, протяните вправо.
некорректность в объединенных ячейках, а не в формуле.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеа что Вы хотели...
напишите в любой ячейке
Код
=B9
, протяните вправо.
некорректность в объединенных ячейках, а не в формуле.

Автор - Nic70y
Дата добавления - 03.07.2016 в 19:18
Che79 Дата: Воскресенье, 03.07.2016, 19:26 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
некорректность в объединенных ячейках

Николай, спасибо за подсказку, объединение ячеек - зло. Разъединим))


Делай нормально и будет нормально!
 
Ответить
Сообщение
некорректность в объединенных ячейках

Николай, спасибо за подсказку, объединение ячеек - зло. Разъединим))

Автор - Che79
Дата добавления - 03.07.2016 в 19:26
krosav4ig Дата: Воскресенье, 03.07.2016, 21:21 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
как вариант для столбцов показы и клики формула
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ($B11:$BO11*(ПРОСМОТР(СТОЛБЕЦ($B$9:$BO$9);СТОЛБЕЦ($B$9:$BO$9)/(ДЛСТР($B$9:$BO$9)>0);$B$9:$BO$9)=ПРОСМОТР("яяя";$A$9:BP$9;$A$9:BP$9))*(ПРОСМОТР(СТОЛБЕЦ($B$10:$BO$10);СТОЛБЕЦ($B$10:$BO$10)/(ДЛСТР($B$10:$BO$10)>0);$B$10:$BO$10)=BP$10));0)
К сообщению приложен файл: 7583446.xls(68Kb)


(_)Õvõ(_)
 
Ответить
Сообщениекак вариант для столбцов показы и клики формула
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ($B11:$BO11*(ПРОСМОТР(СТОЛБЕЦ($B$9:$BO$9);СТОЛБЕЦ($B$9:$BO$9)/(ДЛСТР($B$9:$BO$9)>0);$B$9:$BO$9)=ПРОСМОТР("яяя";$A$9:BP$9;$A$9:BP$9))*(ПРОСМОТР(СТОЛБЕЦ($B$10:$BO$10);СТОЛБЕЦ($B$10:$BO$10)/(ДЛСТР($B$10:$BO$10)>0);$B$10:$BO$10)=BP$10));0)

Автор - krosav4ig
Дата добавления - 03.07.2016 в 21:21
Che79 Дата: Воскресенье, 03.07.2016, 22:36 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
krosav4ig, спасибо за "монстра"! Главное, что объединенные ячейки "ест".


Делай нормально и будет нормально!
 
Ответить
Сообщениеkrosav4ig, спасибо за "монстра"! Главное, что объединенные ячейки "ест".

Автор - Che79
Дата добавления - 03.07.2016 в 22:36
Nic70y Дата: Воскресенье, 03.07.2016, 22:46 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
Excel 2007, Excel 2010
Код
=СУММЕСЛИМН($C11:$BP11;$C$10:$BP$10;BQ$10;$B$9:$BO$9;$BP$9)

Главное, что объединенные ячейки "ест"
не уговорил :)
Код
=СУММПРОИЗВ($C11:$BP11;($C$10:$BP$10=BQ$10)*($B$9:$BO$9=$BP$9))
К сообщению приложен файл: 6859667.xls(60Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 03.07.2016, 22:47
 
Ответить
Сообщение
Excel 2007, Excel 2010
Код
=СУММЕСЛИМН($C11:$BP11;$C$10:$BP$10;BQ$10;$B$9:$BO$9;$BP$9)

Главное, что объединенные ячейки "ест"
не уговорил :)
Код
=СУММПРОИЗВ($C11:$BP11;($C$10:$BP$10=BQ$10)*($B$9:$BO$9=$BP$9))

Автор - Nic70y
Дата добавления - 03.07.2016 в 22:46
Che79 Дата: Воскресенье, 03.07.2016, 22:58 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
о как) спасибо! Я как-то и забыл, что в СУММЕСЛИМН диапазоны могут начинаться с разных строк/столбцов. Надо справку перечитать)
[offtop]Николай, давайте еще парочку сообщений на форуме и будут красивые 3000 yes


Делай нормально и будет нормально!
 
Ответить
Сообщениео как) спасибо! Я как-то и забыл, что в СУММЕСЛИМН диапазоны могут начинаться с разных строк/столбцов. Надо справку перечитать)
[offtop]Николай, давайте еще парочку сообщений на форуме и будут красивые 3000 yes

Автор - Che79
Дата добавления - 03.07.2016 в 22:58
Nic70y Дата: Воскресенье, 03.07.2016, 22:59 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
давайте еще парочку сообщений
ну вот еще одно:
что в СУММЕСЛИМН диапазоны могут начинаться с разных строк/столбцов
в суммпроизв тоже
=СУММПРОИЗВ($C11:$BP11;($C$10:$BP$10=BQ$10)*($B$9:$BO$9=$BP$9))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
давайте еще парочку сообщений
ну вот еще одно:
что в СУММЕСЛИМН диапазоны могут начинаться с разных строк/столбцов
в суммпроизв тоже
=СУММПРОИЗВ($C11:$BP11;($C$10:$BP$10=BQ$10)*($B$9:$BO$9=$BP$9))

Автор - Nic70y
Дата добавления - 03.07.2016 в 22:59
Che79 Дата: Воскресенье, 03.07.2016, 23:02 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
про суммпроизв помнил, а про суммеслимн - нет, последней пользуюсь реже...


Делай нормально и будет нормально!
 
Ответить
Сообщениепро суммпроизв помнил, а про суммеслимн - нет, последней пользуюсь реже...

Автор - Che79
Дата добавления - 03.07.2016 в 23:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Некорректный подсчёт количества кликов через СУММПРОИЗВ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!