Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнения двух таблиц с условием содержащим звездочку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнения двух таблиц с условием содержащим звездочку (Формулы/Formulas)
Сравнения двух таблиц с условием содержащим звездочку
flager Дата: Понедельник, 04.07.2016, 00:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Есть задача, пока не знаю как к ней подойти.
Условно есть две таблицы:
1я таблица содержит одну "запись" и шесть "значений признаков" к этой записи.
2я таблица "Значение" и те же 6 признаков.
Надо в первой таблице для каждой строки найти "значение" из второй таблице по комбинации признаков.
Но самая сложность в том, что в таблице со значениями вместо некоторый признак стоит "звездочка", подразумевается что для данной комбинации значений признака со звездочкой может быть любым значением.
Вторая условность, считается что к каждой строке может быть найдено только одной значение из второй таблице или не найдено вообще, тогда в такой строке надо поставить какой-нибудь признак, например запись "нет кода"

Во вложении пример, 1я таблицы - синяя, 2я таблица - зеленая.
красным для примера к первой таблице найдено значение из второй таблицы, но руками.

Можете подсказать как решить такую задачу?

[p.s.] буду благодарен.
К сообщению приложен файл: 8930600.xlsx(11Kb)
 
Ответить
СообщениеДобрый вечер!
Есть задача, пока не знаю как к ней подойти.
Условно есть две таблицы:
1я таблица содержит одну "запись" и шесть "значений признаков" к этой записи.
2я таблица "Значение" и те же 6 признаков.
Надо в первой таблице для каждой строки найти "значение" из второй таблице по комбинации признаков.
Но самая сложность в том, что в таблице со значениями вместо некоторый признак стоит "звездочка", подразумевается что для данной комбинации значений признака со звездочкой может быть любым значением.
Вторая условность, считается что к каждой строке может быть найдено только одной значение из второй таблице или не найдено вообще, тогда в такой строке надо поставить какой-нибудь признак, например запись "нет кода"

Во вложении пример, 1я таблицы - синяя, 2я таблица - зеленая.
красным для примера к первой таблице найдено значение из второй таблицы, но руками.

Можете подсказать как решить такую задачу?

[p.s.] буду благодарен.

Автор - flager
Дата добавления - 04.07.2016 в 00:07
krosav4ig Дата: Понедельник, 04.07.2016, 01:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1422
Репутация: 585 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте
Код
=ЕСЛИОШИБКА(ВПР(6;ЕСЛИ({1;0};МУМНОЖ(1-ЕОШ(ПОИСК($L$2:$Q$6;B2:G2));СТРОКА($1:$6)^0);$R$2:$R$6);2;);"НЕТ КОДА")
К сообщению приложен файл: 5100317.xlsx(12Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Понедельник, 04.07.2016, 03:36
 
Ответить
СообщениеЗдравствуйте
Код
=ЕСЛИОШИБКА(ВПР(6;ЕСЛИ({1;0};МУМНОЖ(1-ЕОШ(ПОИСК($L$2:$Q$6;B2:G2));СТРОКА($1:$6)^0);$R$2:$R$6);2;);"НЕТ КОДА")

Автор - krosav4ig
Дата добавления - 04.07.2016 в 01:26
BobroEJ Дата: Понедельник, 04.07.2016, 16:13 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Класс. krosav4ig, а не могли бы вы немного пояснить формулу? Она работает, всё супер, но примерно на этапе "ЕСЛИ({1;0}" у меня мозг сломался %) . Что значит данное логическое выражение?
 
Ответить
СообщениеКласс. krosav4ig, а не могли бы вы немного пояснить формулу? Она работает, всё супер, но примерно на этапе "ЕСЛИ({1;0}" у меня мозг сломался %) . Что значит данное логическое выражение?

Автор - BobroEJ
Дата добавления - 04.07.2016 в 16:13
krosav4ig Дата: Понедельник, 04.07.2016, 21:50 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1422
Репутация: 585 ±
Замечаний: 0% ±

Excel 2007, 2013
Что значит данное логическое выражение?

в данном случае то же, что и
Код
ВЫБОР({1;2};A1:A20;C1:C20)
то есть слепливает два вертикальных одномерных массива в один двумерный


(_)Õvõ(_)
 
Ответить
Сообщение
Что значит данное логическое выражение?

в данном случае то же, что и
Код
ВЫБОР({1;2};A1:A20;C1:C20)
то есть слепливает два вертикальных одномерных массива в один двумерный

Автор - krosav4ig
Дата добавления - 04.07.2016 в 21:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнения двух таблиц с условием содержащим звездочку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!