Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как автоматизировать перенос связи ячеек с листа на лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как автоматизировать перенос связи ячеек с листа на лист (Формулы/Formulas)
Как автоматизировать перенос связи ячеек с листа на лист
DrMini Дата: Понедельник, 04.07.2016, 13:56 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
Доброго времени суток. Подскажите пожалуйста, как сделать связь между ячейками с "Лист2" на "Лист1". Таблица на "Лист2" будет заполняться с печатного листа в ручную сверху вниз (так удобнее заполнять с оригинала). А сдавать отчёт надо в виде, как на "Лист1" (с лева на право). Ячеек надо перенести более 5000. Даже боюсь предположить, сколько кликать придётся. Прилагаю пример. Транспонировать не потеряв связь не выходит.
Очень надеюсь, что понятно объяснил.
К сообщению приложен файл: 20160704.xlsx(9Kb)


Сообщение отредактировал DrMini - Понедельник, 04.07.2016, 13:57
 
Ответить
СообщениеДоброго времени суток. Подскажите пожалуйста, как сделать связь между ячейками с "Лист2" на "Лист1". Таблица на "Лист2" будет заполняться с печатного листа в ручную сверху вниз (так удобнее заполнять с оригинала). А сдавать отчёт надо в виде, как на "Лист1" (с лева на право). Ячеек надо перенести более 5000. Даже боюсь предположить, сколько кликать придётся. Прилагаю пример. Транспонировать не потеряв связь не выходит.
Очень надеюсь, что понятно объяснил.

Автор - DrMini
Дата добавления - 04.07.2016 в 13:56
Nic70y Дата: Понедельник, 04.07.2016, 14:01 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(Лист2!$B$2:$G$7;ПОИСКПОЗ(B$1;Лист2!$A$2:$A$7;);ПОИСКПОЗ($A2;Лист2!$B$1:$G$1;))
К сообщению приложен файл: 3668990.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист2!$B$2:$G$7;ПОИСКПОЗ(B$1;Лист2!$A$2:$A$7;);ПОИСКПОЗ($A2;Лист2!$B$1:$G$1;))

Автор - Nic70y
Дата добавления - 04.07.2016 в 14:01
DrMini Дата: Понедельник, 04.07.2016, 14:06 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
Nic70y, СПАСИБО! Всё работает. yes
 
Ответить
СообщениеNic70y, СПАСИБО! Всё работает. yes

Автор - DrMini
Дата добавления - 04.07.2016 в 14:06
DrMini Дата: Понедельник, 04.07.2016, 16:03 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
Nic70y, Скажите, можно, как то сделать, что бы названия столбцов и строк (Верх:Бок) не использовались при расчёте?
 
Ответить
СообщениеNic70y, Скажите, можно, как то сделать, что бы названия столбцов и строк (Верх:Бок) не использовались при расчёте?

Автор - DrMini
Дата добавления - 04.07.2016 в 16:03
Nic70y Дата: Понедельник, 04.07.2016, 16:06 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Можно
Код
=ИНДЕКС(Лист2!$B$2:$G$7;СТОЛБЕЦ(A1);СТРОКА(A1))
К сообщению приложен файл: 2270909.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеМожно
Код
=ИНДЕКС(Лист2!$B$2:$G$7;СТОЛБЕЦ(A1);СТРОКА(A1))

Автор - Nic70y
Дата добавления - 04.07.2016 в 16:06
DrMini Дата: Понедельник, 04.07.2016, 16:16 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
Nic70y, Теперь всё идеально. СПАСИБО ОГРОМНОЕ.
 
Ответить
СообщениеNic70y, Теперь всё идеально. СПАСИБО ОГРОМНОЕ.

Автор - DrMini
Дата добавления - 04.07.2016 в 16:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как автоматизировать перенос связи ячеек с листа на лист (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!