Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР только к первому занчению из списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР только к первому занчению из списка (Формулы/Formulas)
ВПР только к первому занчению из списка
Nidus Дата: Понедельник, 04.07.2016, 14:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Есть конечная таблица с повторяющимися наименованиями продуктов, повторяются многократно. Есть вторая таблица со значениями к каждой продукции (без повторов наименований, но с повторами значений у разных наименований). Задача - подтянуть в конечную таблицу значения из второй - но только к первому наименованию по списку. Если наименование в конечной таблице потом повторяется - к нему - пусто. Пример составил - через счетесли, поискпоз - сделать не получается - не могу сообразить как, ступор просто.. Заранее спасибо!
К сообщению приложен файл: 3438255.xlsx(9Kb)
 
Ответить
СообщениеДобрый день!
Есть конечная таблица с повторяющимися наименованиями продуктов, повторяются многократно. Есть вторая таблица со значениями к каждой продукции (без повторов наименований, но с повторами значений у разных наименований). Задача - подтянуть в конечную таблицу значения из второй - но только к первому наименованию по списку. Если наименование в конечной таблице потом повторяется - к нему - пусто. Пример составил - через счетесли, поискпоз - сделать не получается - не могу сообразить как, ступор просто.. Заранее спасибо!

Автор - Nidus
Дата добавления - 04.07.2016 в 14:51
китин Дата: Понедельник, 04.07.2016, 14:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
чтой то вы с ЕСЛИ перемудрили
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$3:B3;B3)>1;"";ВПР(B3;$I$4:$J$7;2;0))
К сообщению приложен файл: 123.xlsx(9Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 04.07.2016, 14:54
 
Ответить
Сообщениечтой то вы с ЕСЛИ перемудрили
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$3:B3;B3)>1;"";ВПР(B3;$I$4:$J$7;2;0))

Автор - китин
Дата добавления - 04.07.2016 в 14:54
abtextime Дата: Понедельник, 04.07.2016, 15:06 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ИЛИ(B2="Арт";ЕОШИБКА(ВПР(B3;$B2:$B$3;1;0)));ВПР(B3;$E$3:$F$10;2;0);"")
К сообщению приложен файл: 7892377.xlsx(9Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(ИЛИ(B2="Арт";ЕОШИБКА(ВПР(B3;$B2:$B$3;1;0)));ВПР(B3;$E$3:$F$10;2;0);"")

Автор - abtextime
Дата добавления - 04.07.2016 в 15:06
abtextime Дата: Понедельник, 04.07.2016, 15:08 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
дотёмкал. что всё пгоще

Код
=ЕСЛИ(ИЛИ(B2="Арт";ЕОШИБКА(ВПР(B3;$B2:$B$3;1;0)));ВПР(B3;$I$4:$J$7;2;0);"")
К сообщению приложен файл: 7031735.xlsx(9Kb)
 
Ответить
Сообщениедотёмкал. что всё пгоще

Код
=ЕСЛИ(ИЛИ(B2="Арт";ЕОШИБКА(ВПР(B3;$B2:$B$3;1;0)));ВПР(B3;$I$4:$J$7;2;0);"")

Автор - abtextime
Дата добавления - 04.07.2016 в 15:08
Nidus Дата: Понедельник, 04.07.2016, 15:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
abtextime, китин, Шикарно! Спасибо огромное!
 
Ответить
Сообщениеabtextime, китин, Шикарно! Спасибо огромное!

Автор - Nidus
Дата добавления - 04.07.2016 в 15:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР только к первому занчению из списка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!