Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух и более столбцов с сортировкой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух и более столбцов с сортировкой (Формулы/Formulas)
Сравнение двух и более столбцов с сортировкой
Devkeyz Дата: Вторник, 05.07.2016, 13:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго времени суток, господа.

Возник конфуз, стала задача сделать сравнение данных, которые состоят из двух столбцов.
Имеем данные - Два столбца (Слово+Значение) за каждый месяц. Порядок слов, а также наличие и отсутствие в каждом из периодов - разное.
Стоит задача - сравнить столбцы по Столбцу "Слово" и отсортировать таким образом, чтобы повторяющиеся Слова из одного столбца были напротив таких же в другим, но при этом, чтобы числовые значения остались привязаны к Слову.
Я добавил файл, чтобы возможно было более понятно. Мне на самом деле сложно объяснить, если вы можете помочь, буду очень благодарен. Дело в том, что таких периодов много, а количество слов - не 20, как в примере, а несколько тысяч, и вручную это сравнить невозможно.

В итоге нужно получить таблицу, где в одном столбце - список слов за каждый период, а в последующих их значения за каждый отдельно взятый период.
К сообщению приложен файл: Table_Compare.xlsx(9Kb)


Сообщение отредактировал Devkeyz - Вторник, 05.07.2016, 13:04
 
Ответить
СообщениеДоброго времени суток, господа.

Возник конфуз, стала задача сделать сравнение данных, которые состоят из двух столбцов.
Имеем данные - Два столбца (Слово+Значение) за каждый месяц. Порядок слов, а также наличие и отсутствие в каждом из периодов - разное.
Стоит задача - сравнить столбцы по Столбцу "Слово" и отсортировать таким образом, чтобы повторяющиеся Слова из одного столбца были напротив таких же в другим, но при этом, чтобы числовые значения остались привязаны к Слову.
Я добавил файл, чтобы возможно было более понятно. Мне на самом деле сложно объяснить, если вы можете помочь, буду очень благодарен. Дело в том, что таких периодов много, а количество слов - не 20, как в примере, а несколько тысяч, и вручную это сравнить невозможно.

В итоге нужно получить таблицу, где в одном столбце - список слов за каждый период, а в последующих их значения за каждый отдельно взятый период.

Автор - Devkeyz
Дата добавления - 05.07.2016 в 13:00
китин Дата: Вторник, 05.07.2016, 13:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
файла нетути


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениефайла нетути

Автор - китин
Дата добавления - 05.07.2016 в 13:02
Devkeyz Дата: Вторник, 05.07.2016, 13:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
файла нетути

Прошу прощения, добавил.
 
Ответить
Сообщение
файла нетути

Прошу прощения, добавил.

Автор - Devkeyz
Дата добавления - 05.07.2016 в 13:05
китин Дата: Вторник, 05.07.2016, 13:40 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$D$21;ПОИСКПОЗ(A2;$D$2:$D$21;0));"НЕТ В СПИСКЕ")
К сообщению приложен файл: 7955974.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$D$21;ПОИСКПОЗ(A2;$D$2:$D$21;0));"НЕТ В СПИСКЕ")

Автор - китин
Дата добавления - 05.07.2016 в 13:40
Devkeyz Дата: Вторник, 05.07.2016, 14:02 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
так надо?

Немного не верно объяснил, скорее всего. Вот файл, сверху входящие данные, снизу подписано, как должно получится на выходе. То есть, правый блок сортируется по Продукту, чтобы продукт из правого блока был в одной строке с левым, но значения не должны подставлятся с левого блока, а сохранятся и перемещаться вместе с продуктом из правого, а те продукты, которые отсутствуют - оставаться внизу. Файл прилагаю.
К сообщению приложен файл: 5875686.xlsx(10Kb)
 
Ответить
Сообщение
так надо?

Немного не верно объяснил, скорее всего. Вот файл, сверху входящие данные, снизу подписано, как должно получится на выходе. То есть, правый блок сортируется по Продукту, чтобы продукт из правого блока был в одной строке с левым, но значения не должны подставлятся с левого блока, а сохранятся и перемещаться вместе с продуктом из правого, а те продукты, которые отсутствуют - оставаться внизу. Файл прилагаю.

Автор - Devkeyz
Дата добавления - 05.07.2016 в 14:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух и более столбцов с сортировкой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!