Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Массив, поиск из списка, подстановка значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Массив, поиск из списка, подстановка значения (Формулы/Formulas)
Массив, поиск из списка, подстановка значения
Shadovi4 Дата: Вторник, 05.07.2016, 13:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Приветствую знатоки!
Задача: в ячейку С3 подставляется значение из столбца L, при пересечении со строкой в которой есть значение "Итого:", при условии, что значение в B2 соответствует значению из столбца E

Пробовал через формулу массива, но чет не рОбит:
Код
{=ЕСЛИОШИБКА(ИНДЕКС($L$12:$L$1759;ПОИСКПОЗ(ТЕКСТ($B3;"\*0000\ 000000\*")&ПРАВБ(C$2;2);ПРОСМОТР(СТРОКА(G$12:G$1759);СТРОКА(G$12:G$1759)/($L$12:$L$1759="");$G$12:$G$1759)&$G$12:$G$1759;));"")}
К сообщению приложен файл: svodka.xlsx(9Kb)
 
Ответить
СообщениеПриветствую знатоки!
Задача: в ячейку С3 подставляется значение из столбца L, при пересечении со строкой в которой есть значение "Итого:", при условии, что значение в B2 соответствует значению из столбца E

Пробовал через формулу массива, но чет не рОбит:
Код
{=ЕСЛИОШИБКА(ИНДЕКС($L$12:$L$1759;ПОИСКПОЗ(ТЕКСТ($B3;"\*0000\ 000000\*")&ПРАВБ(C$2;2);ПРОСМОТР(СТРОКА(G$12:G$1759);СТРОКА(G$12:G$1759)/($L$12:$L$1759="");$G$12:$G$1759)&$G$12:$G$1759;));"")}

Автор - Shadovi4
Дата добавления - 05.07.2016 в 13:29
abtextime Дата: Вторник, 05.07.2016, 14:05 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
посмотрите такой вариант

[vba]
Код
Public Function MySum(S As String, R As Range) As Double

RCC = R.Columns.Count

For i = 1 To R.Rows.Count
If R.Cells(i, 1) <> "" Then SS = R.Cells(i, 1) & ""
If Trim(R.Cells(i, 3)) = "Итого:" And SS = S Then MySum = MySum + R.Cells(i, RCC)
Next i

End Function

[/vba]
К сообщению приложен файл: svodka-1-.xlsm(15Kb)
 
Ответить
Сообщениепосмотрите такой вариант

[vba]
Код
Public Function MySum(S As String, R As Range) As Double

RCC = R.Columns.Count

For i = 1 To R.Rows.Count
If R.Cells(i, 1) <> "" Then SS = R.Cells(i, 1) & ""
If Trim(R.Cells(i, 3)) = "Итого:" And SS = S Then MySum = MySum + R.Cells(i, RCC)
Next i

End Function

[/vba]

Автор - abtextime
Дата добавления - 05.07.2016 в 14:05
jakim Дата: Вторник, 05.07.2016, 14:51 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Добавил одну стрчку для последнего кода.
Далее смотрите приложение.
К сообщению приложен файл: 4044984.xlsx(9Kb)
 
Ответить
Сообщение
Добавил одну стрчку для последнего кода.
Далее смотрите приложение.

Автор - jakim
Дата добавления - 05.07.2016 в 14:51
krosav4ig Дата: Вторник, 05.07.2016, 15:05 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
для C3 немассивная формула
Код
=ИНДЕКС(L:L;ЕСЛИОШИБКА(ПОИСКПОЗ(B4;E:E;)-1;ПРОСМОТР("яяя";G:G;СТРОКА(G:G))))


(_)Õvõ(_)
 
Ответить
Сообщениедля C3 немассивная формула
Код
=ИНДЕКС(L:L;ЕСЛИОШИБКА(ПОИСКПОЗ(B4;E:E;)-1;ПРОСМОТР("яяя";G:G;СТРОКА(G:G))))

Автор - krosav4ig
Дата добавления - 05.07.2016 в 15:05
_Boroda_ Дата: Вторник, 05.07.2016, 22:00 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
На случай, если значения в столбце НЕ в том же порядке, как в Е
Тоже немассивная
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА(E$12:E$99);СТРОКА(E$12:E$99)/(E$12:E$99>0);E$12:E$99)=B3)*L$12:L$99)/2

или
Код
=ИНДЕКС(L:L;ПОИСКПОЗ("Итого:";G$999:ИНДЕКС(G:G;ПОИСКПОЗ(B3;E:E;));)+ПОИСКПОЗ(B3;E:E;)-1)
К сообщению приложен файл: vodka_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНа случай, если значения в столбце НЕ в том же порядке, как в Е
Тоже немассивная
Код
=СУММПРОИЗВ((ПРОСМОТР(СТРОКА(E$12:E$99);СТРОКА(E$12:E$99)/(E$12:E$99>0);E$12:E$99)=B3)*L$12:L$99)/2

или
Код
=ИНДЕКС(L:L;ПОИСКПОЗ("Итого:";G$999:ИНДЕКС(G:G;ПОИСКПОЗ(B3;E:E;));)+ПОИСКПОЗ(B3;E:E;)-1)

Автор - _Boroda_
Дата добавления - 05.07.2016 в 22:00
krosav4ig Дата: Вторник, 05.07.2016, 22:39 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
и еще массивная формула
Код
=ВПР("Итого:";ЕСЛИ(СТРОКА(G$12:G$26)>=ПОИСКПОЗ(B3;E:E;);$G$12:$L$26);6;)


(_)Õvõ(_)
 
Ответить
Сообщениеи еще массивная формула
Код
=ВПР("Итого:";ЕСЛИ(СТРОКА(G$12:G$26)>=ПОИСКПОЗ(B3;E:E;);$G$12:$L$26);6;)

Автор - krosav4ig
Дата добавления - 05.07.2016 в 22:39
Shadovi4 Дата: Среда, 06.07.2016, 13:21 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем спасибо, из 6 вариантов 5 рабочих. Проблема решена. Единственно я все таки не понял, может кто подскажет в чем косяк или маны курить?)
 
Ответить
СообщениеВсем спасибо, из 6 вариантов 5 рабочих. Проблема решена. Единственно я все таки не понял, может кто подскажет в чем косяк или маны курить?)

Автор - Shadovi4
Дата добавления - 06.07.2016 в 13:21
китин Дата: Среда, 06.07.2016, 13:40 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
из 6 вариантов 5 рабочих

и что же это за нерабочий? пример в студию
К сообщению приложен файл: 3169759.gif(6Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
из 6 вариантов 5 рабочих

и что же это за нерабочий? пример в студию

Автор - китин
Дата добавления - 06.07.2016 в 13:40
Shadovi4 Дата: Среда, 06.07.2016, 16:45 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
и что же это за нерабочий? пример в студию

Показалось, что через функцию не работает как надо, показалось...
 
Ответить
Сообщение
и что же это за нерабочий? пример в студию

Показалось, что через функцию не работает как надо, показалось...

Автор - Shadovi4
Дата добавления - 06.07.2016 в 16:45
abtextime Дата: Среда, 06.07.2016, 17:33 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Показалось, что через функцию не работает

Проверил еще раз. На мой взгляд, работает правильно. Результаты в ячейках C3:С6 точно такие же, как у других

454,4002
464,4001
504,4002
500

 
Ответить
Сообщение
Показалось, что через функцию не работает

Проверил еще раз. На мой взгляд, работает правильно. Результаты в ячейках C3:С6 точно такие же, как у других

454,4002
464,4001
504,4002
500


Автор - abtextime
Дата добавления - 06.07.2016 в 17:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Массив, поиск из списка, подстановка значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!